aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/py-bittorrent-devel
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-12-11 02:51:16 +0800
committerlioux <lioux@FreeBSD.org>2004-12-11 02:51:16 +0800
commit1605f6b3401185aa95ea3750b48501db7b167ccb (patch)
tree4db4afad526abc65f3325b7e60352b206abae037 /net-p2p/py-bittorrent-devel
parent1a9e63fd3356ffa6dd9830ee7abf7082c67ffd86 (diff)
downloadfreebsd-ports-gnome-1605f6b3401185aa95ea3750b48501db7b167ccb.tar.gz
freebsd-ports-gnome-1605f6b3401185aa95ea3750b48501db7b167ccb.tar.zst
freebsd-ports-gnome-1605f6b3401185aa95ea3750b48501db7b167ccb.zip
o A better fix for the python 2.4 issue: there are still some minor
adjustments required but the port is quite useable again o Bump PORTREVISION PR: 74883 Submitted by: Jonathan Lennox <lennox@cs.columbia.edu> Reviewed by: Randy Pratt <rpratt1950@earthlink.net>
Diffstat (limited to 'net-p2p/py-bittorrent-devel')
-rw-r--r--net-p2p/py-bittorrent-devel/Makefile6
-rw-r--r--net-p2p/py-bittorrent-devel/files/patch-BitTorrent::zurllib.py18
2 files changed, 21 insertions, 3 deletions
diff --git a/net-p2p/py-bittorrent-devel/Makefile b/net-p2p/py-bittorrent-devel/Makefile
index f3ad85dea2a2..22549d3887e8 100644
--- a/net-p2p/py-bittorrent-devel/Makefile
+++ b/net-p2p/py-bittorrent-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 3.4.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -44,9 +44,9 @@ pre-everything::
@${ECHO_MSG} '===> Define WITHOUT_GUI to disable GUI installation'
.endif
-post-extract:
+#post-extract:
# patch to work with python 2.4
- @${CP} ${FILESDIR}/zurllib.py ${WRKSRC}/BitTorrent
+# @${CP} ${FILESDIR}/zurllib.py ${WRKSRC}/BitTorrent
post-patch:
@${FIND} ${WRKSRC} -type f | \
diff --git a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::zurllib.py b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::zurllib.py
new file mode 100644
index 000000000000..deca5e24f028
--- /dev/null
+++ b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::zurllib.py
@@ -0,0 +1,18 @@
+--- BitTorrent/zurllib.py.orig Thu Dec 9 10:36:43 2004
++++ BitTorrent/zurllib.py Thu Dec 9 10:38:19 2004
+@@ -35,7 +35,14 @@
+ if DEBUG:
+ pprint.pprint(headers.dict)
+ url = fp.url
+- return addinfourldecompress(fp, headers, url)
++ resp = addinfourldecompress(fp, headers, url)
++ # As of Python 2.4 http_open response also has 'code' and 'msg'
++ # members, and HTTPErrorProcessor breaks if they don't exist.
++ if 'code' in dir(fp):
++ resp.code = fp.code
++ if 'msg' in dir(fp):
++ resp.msg = fp.msg
++ return resp
+
+
+ class addinfourldecompress(addinfourl):