aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/py-libtorrent-rasterbar
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-10-07 04:31:52 +0800
committeryuri <yuri@FreeBSD.org>2018-10-07 04:31:52 +0800
commitfc2f6e1588aa5eded3de7949b55461ef81e4f398 (patch)
tree75d57589c9eac7b5766c31d243717ad159925530 /net-p2p/py-libtorrent-rasterbar
parent243a2450026d6e6fa75a30b57626d743a506e15c (diff)
downloadfreebsd-ports-gnome-fc2f6e1588aa5eded3de7949b55461ef81e4f398.tar.gz
freebsd-ports-gnome-fc2f6e1588aa5eded3de7949b55461ef81e4f398.tar.zst
freebsd-ports-gnome-fc2f6e1588aa5eded3de7949b55461ef81e4f398.zip
Move net-p2p/libtorrent-rasterbar-python -> net-p2p/py-libtorrent-rasterbar
It now builds for all versions of python.
Diffstat (limited to 'net-p2p/py-libtorrent-rasterbar')
-rw-r--r--net-p2p/py-libtorrent-rasterbar/Makefile28
-rw-r--r--net-p2p/py-libtorrent-rasterbar/distinfo3
-rw-r--r--net-p2p/py-libtorrent-rasterbar/files/patch-setup.py17
-rw-r--r--net-p2p/py-libtorrent-rasterbar/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/net-p2p/py-libtorrent-rasterbar/Makefile b/net-p2p/py-libtorrent-rasterbar/Makefile
new file mode 100644
index 000000000000..d11fe962d4c7
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/Makefile
@@ -0,0 +1,28 @@
+# Created by: Doug Barton <dougb@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libtorrent-rasterbar
+DISTVERSION= 1.1.10
+CATEGORIES= net-p2p ipv6 python
+MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python bindings for libtorrent-rasterbar
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/../../COPYING
+
+LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
+ ${PY_BOOST}
+
+USES= localbase python
+USE_PYTHON= distutils autoplist
+
+WRKSRC_SUBDIR= bindings/python
+
+# ensure python paths are correctly identified
+CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+ PYTHON_VERSION="${PYTHON_VERSION}"
+
+.include <bsd.port.mk>
diff --git a/net-p2p/py-libtorrent-rasterbar/distinfo b/net-p2p/py-libtorrent-rasterbar/distinfo
new file mode 100644
index 000000000000..2bb772897d2a
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538852302
+SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
+SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542
diff --git a/net-p2p/py-libtorrent-rasterbar/files/patch-setup.py b/net-p2p/py-libtorrent-rasterbar/files/patch-setup.py
new file mode 100644
index 000000000000..d7365e7de3e1
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/files/patch-setup.py
@@ -0,0 +1,17 @@
+--- setup.py.orig 2018-10-06 18:51:57 UTC
++++ setup.py
+@@ -131,11 +131,11 @@ else:
+ source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
+ source_list = [os.path.abspath(os.path.join(os.path.dirname(__file__), "src", s)) for s in source_list if s.endswith(".cpp")]
+
+- if extra_cmd:
++ if True or extra_cmd:
+ flags = flags_parser()
+ # ldflags must be parsed first to ensure the correct library search path order
+- extra_link = flags.parse(ldflags)
+- extra_compile = flags.parse(extra_cmd)
++ extra_link = flags.parse(os.environ['LDFLAGS'])
++ extra_compile = flags.parse(os.environ['CFLAGS'])
+
+ # for some reason distutils uses the CC environment variable to determine
+ # the compiler to use for C++
diff --git a/net-p2p/py-libtorrent-rasterbar/pkg-descr b/net-p2p/py-libtorrent-rasterbar/pkg-descr
new file mode 100644
index 000000000000..9d6a02d83644
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/pkg-descr
@@ -0,0 +1,4 @@
+The python vinfing of libtorrent, an open source C++ library implementing the
+BitTorrent protocol.
+
+WWW: http://libtorrent.org/