aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/py-tremc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-12-31 04:23:12 +0800
committerswills <swills@FreeBSD.org>2017-12-31 04:23:12 +0800
commit40ea95c38b8db3a5f0015a391e93ef1c49064b71 (patch)
tree4d43ea06e8c8956885365f308a3ecfce774c4d67 /net-p2p/py-tremc
parent8252e15f87e95c3bb4e32ed5c5d5d5489862e13d (diff)
downloadfreebsd-ports-gnome-40ea95c38b8db3a5f0015a391e93ef1c49064b71.tar.gz
freebsd-ports-gnome-40ea95c38b8db3a5f0015a391e93ef1c49064b71.tar.zst
freebsd-ports-gnome-40ea95c38b8db3a5f0015a391e93ef1c49064b71.zip
net-p2p/py-tremc: create port
Curses interface for transmission. Python3 fork of the no longer maintained transmission-remote-cli. Some extra modifications have been included and development will follow the original project as much as possible. WWW: https://github.com/louipc/tremc Submitted by: lbdm@privacychain.ch Differential Revision: https://reviews.freebsd.org/D13618
Diffstat (limited to 'net-p2p/py-tremc')
-rw-r--r--net-p2p/py-tremc/Makefile44
-rw-r--r--net-p2p/py-tremc/distinfo3
-rw-r--r--net-p2p/py-tremc/files/pkg-message.in10
-rw-r--r--net-p2p/py-tremc/pkg-descr7
4 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/py-tremc/Makefile b/net-p2p/py-tremc/Makefile
new file mode 100644
index 000000000000..9a8bfea3175b
--- /dev/null
+++ b/net-p2p/py-tremc/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= tremc
+DISTVERSION= g20171202
+CATEGORIES= net-p2p python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lbdm@privacychain.ch
+COMMENT= Console client for the BitTorrent client Transmission
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python:3.4+ shebangfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= louipc
+GH_TAGNAME= e06d08d
+
+NO_ARCH= yes
+NO_BUILD= yes
+SHEBANG_FILES= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz \
+ share/bash-completion/completions/${PORTNAME}
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= GEOIP XEROX
+
+XEROX_DESC= Copy magnet links to the system clipboard
+
+GEOIP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/GeoIP.so:net/py-GeoIP@${PY_FLAVOR}
+XEROX_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xerox/__init__.py:devel/py-xerox@${PY_FLAVOR}
+
+do-install:
+
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/share/bash-completion/completions
+ ${INSTALL_DATA} ${WRKSRC}/completion/bash/transmission-remote-cli-bash-completion.sh \
+ ${STAGEDIR}${PREFIX}/share/bash-completion/completions/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/py-tremc/distinfo b/net-p2p/py-tremc/distinfo
new file mode 100644
index 000000000000..a0270cc8c049
--- /dev/null
+++ b/net-p2p/py-tremc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514265585
+SHA256 (louipc-tremc-g20171202-e06d08d_GH0.tar.gz) = 4559922bc047c4d95f5c2936dd844f2fd4614fef76028beb441553c68bef2ebf
+SIZE (louipc-tremc-g20171202-e06d08d_GH0.tar.gz) = 255734
diff --git a/net-p2p/py-tremc/files/pkg-message.in b/net-p2p/py-tremc/files/pkg-message.in
new file mode 100644
index 000000000000..b6b10ec28a4c
--- /dev/null
+++ b/net-p2p/py-tremc/files/pkg-message.in
@@ -0,0 +1,10 @@
+###################################################################
+
+Please do run "tremc --create-config" to create the configuration
+file with default values.
+
+NOTE: A config file won't be created unless you provide this
+option at least once. After that, it is rewritten whenever tremc
+exits.
+
+###################################################################
diff --git a/net-p2p/py-tremc/pkg-descr b/net-p2p/py-tremc/pkg-descr
new file mode 100644
index 000000000000..6ca6c7e39daa
--- /dev/null
+++ b/net-p2p/py-tremc/pkg-descr
@@ -0,0 +1,7 @@
+Curses interface for transmission.
+
+Python3 fork of the no longer maintained transmission-remote-cli. Some
+extra modifications have been included and development will follow the
+original project as much as possible.
+
+WWW: https://github.com/louipc/tremc