aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/pyslsk/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-02-16 04:27:40 +0800
committerarved <arved@FreeBSD.org>2003-02-16 04:27:40 +0800
commit8a317f7890361ef9c7af8495829ebb21094cfc29 (patch)
tree060f3236e7123d0bce6a45173c38fdca2d59cfd8 /net-p2p/pyslsk/Makefile
parentd63c2bc864773f45043145c00e2edc5ff7bbad74 (diff)
downloadfreebsd-ports-gnome-8a317f7890361ef9c7af8495829ebb21094cfc29.tar.gz
freebsd-ports-gnome-8a317f7890361ef9c7af8495829ebb21094cfc29.tar.zst
freebsd-ports-gnome-8a317f7890361ef9c7af8495829ebb21094cfc29.zip
Add pyslsk, a python Client for the SoulSeek filesharing system
PR: 47290 Submitted by: Stefan Ehmann <shoesoft@gmx.net>
Diffstat (limited to 'net-p2p/pyslsk/Makefile')
-rw-r--r--net-p2p/pyslsk/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-p2p/pyslsk/Makefile b/net-p2p/pyslsk/Makefile
new file mode 100644
index 000000000000..2b821ffefc4d
--- /dev/null
+++ b/net-p2p/pyslsk/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pyslsk
+# Date created: 2003-01-20
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyslsk
+PORTVERSION= 0.4.11
+CATEGORIES= net
+MASTER_SITES= http://www.sensi.org/~ak/pyslsk/ \
+ http://stud4.tuwien.ac.at/~e0125637/
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= "Client for SoulSeek filesharing system"
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>