aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-13 08:11:45 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-13 08:11:45 +0800
commit1e6d2a26fd5054f1e975fc8a037db6b7b4007bc1 (patch)
tree78c00db8b2cad37a368789cfb612fe983597d4a8 /net-p2p/qbittorrent
parent9a35221b7b9db6924e019947ba56bb1e4b5607f9 (diff)
downloadfreebsd-ports-gnome-1e6d2a26fd5054f1e975fc8a037db6b7b4007bc1.tar.gz
freebsd-ports-gnome-1e6d2a26fd5054f1e975fc8a037db6b7b4007bc1.tar.zst
freebsd-ports-gnome-1e6d2a26fd5054f1e975fc8a037db6b7b4007bc1.zip
- Update to 3.1.9, Announce message:
BUGFIX: Fix nox build. Closes #1368 (bob23450) BUGFIX: Fix build with libtorrent 0.15.x (sledgehammer999) BUGFIX: Fix missing percentage signs. Closes #1392. (sledgehammer999) BUGFIX: Fix queue sorting order. (alfrix) BUGFIX: Fix build using qt < 4.7 Closes #1385. (Evgeny Lensky) BUGFIX: Fix autoupdater. Send our user-agent to sourceforge.net (sledgehammer999) FEATURE: Add button for links in toolbar (alfrix) - Add DEBUG Option - Install conditional DOCS, fix conflict with SLAVE Port - Remove obsolete patch, changed by upstream
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile11
-rw-r--r--net-p2p/qbittorrent/distinfo4
-rw-r--r--net-p2p/qbittorrent/files/patch-src__src.pro42
3 files changed, 9 insertions, 48 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index a2105e655b10..31dd1e8e009c 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.1.8
-PORTREVISION?= 1
+PORTVERSION= 3.1.9
+PORTREVISION?= 0
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
@@ -32,8 +32,9 @@ OPTIONS_DEFINE= DBUS
PORTDOCS= AUTHORS Changelog README TODO
-OPTIONS_DEFINE= DOCS DBUS
+OPTIONS_DEFINE= DEBUG DOCS DBUS
+DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
.include <bsd.port.options.mk>
@@ -45,15 +46,17 @@ USE_QT4+= dbus
do-configure:
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "no"
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
- ./configure --prefix=${PREFIX} --enable-debug
+ ./configure --prefix=${PREFIX}
.else
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
./configure --prefix=${PREFIX} --disable-gui
.endif
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+.endif
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "no"
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index f67f020eabb3..2d8f1ac0115f 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qbittorrent-3.1.8.tar.gz) = 947c643c37318254bbd2cb7de6f1abdf752b1c114b2c68c414a2c164371df571
-SIZE (qbittorrent-3.1.8.tar.gz) = 3920680
+SHA256 (qbittorrent-3.1.9.tar.gz) = bf1c4a071ab6aa025de47020055ac19b51de920c3d386bbac89ccd4e588e6695
+SIZE (qbittorrent-3.1.9.tar.gz) = 3923413
diff --git a/net-p2p/qbittorrent/files/patch-src__src.pro b/net-p2p/qbittorrent/files/patch-src__src.pro
deleted file mode 100644
index 76df654419d9..000000000000
--- a/net-p2p/qbittorrent/files/patch-src__src.pro
+++ /dev/null
@@ -1,42 +0,0 @@
---- ./src/src.pro.orig 2014-02-02 21:50:54.000000000 +0100
-+++ ./src/src.pro 2014-02-06 23:30:26.000000000 +0100
-@@ -107,8 +107,7 @@
- scannedfoldersmodel.h \
- qinisettings.h \
- smtp.h \
-- dnsupdater.h \
-- messageboxraised.h
-+ dnsupdater.h
-
-
- SOURCES += main.cpp \
-@@ -117,8 +116,7 @@
- misc.cpp \
- fs_utils.cpp \
- smtp.cpp \
-- dnsupdater.cpp \
-- messageboxraised.cpp
-+ dnsupdater.cpp
-
- nox {
- HEADERS += headlessloader.h
-@@ -152,7 +150,8 @@
- loglistwidget.h \
- addnewtorrentdialog.h \
- autoexpandabledialog.h \
-- statsdialog.h
-+ statsdialog.h \
-+ messageboxraised.h
-
- SOURCES += mainwindow.cpp \
- ico.cpp \
-@@ -171,7 +170,8 @@
- loglistwidget.cpp \
- addnewtorrentdialog.cpp \
- autoexpandabledialog.cpp \
-- statsdialog.cpp
-+ statsdialog.cpp \
-+ messageboxraised.cpp
-
- win32 {
- HEADERS += programupdater.h