aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/qtorrent
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-04-21 05:55:37 +0800
committerlofi <lofi@FreeBSD.org>2006-04-21 05:55:37 +0800
commit3ca6a31c586fea7dd3bcbc2910ca80071f8c4928 (patch)
tree3631cb06d85e013becf0fa9c8291be5bc20610fa /net-p2p/qtorrent
parent5f79e7b1baf730aa009aa98fe193d62335f0cc0d (diff)
downloadfreebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.tar.gz
freebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.tar.zst
freebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.zip
Ports using Qt without setting USE_QT_VER need environment fixups.
Diffstat (limited to 'net-p2p/qtorrent')
-rw-r--r--net-p2p/qtorrent/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-p2p/qtorrent/Makefile b/net-p2p/qtorrent/Makefile
index 065f46c32f12..aea50c533379 100644
--- a/net-p2p/qtorrent/Makefile
+++ b/net-p2p/qtorrent/Makefile
@@ -22,6 +22,12 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+.if defined(PACKAGE_BUILDING)
+TMPDIR?= /tmp
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+.endif
+
pre-everything::
@${ECHO_MSG} "===>"
@${ECHO_MSG} "===> For qtorrent to work you need to compile"
@@ -30,7 +36,7 @@ pre-everything::
post-patch:
.for i in torrentsettings torrentwindow
- @${LOCALBASE}/bin/pyuic -o ${WRKSRC}/pyqtorrent/${i}.py ${WRKSRC}/pyqtorrent/${i}.ui
+ @${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/pyuic -o ${WRKSRC}/pyqtorrent/${i}.py ${WRKSRC}/pyqtorrent/${i}.ui
.endfor
.include <bsd.port.mk>