aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/rtorrent
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2012-07-05 16:40:32 +0800
committerflz <flz@FreeBSD.org>2012-07-05 16:40:32 +0800
commite763c72fa384fd8656549b15809a6a028c490f1a (patch)
tree4af2b2ccf67145ccf511e9232972366ba72c3d70 /net-p2p/rtorrent
parent36fb670591064208228e551cbc2529a40224741a (diff)
downloadfreebsd-ports-gnome-e763c72fa384fd8656549b15809a6a028c490f1a.tar.gz
freebsd-ports-gnome-e763c72fa384fd8656549b15809a6a028c490f1a.tar.zst
freebsd-ports-gnome-e763c72fa384fd8656549b15809a6a028c490f1a.zip
Update net-p2p/rtorrent to 0.9.2.
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/Makefile8
-rw-r--r--net-p2p/rtorrent/distinfo4
-rw-r--r--net-p2p/rtorrent/files/patch-src_thread_base.cc37
3 files changed, 6 insertions, 43 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index ebc34a81ed11..f02df262a832 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= rtorrent
-PORTVERSION?= 0.8.9
-PORTREVISION?= 1
+PORTVERSION?= 0.9.2
+PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -16,8 +16,8 @@ MASTER_SITE_SUBDIR= flz/rtorrent/
MAINTAINER?= flz@FreeBSD.org
COMMENT?= BitTorrent Client written in C++
-BUILD_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
+BUILD_DEPENDS?= libtorrent=0.13.2:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS?= libtorrent=0.13.2:${PORTSDIR}/net-p2p/libtorrent
LIB_DEPENDS?= curl.6:${PORTSDIR}/ftp/curl
CONFLICTS?= rtorrent-devel-[0-9]*
diff --git a/net-p2p/rtorrent/distinfo b/net-p2p/rtorrent/distinfo
index 822f267d5929..90858d117abb 100644
--- a/net-p2p/rtorrent/distinfo
+++ b/net-p2p/rtorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rtorrent-0.8.9.tar.gz) = cca70eb36a0c176bbd6fdb3afe2bc9f163fa4c9377fc33bc29689dec60cf6d84
-SIZE (rtorrent-0.8.9.tar.gz) = 570904
+SHA256 (rtorrent-0.9.2.tar.gz) = 5c8f8c780bee376afce3c1cde2f5ecb928f40bac23b2b8171deed5cf3c888c3d
+SIZE (rtorrent-0.9.2.tar.gz) = 591837
diff --git a/net-p2p/rtorrent/files/patch-src_thread_base.cc b/net-p2p/rtorrent/files/patch-src_thread_base.cc
deleted file mode 100644
index d13727326024..000000000000
--- a/net-p2p/rtorrent/files/patch-src_thread_base.cc
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/thread_base.cc.orig 2011-04-05 11:26:11.000000000 +0100
-+++ src/thread_base.cc 2011-06-09 18:59:41.375670521 +0100
-@@ -44,4 +44,5 @@
- #include <iostream>
- #include <signal.h>
-+#include <unistd.h>
- #include <rak/error_number.h>
- #include <torrent/exceptions.h>
-@@ -61,7 +61,7 @@
-
- static const unsigned int max_size = 32;
-
-- thread_queue_hack() { std::memset(this, 0, sizeof(thread_queue_hack)); }
-+ thread_queue_hack() : m_lock(0) { std::memset(this, 0, sizeof(thread_queue_hack)); }
-
- void lock() { while (!__sync_bool_compare_and_swap(&m_lock, 0, 1)) usleep(0); }
- void unlock() { __sync_bool_compare_and_swap(&m_lock, 1, 0); }
-@@ -202,9 +203,14 @@
- void
- ThreadBase::interrupt_main_polling() {
-- do {
-+ int sleep_length = 0;
-+
-+ while (ThreadBase::is_main_polling()) {
-+ pthread_kill(main_thread->m_thread, SIGUSR1);
-+
- if (!ThreadBase::is_main_polling())
- return;
--
-- pthread_kill(main_thread->m_thread, SIGUSR1);
-- } while (1);
--}
-+
-+ usleep(sleep_length);
-+ sleep_length = std::min(sleep_length + 50, 1000);
-+ }
-+}