aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/transmission-cli/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-09-14 04:53:52 +0800
committermarino <marino@FreeBSD.org>2013-09-14 04:53:52 +0800
commite79d7506fab69aa100115d500d1dd092e7103740 (patch)
tree95efc4152c29a845388b11f8d44dd64c86be6d7c /net-p2p/transmission-cli/Makefile
parent7ee9fd2950dea99a2cfa29ce1d54e347a903b99b (diff)
downloadfreebsd-ports-gnome-e79d7506fab69aa100115d500d1dd092e7103740.tar.gz
freebsd-ports-gnome-e79d7506fab69aa100115d500d1dd092e7103740.tar.zst
freebsd-ports-gnome-e79d7506fab69aa100115d500d1dd092e7103740.zip
net-p2p/transmission-cli: Fix USES and iconv support
This is a master port for transmission-qt and transmission-gtk. To honor any USES definition of the slave ports, the USES here has to be defined with +=. Additionally, it links with iconv so that support was added while I'm here. Approved by: crees (maintainer)
Diffstat (limited to 'net-p2p/transmission-cli/Makefile')
-rw-r--r--net-p2p/transmission-cli/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 985ae1039e36..0598dc6f78e4 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -35,12 +35,12 @@ GEN_LIB_DEPENDS=curl:${PORTSDIR}/ftp/curl \
event-2.0.6:${PORTSDIR}/devel/libevent2
GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
-USE_GMAKE= yes
-USES= pkgconfig
+# This is master port of transmission-*, so don't override USES definition
+USES+= gmake pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS=--with-zlib=/usr \
${EXTRA_CONF_ARGS}
EXTRA_CONF_ARGS?=--enable-cli \