aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/transmission-qt4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:11 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:11 +0800
commit6a8fa025703756528837f1ccf220676f5c3848f0 (patch)
tree919f256f5d4152f9ba2438b4a3cc82a91d4707c6 /net-p2p/transmission-qt4
parent612bc3c9c8698b6a8cdbb965267678a0ac829218 (diff)
downloadfreebsd-ports-gnome-6a8fa025703756528837f1ccf220676f5c3848f0.tar.gz
freebsd-ports-gnome-6a8fa025703756528837f1ccf220676f5c3848f0.tar.zst
freebsd-ports-gnome-6a8fa025703756528837f1ccf220676f5c3848f0.zip
- Pass QMAKE_ARGS to qmake
Approved by: portmgr (blanket approval)
Diffstat (limited to 'net-p2p/transmission-qt4')
-rw-r--r--net-p2p/transmission-qt4/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
index 4c1c8b587b35..b5d2fef54267 100644
--- a/net-p2p/transmission-qt4/Makefile
+++ b/net-p2p/transmission-qt4/Makefile
@@ -17,7 +17,7 @@ SLAVEPORT= qt4
QT_NONSTANDARD= yes
USE_QT4= moc_build qmake_build rcc_build uic_build gui dbus network
USE_GNOME= desktopfileutils
-QMAKEFLAGS= QMAKE_LFLAGS="-lcrypto -L${LOCALBASE}/lib ${ICONV_LIB}"
+LDFLAGS+= -lcrypto
EXTRA_CONF_ARGS=--disable-cli \
--disable-daemon \
@@ -33,7 +33,7 @@ post-patch: general-patch
NO_STAGE= yes
post-build:
- @(cd ${WRKSRC}/qt ; ${QMAKE} ${QMAKEFLAGS} qtr.pro ; ${GMAKE})
+ @(cd ${WRKSRC}/qt ; ${QMAKE} ${QMAKE_ARGS} qtr.pro ; ${GMAKE})
do-install:
@(cd ${WRKSRC}/qt ; ${SETENV} INSTALL_ROOT=${PREFIX} ${MAKE} install)