aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/transmission/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-10-21 03:11:03 +0800
committermezz <mezz@FreeBSD.org>2005-10-21 03:11:03 +0800
commit495c762234dbda239656d642c7af2e53a58ae588 (patch)
tree0c6ed551f298c1c713d4658bf0830d2b447524fe /net-p2p/transmission/Makefile
parenta1fa88c9076a2665ef1a101cc09e221e50fd181e (diff)
downloadfreebsd-ports-gnome-495c762234dbda239656d642c7af2e53a58ae588.tar.gz
freebsd-ports-gnome-495c762234dbda239656d642c7af2e53a58ae588.tar.zst
freebsd-ports-gnome-495c762234dbda239656d642c7af2e53a58ae588.zip
Update to 0.3, add WITHOUT_OPENSSL knob. I have created a patch for configure
to add a few new flags. If it causes any trouble, I will remove it. * --help * --disable-openssl (autocheck: enable by default) * --openssl-include=PATH * --openssl-lib=PATH * Add CC and CFLAGS in configure for anyone can edit it. I have submitted this patch to the author. http://people.freebsd.org/~mezz/diff/configure.diff I believe that it can be done in Jamfile instead configure, I will have to learn more abot Jamfile later for what features and what it can do. If anyone know any better way or so, let me know.
Diffstat (limited to 'net-p2p/transmission/Makefile')
-rw-r--r--net-p2p/transmission/Makefile35
1 files changed, 26 insertions, 9 deletions
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 8bcfe28a1370..1820fa3852dd 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= transmission
-PORTVERSION= 0.2.20051009
+PORTVERSION= 0.3
CATEGORIES= net
-#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= mezz
+MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
+#MASTER_SITES= ${MASTER_SITE_LOCAL}
+#MASTER_SITE_SUBDIR= mezz
DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
@@ -18,9 +18,8 @@ COMMENT= A free BitTorrent client written from scratch in C
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
-USE_OPENSSL= yes
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
USE_GETOPT_LONG=yes
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude macosx \
@@ -29,12 +28,30 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude macosx \
PLIST_FILES= bin/transmissioncli
PORTDOCS= AUTHORS LICENSE NEWS README
+.if defined(WITHOUT_OPENSSL)
+CONFIGURE_ARGS+=--disable-openssl
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--openssl-include=${OPENSSLINC} \
+ --openssl-lib=${OPENSSLLIB}
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_OPENSSL)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+.if !defined(WITHOUT_OPENSSL)
+ @${ECHO_MSG} "WITHOUT_OPENSSL=yes to disable OpenSSL support, using built-in SHA1 implementation. Warning, it is a bit slower if you use this option." | /usr/bin/fmt 75 75
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|cc|${CC}|g ; \
+ s|-g |${CFLAGS} ${CPPFLAGS} ${PTHREAD_CFLAGS}|g ; \
+ s|-pthread|${PTHREAD_LIBS}|g ; \
s|$$LINKLIBS ;|${LDFLAGS} $$LINKLIBS ;|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-O3||g ; \
- s|-g |${CFLAGS} ${CPPFLAGS} ${PTHREAD_CFLAGS} |g' \
+ @${REINPLACE_CMD} -e 's|-O3||g' \
${WRKSRC}/Jamrules
# jam -dx, it will giving a verbose of build.