aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/tribler
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net-p2p/tribler
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'net-p2p/tribler')
-rw-r--r--net-p2p/tribler/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index 02f82e443ca6..7ceb72d7304e 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -15,21 +15,21 @@ LICENSE= LGPL21 MIT
LICENSE_COMB= multi
BUILD_DEPENDS= xpmtoppm:graphics/netpbm
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>0:databases/py-apsw \
- ${PYTHON_PKGNAMEPREFIX}leveldb>0:databases/py-leveldb \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}gmpy>0:math/py-gmpy \
- ${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces \
- ${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0.16.4:net-p2p/libtorrent-rasterbar-python \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>0:databases/py-apsw@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}leveldb>0:databases/py-leveldb@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gmpy>0:math/py-gmpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netifaces>0:net/py-netifaces@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0.16.4:net-p2p/libtorrent-rasterbar-python@${PY_FLAVOR} \
libsodium>0:security/libsodium \
- ${PYTHON_PKGNAMEPREFIX}m2crypto>0:security/py-m2crypto \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser \
- ${PYTHON_PKGNAMEPREFIX}cherrypy>0:www/py-cherrypy \
- ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted
+ ${PYTHON_PKGNAMEPREFIX}m2crypto>0:security/py-m2crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}feedparser>0:textproc/py-feedparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cherrypy>0:www/py-cherrypy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
NO_ARCH= yes
NO_WRKSUBDIR= yes