aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/unworkable
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-11 23:27:42 +0800
committermiwi <miwi@FreeBSD.org>2008-10-11 23:27:42 +0800
commit8b382a81577ed2783d19454caabbedb085f72c35 (patch)
treea489dfd395e7fba9c7aa20cee94a576ccb36d5db /net-p2p/unworkable
parent0086b08431b4d6e9dc4659a8d33dad0a9dcb2ebc (diff)
downloadfreebsd-ports-gnome-8b382a81577ed2783d19454caabbedb085f72c35.tar.gz
freebsd-ports-gnome-8b382a81577ed2783d19454caabbedb085f72c35.tar.zst
freebsd-ports-gnome-8b382a81577ed2783d19454caabbedb085f72c35.zip
Unworkable is a BSD-licensed BitTorrent implementation
for UNIX written from-scratch in C. It uses libevent for scalable asynchronous networking and the mmap() system call for local data access. Some of the goals of the project include (in no particular order) high code quality, efficiency, simplicity and security. WWW: http://p2presearch.com/unworkable/ PR: ports/127904 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'net-p2p/unworkable')
-rw-r--r--net-p2p/unworkable/Makefile32
-rw-r--r--net-p2p/unworkable/distinfo3
-rw-r--r--net-p2p/unworkable/pkg-descr14
3 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/unworkable/Makefile b/net-p2p/unworkable/Makefile
new file mode 100644
index 000000000000..75e2cc25a63b
--- /dev/null
+++ b/net-p2p/unworkable/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: unworkable
+# Date created: 06 Oct 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unworkable
+PORTVERSION= 0.51
+CATEGORIES= net-p2p
+MASTER_SITES= http://p2presearch.com/unworkable/dist/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Free BitTorrent Implementation
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+# crypto:${PORTDIR}/security/openssl
+
+USE_SCONS= yes
+USE_OPENSSL= yes
+SCONS_BUILDENV= ${SCONS_ENV}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/unworkable
+
+MAN1= unworkable.1
+
+.include <bsd.port.pre.mk>
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unworkable ${LOCALBASE}/bin
+ ${INSTALL_MAN} ${WRKSRC}/unworkable.1 ${LOCALBASE}/man/man1/
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/unworkable/distinfo b/net-p2p/unworkable/distinfo
new file mode 100644
index 000000000000..3b58536b2acc
--- /dev/null
+++ b/net-p2p/unworkable/distinfo
@@ -0,0 +1,3 @@
+MD5 (unworkable-0.51.tar.gz) = 9a8156f1f2a08a954f3e5d18d67a27ee
+SHA256 (unworkable-0.51.tar.gz) = 4f5f96daf1d40ebc64fe8b736da77c67d9f22f25b5c90fc235d6d00c3a74df4e
+SIZE (unworkable-0.51.tar.gz) = 71020
diff --git a/net-p2p/unworkable/pkg-descr b/net-p2p/unworkable/pkg-descr
new file mode 100644
index 000000000000..392383e64afe
--- /dev/null
+++ b/net-p2p/unworkable/pkg-descr
@@ -0,0 +1,14 @@
+Unworkable is a BSD-licensed BitTorrent implementation
+for UNIX written from-scratch in C. It uses libevent
+for scalable asynchronous networking and the mmap()
+system call for local data access. Some of the goals of
+the project include (in no particular order) high code
+quality, efficiency, simplicity and security.
+
+Unworkable is still in an early stage of development,
+and is far behind most other BitTorrent implementations.
+However, it is usable for some basic things and the
+source code is quite minimal(4,000 lines of C compared
+to rTorrent's 40,000+ of C++).
+
+WWW: http://p2presearch.com/unworkable/