aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/vuze
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /net-p2p/vuze
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net-p2p/vuze')
-rw-r--r--net-p2p/vuze/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index 35755225ef28..55c7f5d7e48c 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -30,7 +30,6 @@ INSTALLS_ICONS= yes
JARFILE= ${PORTNAME}.jar
# build classpath from BUILD_DEPENDS
-MAKE_ENV= LANG=C
CLASSPATH_JARS= ${BUILD_DEPENDS:C/:.+$//:M*.jar:T}
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE} \