aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/xmule/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-10-08 22:44:25 +0800
committerlioux <lioux@FreeBSD.org>2003-10-08 22:44:25 +0800
commitc226bdb66bd9b8023ba3737ce90ff77c0d774a22 (patch)
treee50d1a3c00da1035a74222076f8292d95ee013af /net-p2p/xmule/Makefile
parent86e9f2a063cbbab311e0097013a9f3984ea4576f (diff)
downloadfreebsd-ports-gnome-c226bdb66bd9b8023ba3737ce90ff77c0d774a22.tar.gz
freebsd-ports-gnome-c226bdb66bd9b8023ba3737ce90ff77c0d774a22.tar.zst
freebsd-ports-gnome-c226bdb66bd9b8023ba3737ce90ff77c0d774a22.zip
o Update to 1.6.0a
o Keep FORBIDDEN line since I have been unable to verify if bugs have been thoroughly fixed PR: 56618 Submitted by: YazzY <yazzy@yazzy.org>
Diffstat (limited to 'net-p2p/xmule/Makefile')
-rw-r--r--net-p2p/xmule/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index 26f420475bdd..f53668d415bd 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmule
-PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTVERSION= 1.6.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xmule
@@ -48,6 +47,14 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's| ||' \
${WRKSRC}/src/MD5Sum.cpp
+# do not install a generic named ed2k binary
+ @${REINPLACE_CMD} -E \
+ -e 's|^(bin_PROGRAMS.+)ed2k|\1|' \
+ ${WRKSRC}/src/Makefile.in
+# update documentation regarding aforementioned change
+ @${REINPLACE_CMD} -E \
+ -e 's|/usr/local/bin/ed2k|${PREFIX}/bin/${PORTNAME}-ed2k-handler|' \
+ ${WRKSRC}/ED2K-Links.HOWTO
pre-configure:
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | \
@@ -55,8 +62,16 @@ pre-configure:
${REINPLACE_CMD} -E \
-e 's!^(AUTOCONF|AUTOHEADER|AUTOMAKE|ACLOCAL).*$$!\1=${TRUE}!'
+post-build:
+# build the generic named ed2k binary
+# it will installed in an adhoc fashion
+ @cd ${BUILD_WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ed2k
+
post-install:
- @${CAT} ${PKGMESSAGE}
+# do not install a generic named ed2k binary
+# install it under a more specific name
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
+ ${PREFIX}/bin/${PORTNAME}-ed2k-handler
.include <bsd.port.pre.mk>