aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/xmule/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-01 15:39:02 +0800
committerpav <pav@FreeBSD.org>2006-12-01 15:39:02 +0800
commit92d21b3194c49cedf08339e7514171807a9c6196 (patch)
tree9c146b3b2fdea9918389f3184052481e51ccf2f9 /net-p2p/xmule/Makefile
parent977deb3eb313758a6e81aa2d1d05565d53d51455 (diff)
downloadfreebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.tar.gz
freebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.tar.zst
freebsd-ports-gnome-92d21b3194c49cedf08339e7514171807a9c6196.zip
- Use features of bsd.wx.mk, especially USE_WX
PR: ports/101613 Submitted by: alepulver
Diffstat (limited to 'net-p2p/xmule/Makefile')
-rw-r--r--net-p2p/xmule/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index f9fd3e4f2c2f..5b0df9f3e67a 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= Port of eMule eDonkey P2P client using wxWindows class library
BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_GETTEXT= yes
@@ -28,14 +27,15 @@ USE_GNOME= gnomehier \
gnomehack \
gnomeprefix
USE_GMAKE= yes
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext \
--with-cryptopp-prefix=${LOCALBASE} \
--with-gtk-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
- --enable-debug \
- --with-wx-config=${WX_CONFIG}
+ --enable-debug
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
MAKE_ARGS= -e
@@ -44,8 +44,6 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
# for debugging purposes
STRIP=
-WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.6-config
-
FILES_ATOLL_PATCH= src/Preferences.cpp \
src/otherfunctions.cpp
FILES_STDINT_PATCH= \