aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/xmule/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-04-23 04:34:52 +0800
committerlioux <lioux@FreeBSD.org>2003-04-23 04:34:52 +0800
commitb3c55a726f22eed0e5881185f488af6d5c277c0e (patch)
treeff9d759c98ea52b162f95735dca1afa25d4e0094 /net-p2p/xmule/Makefile
parentdfb0bfe63675da8b00a1ca79752a3be1b6a166d3 (diff)
downloadfreebsd-ports-gnome-b3c55a726f22eed0e5881185f488af6d5c277c0e.tar.gz
freebsd-ports-gnome-b3c55a726f22eed0e5881185f488af6d5c277c0e.tar.zst
freebsd-ports-gnome-b3c55a726f22eed0e5881185f488af6d5c277c0e.zip
o Update to 1.2.0
o Remove patches merged into the distribution o Add PKGMESSAGE warning about some POLA changes in the way LMule works
Diffstat (limited to 'net-p2p/xmule/Makefile')
-rw-r--r--net-p2p/xmule/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index bf99451acca5..58d7a36ff100 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lmule
-PORTVERSION= 1.1.13c
+PORTVERSION= 1.2.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lmule
@@ -22,8 +22,8 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_X_PREFIX= yes
USE_GNOME= gnomehier \
gnomehack \
- gnomeprefix \
- gtk12
+ gnomeprefix
+USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -47,4 +47,18 @@ pre-configure:
${REINPLACE_CMD} -E \
-e 's!^(AUTOCONF|AUTOHEADER|AUTOMAKE|ACLOCAL).*$$!\1=${TRUE}!'
-.include <bsd.port.mk>
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+# detect if wxgtk was linked against gtk1 or gtk2
+DECISION_GTK_1_OR_2!= ${WX_CONFIG} --cppflags
+
+.if (${DECISION_GTK_1_OR_2:Mgtk2} != "")
+USE_GNOME+= gtk20
+.else
+USE_GNOME+= gtk12
+.endif
+
+.include <bsd.port.post.mk>