aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/xmule
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-04-03 10:44:42 +0800
committerlioux <lioux@FreeBSD.org>2005-04-03 10:44:42 +0800
commitb52b75eb1dc73eb9f15468aadd6a368b51d8c5a6 (patch)
tree51c045f5aac2ec92767f487596946a895f980838 /net-p2p/xmule
parent6abd9892b10c1a1a2a168ca4aea33283628fe0c5 (diff)
downloadfreebsd-ports-gnome-b52b75eb1dc73eb9f15468aadd6a368b51d8c5a6.tar.gz
freebsd-ports-gnome-b52b75eb1dc73eb9f15468aadd6a368b51d8c5a6.tar.zst
freebsd-ports-gnome-b52b75eb1dc73eb9f15468aadd6a368b51d8c5a6.zip
Update to 1.10.0a based in [1]
PR: 76493 [1] Submitted by: Boris Kovalenko <boris@tagnet.ru> [1]
Diffstat (limited to 'net-p2p/xmule')
-rw-r--r--net-p2p/xmule/Makefile17
-rw-r--r--net-p2p/xmule/distinfo4
-rw-r--r--net-p2p/xmule/files/patch-Makefile.in9
-rw-r--r--net-p2p/xmule/pkg-plist11
4 files changed, 30 insertions, 11 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index 835555679bb1..925f901aded5 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmule
-PORTVERSION= 1.9.4.b
-PORTREVISION= 2
+DISTVERSION= 1.10.0a
CATEGORIES= net
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITES= http://download.berlios.de/%SUBDIR%/
@@ -17,6 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Port of eMule eDonkey P2P client using wxWindows class library
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
@@ -31,13 +31,14 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext \
+ --with-cryptopp-prefix=${LOCALBASE} \
--with-gtk-prefix=${X11BASE} \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
--enable-debug \
--with-wx-config=${WX_CONFIG}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
MAKE_ENV= CC="${CC}" CXX="${CXX}"
# for debugging purposes
@@ -78,6 +79,14 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|cp -p|${INSTALL_DATA}|' \
${WRKSRC}/po/Makefile.in.in
+# fix mkinstalldirs location
+# uphold CXX{,FLAGS}
+ ${FIND} ${WRKSRC} -name "Makefile*" -type f -print0 | \
+ ${XARGS} -0 \
+ ${REINPLACE_CMD} -E \
+ -e 's,^(MKINSTALLDIRS|mkinstalldirs).*$$,\1=${INSTALL_WRKSRC}/mkinstalldirs,' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|-O3|${CXXFLAGS}|'
# use correct FreeBSD atoll() prototype
.for file in ${FILES_ATOLL_PATCH}
@${REINPLACE_CMD} -E \
@@ -108,7 +117,7 @@ post-install:
# do not install a generic named ed2k binary
# install it under a more specific name
@${INSTALL_PROGRAM} \
- ${WRKSRC}/ed2k \
+ ${WRKSRC}/ed2k.xmule-2.0 \
${PREFIX}/bin/${PORTNAME}-ed2k-handler
.include <bsd.port.post.mk>
diff --git a/net-p2p/xmule/distinfo b/net-p2p/xmule/distinfo
index ac5010f8fbc5..dc978a358c1d 100644
--- a/net-p2p/xmule/distinfo
+++ b/net-p2p/xmule/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmule-1.9.4b.tar.bz2) = 467512b482feb308e376ff16ac4de649
-SIZE (xmule-1.9.4b.tar.bz2) = 1395296
+MD5 (xmule-1.10.0a.tar.bz2) = 44935bc3ae712bca8aa78451b514feb3
+SIZE (xmule-1.10.0a.tar.bz2) = 1253524
diff --git a/net-p2p/xmule/files/patch-Makefile.in b/net-p2p/xmule/files/patch-Makefile.in
index 0b26965c1675..c73e314bc71e 100644
--- a/net-p2p/xmule/files/patch-Makefile.in
+++ b/net-p2p/xmule/files/patch-Makefile.in
@@ -1,12 +1,13 @@
---- Makefile.in.orig Sun Nov 14 20:51:28 2004
-+++ Makefile.in Sun Nov 14 20:52:07 2004
-@@ -268,9 +268,9 @@
+--- Makefile.in.orig Sat Apr 2 22:24:36 2005
++++ Makefile.in Sat Apr 2 22:25:03 2005
+@@ -268,10 +268,9 @@
@rm -rf Compilation.flags Makefile aclocal.m4 autom4te.cache config.h* config.l* config.st* config.rp* configure depcomp intl
install: all
- @mkdir -p @bindir@
- @mkdir -p @datadir@/{applications,locale,pixmaps}
-- @cp -f ed2k xmule @bindir@
+- @cp -f ed2k.xmule-2.0 xmule @bindir@
+- @cp -f ed2k.xmule-2.0 @bindir@/ed2k
+ @mkdir -p @datadir@/applications
+ @mkdir -p @datadir@/locale
+ @mkdir -p @datadir@/pixmaps
diff --git a/net-p2p/xmule/pkg-plist b/net-p2p/xmule/pkg-plist
index b9577dbe1577..1fa1026ac28f 100644
--- a/net-p2p/xmule/pkg-plist
+++ b/net-p2p/xmule/pkg-plist
@@ -11,10 +11,19 @@ share/locale/it/LC_MESSAGES/xMule.mo
share/locale/ko/LC_MESSAGES/xMule.mo
share/locale/pl/LC_MESSAGES/xMule.mo
share/locale/tr/LC_MESSAGES/xMule.mo
+@unexec rmdir %D/share/locale/tr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/tr 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/ko/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ko 2>/dev/null || true
+@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/it 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr 2>/dev/null || true
+@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/es 2>/dev/null || true
@unexec rmdir %D/share/locale/ee/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ee 2>/dev/null || true
-@unexec rmdir %D/share/gnome/locale 2>/dev/null || true
+@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/de 2>/dev/null || true