aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-23 21:08:41 +0800
committermakc <makc@FreeBSD.org>2013-10-23 21:08:41 +0800
commit257d95e619d504625a3dd72269614d7fe350704c (patch)
tree902ae1e48303d70f1045908f9eb477d7722924c8 /net-p2p
parent4db462c2d32f9526ce9940e28a4b22915d0982f5 (diff)
downloadfreebsd-ports-gnome-257d95e619d504625a3dd72269614d7fe350704c.tar.gz
freebsd-ports-gnome-257d95e619d504625a3dd72269614d7fe350704c.tar.zst
freebsd-ports-gnome-257d95e619d504625a3dd72269614d7fe350704c.zip
- Support staging
- Use new LIB_DEPENDS syntax - Use options helpers - Convert to USES - Minor changes/fixes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Makefile7
-rw-r--r--net-p2p/libktorrent/Makefile9
2 files changed, 7 insertions, 9 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 1107ce01d026..8cd3e08ec611 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -11,9 +11,9 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= BitTorrent client for KDE
BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
- gmp:${PORTSDIR}/math/gmp \
- ktorrent.5:${PORTSDIR}/net-p2p/libktorrent
+LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libktorrent.so:${PORTSDIR}/net-p2p/libktorrent
USE_BZIP2= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4 pimlibs workspace
@@ -30,7 +30,6 @@ PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
CMAKE_ARGS+= -DENABLE_KIO_MAGNET=1
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,ktorrent,$${LIBKTORRENT_LIBRARIES},' \
${WRKSRC}/plugins/ipfilter/tests/CMakeLists.txt
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 45959dd5a8d4..d18617e240e6 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -7,12 +7,12 @@ CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:C,^1,4,:C,-.*,,}/
MAINTAINER= makc@FreeBSD.org
-COMMENT= Torrent library split from KTorrent
+COMMENT= Torrent library from KTorrent project
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
- gmp:${PORTSDIR}/math/gmp \
- qca:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgmp.so:${PORTSDIR}/math/gmp \
+ libqca.so:${PORTSDIR}/devel/qca
USE_BZIP2= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4
@@ -24,5 +24,4 @@ SHLIB_VER= 5.0.1
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
SHLIB_SHVER=${SHLIB_VER:R:R}
-NO_STAGE= yes
.include <bsd.port.mk>