aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /net-p2p
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp-daemon/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-lib/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-qt/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/net-p2p/eiskaltdcpp-daemon/Makefile b/net-p2p/eiskaltdcpp-daemon/Makefile
index 5fad1866422f..5f8434066752 100644
--- a/net-p2p/eiskaltdcpp-daemon/Makefile
+++ b/net-p2p/eiskaltdcpp-daemon/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USES= cmake gettext
USE_OPENSSL= yes
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 7a2e47bbf257..2abd8576e233 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -21,7 +21,7 @@ CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USES= cmake gettext
USE_OPENSSL= yes
diff --git a/net-p2p/eiskaltdcpp-lib/Makefile b/net-p2p/eiskaltdcpp-lib/Makefile
index 76e79fe2394a..6954e50f66e4 100644
--- a/net-p2p/eiskaltdcpp-lib/Makefile
+++ b/net-p2p/eiskaltdcpp-lib/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USES= cmake gettext
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/net-p2p/eiskaltdcpp-qt/Makefile b/net-p2p/eiskaltdcpp-qt/Makefile
index 93ee49278e0f..bc5f2a4dc9d6 100644
--- a/net-p2p/eiskaltdcpp-qt/Makefile
+++ b/net-p2p/eiskaltdcpp-qt/Makefile
@@ -24,7 +24,7 @@ CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USES= cmake gettext
USE_OPENSSL= yes