aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-08-30 20:11:48 +0800
committercrees <crees@FreeBSD.org>2013-08-30 20:11:48 +0800
commit9b2ebfebbe98fc3171b030aad60440904b0f5146 (patch)
treeeb45dc6b54e8e61cfb4061324db77318a8ce0f17 /net-p2p
parent9a99b0ef9870bb196f920ea946e16f0fa8a1edb1 (diff)
downloadfreebsd-ports-gnome-9b2ebfebbe98fc3171b030aad60440904b0f5146.tar.gz
freebsd-ports-gnome-9b2ebfebbe98fc3171b030aad60440904b0f5146.tar.zst
freebsd-ports-gnome-9b2ebfebbe98fc3171b030aad60440904b0f5146.zip
Fix transmission-qt4 build.
PR: ports/180292 Submitted by: naddy Obtained from: OpenBSD
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-cli/files/patch-qt_favicon_cc28
-rw-r--r--net-p2p/transmission-cli/files/patch-qt_file-tree_cc15
-rw-r--r--net-p2p/transmission-cli/files/patch-qt_qtr_pro21
-rw-r--r--net-p2p/transmission-cli/files/patch-qt_torrent-filter_cc12
-rw-r--r--net-p2p/transmission-qt4/Makefile2
5 files changed, 76 insertions, 2 deletions
diff --git a/net-p2p/transmission-cli/files/patch-qt_favicon_cc b/net-p2p/transmission-cli/files/patch-qt_favicon_cc
new file mode 100644
index 000000000000..f78999581cea
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-qt_favicon_cc
@@ -0,0 +1,28 @@
+$OpenBSD$
+--- qt/favicon.cc.orig Fri Aug 9 04:45:47 2013
++++ qt/favicon.cc Thu Aug 22 16:39:50 2013
+@@ -14,7 +14,12 @@
+ #include <QNetworkAccessManager>
+ #include <QNetworkReply>
+ #include <QNetworkRequest>
++
++#if QT_VERSION >= 0x050000
+ #include <QStandardPaths>
++#else
++#include <QDesktopServices>
++#endif
+
+ #include "favicon.h"
+
+@@ -40,7 +45,11 @@ Favicons :: ~Favicons( )
+ QString
+ Favicons :: getCacheDir( )
+ {
++#if QT_VERSION >= 0x050000
+ const QString base = QStandardPaths::writableLocation (QStandardPaths::CacheLocation);
++#else
++ const QString base = QDesktopServices::storageLocation( QDesktopServices::CacheLocation );
++#endif
+ return QDir( base ).absoluteFilePath( "favicons" );
+ }
+
diff --git a/net-p2p/transmission-cli/files/patch-qt_file-tree_cc b/net-p2p/transmission-cli/files/patch-qt_file-tree_cc
new file mode 100644
index 000000000000..3ca53511a0ef
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-qt_file-tree_cc
@@ -0,0 +1,15 @@
+$OpenBSD$
+--- qt/file-tree.cc.orig Fri Aug 9 04:45:54 2013
++++ qt/file-tree.cc Thu Aug 22 16:40:53 2013
+@@ -885,7 +885,11 @@ FileTreeView :: FileTreeView (QWidget * parent, bool i
+ for (int i=0; i<NUM_COLUMNS; ++i)
+ {
+ setColumnHidden (i, (i<FIRST_VISIBLE_COLUMN) || (LAST_VISIBLE_COLUMN<i));
++#if QT_VERSION >= 0x050000
+ header()->setSectionResizeMode(i, QHeaderView::Interactive);
++#else
++ header()->setResizeMode(i, QHeaderView::Interactive);
++#endif
+ }
+
+ connect (this, SIGNAL(clicked(const QModelIndex&)),
diff --git a/net-p2p/transmission-cli/files/patch-qt_qtr_pro b/net-p2p/transmission-cli/files/patch-qt_qtr_pro
new file mode 100644
index 000000000000..76a8a66a6882
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-qt_qtr_pro
@@ -0,0 +1,21 @@
+$OpenBSD: patch-qt_qtr_pro,v 1.4 2012/04/07 10:55:04 naddy Exp $
+--- qt/qtr.pro.orig Fri Aug 9 04:45:47 2013
++++ qt/qtr.pro Thu Aug 22 16:37:03 2013
+@@ -8,7 +8,7 @@ target.path = /bin
+ INSTALLS += target
+
+ unix: INSTALLS += man
+-man.path = /share/man/man1/
++man.path = /man/man1/
+ man.files = transmission-qt.1
+
+ CONFIG += qt thread debug link_pkgconfig
+@@ -26,7 +26,7 @@ LIBS += $${LIBUTP_LIBS}
+ LIBS += $${TRANSMISSION_TOP}/third-party/dht/libdht.a
+ LIBS += $${LIBUPNP_LIBS}
+ LIBS += $${LIBNATPMP_LIBS}
+-unix: LIBS += -L$${EVENT_TOP}/lib -lz -lrt
++unix: LIBS += -L$${EVENT_TOP}/lib -lz -levent_core -levent_extra
+ win32:DEFINES += QT_DBUS
+ win32:LIBS += -levent-2.0 -lws2_32 -lintl
+ win32:LIBS += -lidn -liconv -lwldap32 -liphlpapi
diff --git a/net-p2p/transmission-cli/files/patch-qt_torrent-filter_cc b/net-p2p/transmission-cli/files/patch-qt_torrent-filter_cc
new file mode 100644
index 000000000000..0beebf73291f
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-qt_torrent-filter_cc
@@ -0,0 +1,12 @@
+$OpenBSD$
+--- qt/torrent-filter.cc.orig Sat Jul 6 22:21:17 2013
++++ qt/torrent-filter.cc Sat Jul 6 22:29:10 2013
+@@ -211,7 +211,7 @@ TorrentFilter :: hiddenRowCount( ) const
+ void
+ TorrentFilter :: countTorrentsPerMode (int * setmeCounts) const
+ {
+- std::fill_n (setmeCounts, FilterMode::NUM_MODES, 0);
++ std::fill_n (setmeCounts, int(FilterMode::NUM_MODES), 0);
+
+ for (int row(0); ; ++row)
+ {
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
index c6e3e23860c4..e23a2d159824 100644
--- a/net-p2p/transmission-qt4/Makefile
+++ b/net-p2p/transmission-qt4/Makefile
@@ -9,8 +9,6 @@ COMMENT= Fast and lightweight QT4 BitTorrent client
LIB_DEPENDS= ${GEN_LIB_DEPENDS}
RUN_DEPENDS= ${GEN_RUN_DEPENDS}
-BROKEN= Requires newer version of Qt than in the ports tree
-
DESCR= ${.CURDIR}/pkg-descr
MASTERDIR= ${.CURDIR}/../transmission-cli
PLIST= ${.CURDIR}/pkg-plist