aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-18 05:36:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-18 05:36:55 +0800
commitdf94dff57f2487713c31630abe8ec31b4f251b98 (patch)
tree8926cd2abaad5488f300821255bc47fca9e6424d /net-p2p
parent8d92cb23d58919eb8f853ace38d19b88f0cdff77 (diff)
downloadfreebsd-ports-gnome-df94dff57f2487713c31630abe8ec31b4f251b98.tar.gz
freebsd-ports-gnome-df94dff57f2487713c31630abe8ec31b4f251b98.tar.zst
freebsd-ports-gnome-df94dff57f2487713c31630abe8ec31b4f251b98.zip
- Clarify LICENSE
- Add LICENSE_FILE - Drop uneeded flags - Remove SQLITE option, sqlite support is not conditional - Switch to opt_CMAKE_BOOL - Simplify installation
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/uhub/Makefile38
-rw-r--r--net-p2p/uhub/files/patch-src__network__openssl.c4
-rw-r--r--net-p2p/uhub/pkg-plist6
3 files changed, 19 insertions, 29 deletions
diff --git a/net-p2p/uhub/Makefile b/net-p2p/uhub/Makefile
index 5ee8849fcf6c..2aed39b8b027 100644
--- a/net-p2p/uhub/Makefile
+++ b/net-p2p/uhub/Makefile
@@ -10,30 +10,26 @@ MASTER_SITES= http://www.extatic.org/downloads/uhub/
MAINTAINER= ports@FreeBSD.org
COMMENT= High performance peer-to-peer hub for the ADC network
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USERS= uhub
-GROUPS= uhub
-
-USES= cmake perl5
+USES= cmake perl5 sqlite
USE_RC_SUBR= uhub
USE_PERL5= build
-CFLAGS+= -fPIC -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USERS= uhub
+GROUPS= uhub
+
+CFLAGS+= -fPIC
-OPTIONS_DEFINE= OPENSSL SQLITE
+OPTIONS_DEFINE= OPENSSL
OPTIONS_DEFAULT= OPENSSL SQLITE
OPTIONS_SUB= yes
-OPENSSL_USE= openssl=yes
-OPENSSL_CMAKE_OFF= -DSSL_SUPPORT:BOOL=OFF
-SQLITE_USES= sqlite
-SQLITE_CMAKE_OFF= -DSQLITE_SUPPORT:BOOL=OFF
-
-.include <bsd.port.options.mk>
+OPENSSL_USES= ssl
+OPENSSL_CMAKE_BOOL= SSL_SUPPORT
post-patch:
@${REINPLACE_CMD} -e \
@@ -45,19 +41,13 @@ post-patch:
's|"/etc/uhub/|"${ETCDIR}/|' ${WRKSRC}/src/uhub.h
do-install:
- (cd ${INSTALL_WRKSRC} && ${INSTALL_PROGRAM} uhub \
- ${STAGEDIR}${PREFIX}/bin)
-.if ${PORT_OPTIONS:MSQLITE}
- (cd ${INSTALL_WRKSRC} && ${INSTALL_PROGRAM} uhub-passwd \
- ${STAGEDIR}${PREFIX}/bin)
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/uhub ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/uhub-passwd ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/uhub
- (cd ${INSTALL_WRKSRC} && ${INSTALL_LIB} mod_*.so \
- ${STAGEDIR}${PREFIX}/lib/uhub)
+ ${INSTALL_LIB} ${WRKSRC}/mod_*.so ${STAGEDIR}${PREFIX}/lib/uhub
@${MKDIR} ${STAGEDIR}${ETCDIR}
.for i in uhub.conf users.conf
- (cd ${WRKSRC}/doc && ${INSTALL_DATA} ${i} \
- ${STAGEDIR}${ETCDIR}/${i}.sample)
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${ETCDIR}/${i}.sample
.endfor
.for i in motd.txt rules.txt
@${ECHO_CMD} -n > ${STAGEDIR}${ETCDIR}/${i}.sample
diff --git a/net-p2p/uhub/files/patch-src__network__openssl.c b/net-p2p/uhub/files/patch-src__network__openssl.c
index c1b67184db8c..8424ca7a840e 100644
--- a/net-p2p/uhub/files/patch-src__network__openssl.c
+++ b/net-p2p/uhub/files/patch-src__network__openssl.c
@@ -1,6 +1,6 @@
---- src/network/openssl.c.orig
+--- src/network/openssl.c.orig 2014-08-06 18:56:07 UTC
+++ src/network/openssl.c
-@@ -106,10 +106,12 @@
+@@ -106,10 +106,12 @@ static const SSL_METHOD* get_ssl_method(
if (!strcmp(tls_version, "1.0"))
return TLSv1_method();
diff --git a/net-p2p/uhub/pkg-plist b/net-p2p/uhub/pkg-plist
index 8f4658a2d0e8..509fecb983d2 100644
--- a/net-p2p/uhub/pkg-plist
+++ b/net-p2p/uhub/pkg-plist
@@ -1,13 +1,13 @@
bin/uhub
-%%SQLITE%%bin/uhub-passwd
+bin/uhub-passwd
@sample(,uhub,0640) %%ETCDIR%%/motd.txt.sample
@sample(,uhub,0640) %%ETCDIR%%/rules.txt.sample
@sample(,uhub,0640) %%ETCDIR%%/uhub.conf.sample
@sample(,uhub,0640) %%ETCDIR%%/users.conf.sample
lib/uhub/mod_auth_simple.so
-%%SQLITE%%lib/uhub/mod_auth_sqlite.so
+lib/uhub/mod_auth_sqlite.so
lib/uhub/mod_chat_history.so
-%%SQLITE%%lib/uhub/mod_chat_history_sqlite.so
+lib/uhub/mod_chat_history_sqlite.so
lib/uhub/mod_chat_only.so
lib/uhub/mod_example.so
lib/uhub/mod_logging.so