aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2003-04-23 06:07:02 +0800
committerfenner <fenner@FreeBSD.org>2003-04-23 06:07:02 +0800
commit0e69e83154425a554cacb5e55d8a009649a68330 (patch)
tree06746fef3c77c1a9c3ee65ed2a038bda8dd89be2 /net-p2p
parentc1928dd015fb138548d9dabffa0a9e0298b91b94 (diff)
downloadfreebsd-ports-gnome-0e69e83154425a554cacb5e55d8a009649a68330.tar.gz
freebsd-ports-gnome-0e69e83154425a554cacb5e55d8a009649a68330.tar.zst
freebsd-ports-gnome-0e69e83154425a554cacb5e55d8a009649a68330.zip
Don't try to run wxconfig if it doesn't exist; simply
depend on gtk12 in that case.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index 58d7a36ff100..9f718c3eda4f 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -52,8 +52,12 @@ post-install:
.include <bsd.port.pre.mk>
+.if exists(${WX_CONFIG})
# detect if wxgtk was linked against gtk1 or gtk2
DECISION_GTK_1_OR_2!= ${WX_CONFIG} --cppflags
+.else
+DECISION_GTK_1_OR_2= ""
+.endif
.if (${DECISION_GTK_1_OR_2:Mgtk2} != "")
USE_GNOME+= gtk20