aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-04-04 03:14:50 +0800
committermakc <makc@FreeBSD.org>2010-04-04 03:14:50 +0800
commit4329619a8fd5a4849de97527fe88060c3a2adb56 (patch)
tree6907c4603c960511fa81598fbcc7dbfdcc9997f3 /net-p2p
parentb3b1eb19ea87a85729a1b7373c0b411c577f6bb2 (diff)
downloadfreebsd-ports-gnome-4329619a8fd5a4849de97527fe88060c3a2adb56.tar.gz
freebsd-ports-gnome-4329619a8fd5a4849de97527fe88060c3a2adb56.tar.zst
freebsd-ports-gnome-4329619a8fd5a4849de97527fe88060c3a2adb56.zip
Update to 2.0
PR: ports/145011 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com> Approved by: Stas Timokhin (maintainer)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdc/Makefile41
-rw-r--r--net-p2p/eiskaltdc/distinfo6
-rw-r--r--net-p2p/eiskaltdc/files/patch-CMakeLists.txt39
-rw-r--r--net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp10
-rw-r--r--net-p2p/eiskaltdc/files/patch-dcinotify.cpp205
-rw-r--r--net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in11
-rw-r--r--net-p2p/eiskaltdc/pkg-descr10
-rw-r--r--net-p2p/eiskaltdc/pkg-plist225
8 files changed, 65 insertions, 482 deletions
diff --git a/net-p2p/eiskaltdc/Makefile b/net-p2p/eiskaltdc/Makefile
index 9222f0be6628..95317fee6bc7 100644
--- a/net-p2p/eiskaltdc/Makefile
+++ b/net-p2p/eiskaltdc/Makefile
@@ -5,29 +5,42 @@
# $FreeBSD$
#
-PORTNAME= eiskaltdc
-PORTVERSION= 1.0.40
-PORTREVISION= 2
+PORTNAME= eiskaltdcpp
+PORTVERSION= 2.0
CATEGORIES= net-p2p
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= devel@stasyan.com
COMMENT= A Direct Connect client QT GUI
-LIB_DEPENDS= dc.5:${PORTSDIR}/net-p2p/dclib
+LIB_DEPENDS= upnp.3:${PORTSDIR}/devel/upnp \
+ boost_system.4:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+PROJECTHOST= eiskaltdc
-USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network qt3support qmake_build \
- moc_build uic_build rcc_build linguist_build
-USE_GMAKE= yes
USE_CMAKE= yes
-CMAKE_USE_PTHREAD= yes
-QTCFGLIBS+= ${PTHREAD_LIBS}
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml dbus network sql qmake_build uic_build \
+ moc_build rcc_build linguist_build
+MAKE_JOBS_SAFE= yes
-MAN1= eiskaltdc.1
+MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
-BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+OPTIONS= ASPELL "Spell checking support" off
+
+.include <bsd.port.options.mk>
+
+.if definede(WITH_ASPELL)
+LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+CMAKE_ARGS+= -DUSE_ASPELL:BOOL=on
+.else
+CMAKE_ARGS+= -DUSE_ASPELL:BOOL=off
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,share/man/,man/,g' \
+ ${WRKSRC}/${PORTNAME}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/net-p2p/eiskaltdc/distinfo b/net-p2p/eiskaltdc/distinfo
index 0faee23a89b7..da4a13ce55be 100644
--- a/net-p2p/eiskaltdc/distinfo
+++ b/net-p2p/eiskaltdc/distinfo
@@ -1,3 +1,3 @@
-MD5 (eiskaltdc-1.0.40.tar.bz2) = 031d2811b71d15e6894f2fe2eec061c3
-SHA256 (eiskaltdc-1.0.40.tar.bz2) = 697f906f64ffa7ba39a8be9ac47917591be19e283d45f2a91f5bfa2395c93e0d
-SIZE (eiskaltdc-1.0.40.tar.bz2) = 1691772
+MD5 (eiskaltdcpp-2.0.tar.gz) = 32d0f63744be44f178e2821e864c8a5f
+SHA256 (eiskaltdcpp-2.0.tar.gz) = 4204b2c661eeb50e627385a41f19bbb43c42f767965af4df4e1ffb98a2723e1a
+SIZE (eiskaltdcpp-2.0.tar.gz) = 1227282
diff --git a/net-p2p/eiskaltdc/files/patch-CMakeLists.txt b/net-p2p/eiskaltdc/files/patch-CMakeLists.txt
deleted file mode 100644
index 9bcd3e6a1cfa..000000000000
--- a/net-p2p/eiskaltdc/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
---- ./eiskaltdc/CMakeLists.txt.orig 2009-10-23 02:33:43.000000000 +1100
-+++ ./eiskaltdc/CMakeLists.txt 2009-11-06 16:51:20.000000000 +1000
-@@ -253,7 +253,7 @@
- IF (NOT SVNVERSION)
- SET (SVNVERSION "release")
- ENDIF (NOT SVNVERSION)
--#CONFIGURE_FILE(eiskaltdc-1.1.0.pc.cmake.in ${CMAKE_BINARY_DIR}/eiskaltdc-1.1.0.pc)
-+CONFIGURE_FILE(eiskaltdc-1.1.0.pc.cmake.in ${CMAKE_BINARY_DIR}/eiskaltdc-1.1.0.pc)
- CONFIGURE_FILE (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_SOURCE_DIR}/config.h)
- # actual targets:
- IF (UNIX)
-@@ -286,7 +286,7 @@
- INSTALL (TARGETS eiskalt eiskaltdc
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION ${LIBDIR}
-- NAMELINK_SKIP)
-+ )
- #INSTALL (FILES ${CMAKE_BINARY_DIR}/eiskaltdc/libeiskaltdcstatic.a DESTINATION lib RENAME libeiskaltdc.a)
- INSTALL (FILES ${COMPILED_TRANSLATIONS} DESTINATION ${EISKALT_TRANSLATIONS_DEST})
- INSTALL (DIRECTORY icons/appl icons/emot icons/user DESTINATION ${EISKALT_ICONS_DEST} PATTERN ".svn" EXCLUDE)
-@@ -294,7 +294,7 @@
- INSTALL (DIRECTORY sounds/ DESTINATION ${EISKALT_SOUNDS_DEST} PATTERN ".svn" EXCLUDE
- PATTERN "Makefile.*" EXCLUDE)
- INSTALL (FILES ../COPYING DESTINATION share/eiskaltdc)
-- #INSTALL (FILES ${HDRS} ${hdrs} DESTINATION include/eiskaltdc)
-+ INSTALL (FILES ${HDRS} ${hdrs} DESTINATION include/eiskaltdc)
- INSTALL (FILES icons/icon_128x128.png DESTINATION share/icons/hicolor/128x128/apps RENAME eiskaltdc.png)
- INSTALL (FILES icons/icon_64x64.png DESTINATION share/icons/hicolor/64x64/apps RENAME eiskaltdc.png)
- INSTALL (FILES icons/icon_32x32.png DESTINATION share/icons/hicolor/32x32/apps RENAME eiskaltdc.png)
-@@ -305,7 +305,7 @@
- INSTALL (FILES icons/icon_128x128.png DESTINATION share/pixmaps/ RENAME eiskaltdc.png)
- IF (UNIX)
- INSTALL (FILES ../eiskaltdc.desktop DESTINATION share/applications RENAME eiskaltdc.desktop)
-- INSTALL (FILES docs/en/eiskaltdc.1.gz DESTINATION share/man/man1)
-- #INSTALL (FILES ${CMAKE_BINARY_DIR}/eiskaltdc-1.1.0.pc DESTINATION include/pkgconfig)
-+ INSTALL (FILES docs/en/eiskaltdc.1.gz DESTINATION man/man1)
-+ INSTALL (FILES ${CMAKE_BINARY_DIR}/eiskaltdc-1.1.0.pc DESTINATION libdata/pkgconfig)
- ENDIF (UNIX)
-
diff --git a/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp b/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp
deleted file mode 100644
index b9fba8f132d2..000000000000
--- a/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./eiskaltdc/dcfilebrowser.cpp.orig 2009-08-28 10:26:38.000000000 +0700
-+++ ./eiskaltdc/dcfilebrowser.cpp 2009-08-28 10:26:57.000000000 +0700
-@@ -36,6 +36,7 @@
- #include <QColor>
-
- #include <set>
-+#include <stdlib.h>
- #ifdef HAVE_MALLOC_H
- #include <malloc.h>
- #endif
diff --git a/net-p2p/eiskaltdc/files/patch-dcinotify.cpp b/net-p2p/eiskaltdc/files/patch-dcinotify.cpp
deleted file mode 100644
index 9f6e0128f13f..000000000000
--- a/net-p2p/eiskaltdc/files/patch-dcinotify.cpp
+++ /dev/null
@@ -1,205 +0,0 @@
---- ./eiskaltdc/dcinotify.cpp.orig 2009-09-01 09:45:17.000000000 +0700
-+++ ./eiskaltdc/dcinotify.cpp 2009-09-01 09:46:21.000000000 +0700
-@@ -2,7 +2,201 @@
-
- #include "dcinotify.h"
-
--#include <sys/inotify.h>
-+/* inotify_local.h injected directly into dcinotify.cpp
-+
-+/*
-+ * inotify_local.h - wrapping of libc features and kernel defines
-+ *
-+ * Copyright (C) 2005-2006 Kay Sievers <kay.sievers at vrfy.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License as published by the
-+ * Free Software Foundation version 2 of the License.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License along
-+ * with this program; if not, write to the Free Software Foundation, Inc.,
-+ * 675 Mass Ave, Cambridge, MA 02139, USA.
-+ *
-+ */
-+
-+#ifndef _INOTIFY_LOCAL_H_
-+#define _INOTIFY_LOCAL_H_
-+
-+#include <string.h>
-+#include <unistd.h>
-+#include <stdint.h>
-+
-+/* needed until Inotify! syscalls reach glibc */
-+#include <sys/syscall.h>
-+#ifndef __NR_inotify_init
-+#if defined(__i386__)
-+# define __NR_inotify_init 291
-+# define __NR_inotify_add_watch 292
-+# define __NR_inotify_rm_watch 293
-+#elif defined(__x86_64__)
-+# define __NR_inotify_init 253
-+# define __NR_inotify_add_watch 254
-+# define __NR_inotify_rm_watch 255
-+#elif defined(__powerpc__) || defined(__powerpc64__)
-+# define __NR_inotify_init 275
-+# define __NR_inotify_add_watch 276
-+# define __NR_inotify_rm_watch 277
-+#elif defined (__ia64__)
-+# define __NR_inotify_init 1277
-+# define __NR_inotify_add_watch 1278
-+# define __NR_inotify_rm_watch 1279
-+#elif defined (__s390__)
-+# define __NR_inotify_init 284
-+# define __NR_inotify_add_watch 285
-+# define __NR_inotify_rm_watch 286
-+#elif defined (__mc68000__)
-+# define __NR_inotify_init 284
-+# define __NR_inotify_add_watch 285
-+# define __NR_inotify_rm_watch 286
-+#elif defined (__alpha__)
-+# define __NR_inotify_init 444
-+# define __NR_inotify_add_watch 445
-+# define __NR_inotify_rm_watch 446
-+#elif defined (__sparc__) || defined (__sparc64__)
-+# define __NR_inotify_init 151
-+# define __NR_inotify_add_watch 152
-+# define __NR_inotify_rm_watch 156
-+#elif defined (__arm__)
-+# define __NR_inotify_init __NR_SYSCALL_BASE+316
-+# define __NR_inotify_add_watch __NR_SYSCALL_BASE+317
-+# define __NR_inotify_rm_watch __NR_SYSCALL_BASE+318
-+#elif defined (__sh__)
-+# define __NR_inotify_init 290
-+# define __NR_inotify_add_watch 291
-+# define __NR_inotify_rm_watch 292
-+#elif defined (__m32r__)
-+# define __NR_inotify_init 290
-+# define __NR_inotify_add_watch 291
-+# define __NR_inotify_rm_watch 292
-+#elif defined (__hppa__)
-+# define __NR_inotify_init 269
-+# define __NR_inotify_add_watch 270
-+# define __NR_inotify_rm_watch 271
-+#elif defined (__mips__)
-+# include <sgidefs.h>
-+# if _MIPS_SIM == _MIPS_SIM_ABI32
-+# define __NR_Linux 4000
-+# define __NR_inotify_init (__NR_Linux + 284)
-+# define __NR_inotify_add_watch (__NR_Linux + 285)
-+# define __NR_inotify_rm_watch (__NR_Linux + 286)
-+# elif _MIPS_SIM == _MIPS_SIM_ABI64
-+# define __NR_Linux 5000
-+# define __NR_inotify_init (__NR_Linux + 243)
-+# define __NR_inotify_add_watch (__NR_Linux + 244)
-+# define __NR_inotify_rm_watch (__NR_Linux + 245)
-+# elif _MIPS_SIM == _MIPS_SIM_NABI32
-+# define __NR_Linux 6000
-+# define __NR_inotify_init (__NR_Linux + 247)
-+# define __NR_inotify_add_watch (__NR_Linux + 248)
-+# define __NR_inotify_rm_watch (__NR_Linux + 249)
-+# endif
-+#else
-+# warning "inotify unsupported on this architecture!"
-+#endif
-+#endif /* __NR_inotify_init */
-+
-+/* dummy if we don't have the syscalls defined */
-+#ifndef __NR_inotify_init
-+static inline int inotify_init(void)
-+{
-+ return -1;
-+}
-+
-+static inline int inotify_add_watch(int fd, const char *name, uint32_t mask)
-+{
-+ return -1;
-+}
-+
-+static inline int inotify_rm_watch(int fd, uint32_t wd)
-+{
-+ return -1;
-+}
-+#else
-+static inline int inotify_init(void)
-+{
-+ return syscall(__NR_inotify_init);
-+}
-+
-+static inline int inotify_add_watch(int fd, const char *name, uint32_t mask)
-+{
-+ return syscall(__NR_inotify_add_watch, fd, name, mask);
-+}
-+
-+static inline int inotify_rm_watch(int fd, uint32_t wd)
-+{
-+ return syscall(__NR_inotify_rm_watch, fd, wd);
-+}
-+#endif /* __NR_inotify_init */
-+
-+#ifndef IN_CREATE
-+#define IN_CREATE 0x00000100 /* Subfile was created */
-+#define IN_MOVED_FROM 0x00000040 /* File was moved from X */
-+#define IN_MOVED_TO 0x00000080 /* File was moved to Y */
-+#define IN_DELETE 0x00000200 /* Subfile was deleted */
-+#define IN_CLOSE_WRITE 0x00000008 /* Writtable file was closed */
-+#define IN_MOVE (IN_MOVED_FROM | IN_MOVED_TO) /* moves */
-+#endif /* IN_CREATE */
-+
-+struct inotify_event {
-+ int wd;
-+ uint32_t mask;
-+ uint32_t cookie;
-+ uint32_t len;
-+ char *name;
-+};
-+
-+/* the following are legal, implemented events that user-space can watch for */
-+#define IN_ACCESS 0x00000001 /* File was accessed */
-+#define IN_MODIFY 0x00000002 /* File was modified */
-+#define IN_ATTRIB 0x00000004 /* Metadata changed */
-+#define IN_CLOSE_WRITE 0x00000008 /* Writtable file was closed */
-+#define IN_CLOSE_NOWRITE 0x00000010 /* Unwrittable file closed */
-+#define IN_OPEN 0x00000020 /* File was opened */
-+#define IN_MOVED_FROM 0x00000040 /* File was moved from X */
-+#define IN_MOVED_TO 0x00000080 /* File was moved to Y */
-+#define IN_CREATE 0x00000100 /* Subfile was created */
-+#define IN_DELETE 0x00000200 /* Subfile was deleted */
-+#define IN_DELETE_SELF 0x00000400 /* Self was deleted */
-+#define IN_MOVE_SELF 0x00000800 /* Self was moved */
-+
-+/* the following are legal events. they are sent as needed to any watch */
-+#define IN_UNMOUNT 0x00002000 /* Backing fs was unmounted */
-+#define IN_Q_OVERFLOW 0x00004000 /* Event queued overflowed */
-+#define IN_IGNORED 0x00008000 /* File was ignored */
-+
-+/* helper events */
-+#define IN_CLOSE (IN_CLOSE_WRITE | IN_CLOSE_NOWRITE) /* close */
-+#define IN_MOVE (IN_MOVED_FROM | IN_MOVED_TO) /* moves */
-+
-+/* special flags */
-+#define IN_ONLYDIR 0x01000000 /* only watch the path if it is a directory */
-+#define IN_DONT_FOLLOW 0x02000000 /* don't follow a sym link */
-+#define IN_MASK_ADD 0x20000000 /* add to the mask of an already existing watch */
-+#define IN_ISDIR 0x40000000 /* event occurred against dir */
-+#define IN_ONESHOT 0x80000000 /* only send event once */
-+
-+/*
-+ * All of the events - we build the list by hand so that we can add flags in
-+ * the future and not break backward compatibility. Apps will get only the
-+ * events that they originally wanted. Be sure to add new events here!
-+ */
-+#define IN_ALL_EVENTS (IN_ACCESS | IN_MODIFY | IN_ATTRIB | IN_CLOSE_WRITE | \
-+ IN_CLOSE_NOWRITE | IN_OPEN | IN_MOVED_FROM | \
-+ IN_MOVED_TO | IN_DELETE | IN_CREATE | IN_DELETE_SELF | \
-+ IN_MOVE_SELF)
-+
-+#endif /* _INOTIFY_LOCAL_H_ */
-+
- #include <sys/ioctl.h>
- #include <sys/types.h>
- #include <sys/select.h>
diff --git a/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in b/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in
deleted file mode 100644
index a7c02c03e5ff..000000000000
--- a/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./eiskaltdc/docs/en/Makefile.in.orig 2009-08-25 22:23:16.000000000 +0400
-+++ ./eiskaltdc/docs/en/Makefile.in 2009-09-09 21:46:47.000000000 +0400
-@@ -371,8 +371,6 @@
- uninstall uninstall-am
-
- install-data-local:
-- $(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
-- $(INSTALL_DATA) $(srcdir)/eiskaltdc.1 $(DESTDIR)$(mandir)/man1/
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/net-p2p/eiskaltdc/pkg-descr b/net-p2p/eiskaltdc/pkg-descr
index 48839eaab143..947f0d273877 100644
--- a/net-p2p/eiskaltdc/pkg-descr
+++ b/net-p2p/eiskaltdc/pkg-descr
@@ -1,6 +1,6 @@
-EiskaltDC++ is a fork of Valknut client for the Direct Connect
-network. It is compatible with other DC clients, such as the original
-DC from Neomodus, DC++ and derivatives. EiskaltDC++ also interoperates
-with all common DC hub software.
+EiskaltDC++ is a program for UNIX-like systems that uses the Direct Connect
+and ADC protocol. It is compatible with other DC clients, such as the
+original DC from Neomodus, DC++ and derivatives. EiskaltDC++ also
+interoperates with all common DC hub software.
-WWW: http://eiskaltdc.sourceforge.net
+WWW: http://code.google.com/p/eiskaltdc/
diff --git a/net-p2p/eiskaltdc/pkg-plist b/net-p2p/eiskaltdc/pkg-plist
index 12188a358969..02af28f34a7e 100644
--- a/net-p2p/eiskaltdc/pkg-plist
+++ b/net-p2p/eiskaltdc/pkg-plist
@@ -1,89 +1,14 @@
-bin/eiskaltdc
-include/eiskaltdc/about.h
-include/eiskaltdc/cdialogmessage.h
-include/eiskaltdc/cdialogpicturemap.h
-include/eiskaltdc/dcantispam.h
-include/eiskaltdc/dcantispamcontrol.h
-include/eiskaltdc/dcapplicationevents.h
-include/eiskaltdc/dcchat.h
-include/eiskaltdc/dcclient.h
-include/eiskaltdc/dcconfig.h
-include/eiskaltdc/dcconnectionmanager.h
-include/eiskaltdc/dcdebug.h
-include/eiskaltdc/dcdownloadalias.h
-include/eiskaltdc/dceditserver.h
-include/eiskaltdc/dcedittransfer.h
-include/eiskaltdc/dcevent.h
-include/eiskaltdc/dcfilebrowser.h
-include/eiskaltdc/dcfilebrowserhistory.h
-include/eiskaltdc/dcfilebrowsersearchengine.h
-include/eiskaltdc/dcfilehasher.h
-include/eiskaltdc/dcfilelistdecompressor.h
-include/eiskaltdc/dcfiletool.h
-include/eiskaltdc/dcfiletransferinfo.h
-include/eiskaltdc/dcfriendobject.h
-include/eiskaltdc/dcgui.h
-include/eiskaltdc/dcguiutils.h
-include/eiskaltdc/dchubfilter.h
-include/eiskaltdc/dchublinklistener.h
-include/eiskaltdc/dchublistitems.h
-include/eiskaltdc/dchublistmanager.h
-include/eiskaltdc/dchubprofile.h
-include/eiskaltdc/dchubsearch.h
-include/eiskaltdc/dciconloader.h
-include/eiskaltdc/dcinotify.h
-include/eiskaltdc/dcinotifycontrol.h
-include/eiskaltdc/dcipfilter.h
-include/eiskaltdc/dcipfiltercontrol.h
-include/eiskaltdc/dcmenuhandler.h
-include/eiskaltdc/dcoptions.h
-include/eiskaltdc/dcpluginmanager.h
-include/eiskaltdc/dcqtextedit.h
-include/eiskaltdc/dcquickconnect.h
-include/eiskaltdc/dcshellcommandrunner.h
-include/eiskaltdc/dcsigterm.h
-include/eiskaltdc/dcsplash.h
-include/eiskaltdc/dcspy.h
-include/eiskaltdc/dctransferview.h
-include/eiskaltdc/dctransferviewitems.h
-include/eiskaltdc/dctranslator.h
-include/eiskaltdc/dcusercommandeditor.h
-include/eiskaltdc/dcuserslist.h
-include/eiskaltdc/dcwidget.h
-include/eiskaltdc/filebrowsermodel.h
-include/eiskaltdc/filteronlyproxy.h
-include/eiskaltdc/hublistmodel.h
-include/eiskaltdc/ipfiltermodel.h
-include/eiskaltdc/publichubsmodel.h
-include/eiskaltdc/publichubsproxy.h
-include/eiskaltdc/searchresultmodel.h
-include/eiskaltdc/searchspymodel.h
-include/eiskaltdc/userlistmodel.h
-lib/libeiskaltdc.so
-lib/libeiskaltdc.so.1.1.0
-libdata/pkgconfig/eiskaltdc-1.1.0.pc
-share/applications/eiskaltdc.desktop
-%%DATADIR%%/COPYING
-%%DATADIR%%/icons/appl/default/back.png
+bin/eiskaltdcpp
+share/applications/eiskaltdcpp.desktop
%%DATADIR%%/icons/appl/default/ball_green.png
-%%DATADIR%%/icons/appl/default/ball_red.png
-%%DATADIR%%/icons/appl/default/ball_yellow.png
%%DATADIR%%/icons/appl/default/bookmark_add.png
-%%DATADIR%%/icons/appl/default/bookmark_folder.png
%%DATADIR%%/icons/appl/default/chat.png
-%%DATADIR%%/icons/appl/default/choose-language.png
%%DATADIR%%/icons/appl/default/clear.png
-%%DATADIR%%/icons/appl/default/client.png
-%%DATADIR%%/icons/appl/default/colors.png
%%DATADIR%%/icons/appl/default/configure.png
-%%DATADIR%%/icons/appl/default/configure_22x22.png
-%%DATADIR%%/icons/appl/default/configure_32x32.png
%%DATADIR%%/icons/appl/default/connect.png
-%%DATADIR%%/icons/appl/default/connect_creating.png
%%DATADIR%%/icons/appl/default/connect_no.png
-%%DATADIR%%/icons/appl/default/connected.png
-%%DATADIR%%/icons/appl/default/debug.png
%%DATADIR%%/icons/appl/default/down.png
+%%DATADIR%%/icons/appl/default/downlist.png
%%DATADIR%%/icons/appl/default/download.png
%%DATADIR%%/icons/appl/default/download_as.png
%%DATADIR%%/icons/appl/default/edit.png
@@ -92,6 +17,11 @@ share/applications/eiskaltdc.desktop
%%DATADIR%%/icons/appl/default/editdelete.png
%%DATADIR%%/icons/appl/default/emoticon.png
%%DATADIR%%/icons/appl/default/exit.png
+%%DATADIR%%/icons/appl/default/fav.png
+%%DATADIR%%/icons/appl/default/favadd.png
+%%DATADIR%%/icons/appl/default/favrem.png
+%%DATADIR%%/icons/appl/default/favserver.png
+%%DATADIR%%/icons/appl/default/favusers.png
%%DATADIR%%/icons/appl/default/fileclose.png
%%DATADIR%%/icons/appl/default/filefind.png
%%DATADIR%%/icons/appl/default/filetype-application.png
@@ -103,145 +33,50 @@ share/applications/eiskaltdc.desktop
%%DATADIR%%/icons/appl/default/filetype-video.png
%%DATADIR%%/icons/appl/default/filter.png
%%DATADIR%%/icons/appl/default/find.png
-%%DATADIR%%/icons/appl/default/find_22x22.png
-%%DATADIR%%/icons/appl/default/find_32x32.png
-%%DATADIR%%/icons/appl/default/flag_belarus.png
-%%DATADIR%%/icons/appl/default/flag_bosnia.png
-%%DATADIR%%/icons/appl/default/flag_brazil.png
-%%DATADIR%%/icons/appl/default/flag_britain.png
-%%DATADIR%%/icons/appl/default/flag_czech.png
-%%DATADIR%%/icons/appl/default/flag_denmark.png
-%%DATADIR%%/icons/appl/default/flag_finland.png
-%%DATADIR%%/icons/appl/default/flag_france.png
-%%DATADIR%%/icons/appl/default/flag_germany.png
-%%DATADIR%%/icons/appl/default/flag_greece.png
-%%DATADIR%%/icons/appl/default/flag_hungary.png
-%%DATADIR%%/icons/appl/default/flag_iceland.png
-%%DATADIR%%/icons/appl/default/flag_italy.png
-%%DATADIR%%/icons/appl/default/flag_latvia.png
-%%DATADIR%%/icons/appl/default/flag_netherlands.png
-%%DATADIR%%/icons/appl/default/flag_norway.png
-%%DATADIR%%/icons/appl/default/flag_poland.png
-%%DATADIR%%/icons/appl/default/flag_romania.png
-%%DATADIR%%/icons/appl/default/flag_russia.png
-%%DATADIR%%/icons/appl/default/flag_serbia.png
-%%DATADIR%%/icons/appl/default/flag_slovakia.png
-%%DATADIR%%/icons/appl/default/flag_spain.png
-%%DATADIR%%/icons/appl/default/flag_sweden.png
%%DATADIR%%/icons/appl/default/folder_blue.png
-%%DATADIR%%/icons/appl/default/folder_blue_open.png
-%%DATADIR%%/icons/appl/default/folder_red.png
-%%DATADIR%%/icons/appl/default/globe.png
-%%DATADIR%%/icons/appl/default/go-next.png
-%%DATADIR%%/icons/appl/default/go-previous.png
-%%DATADIR%%/icons/appl/default/go-up.png
+%%DATADIR%%/icons/appl/default/freespace.png
%%DATADIR%%/icons/appl/default/gui.png
-%%DATADIR%%/icons/appl/default/help.png
+%%DATADIR%%/icons/appl/default/hashing.png
+%%DATADIR%%/icons/appl/default/hidewindow.png
%%DATADIR%%/icons/appl/default/icon_appl.png
%%DATADIR%%/icons/appl/default/icon_msg.png
-%%DATADIR%%/icons/appl/default/icons.png
-%%DATADIR%%/icons/appl/default/info.png
-%%DATADIR%%/icons/appl/default/inotify.png
-%%DATADIR%%/icons/appl/default/isaway.png
-%%DATADIR%%/icons/appl/default/log.png
-%%DATADIR%%/icons/appl/default/menu.png
+%%DATADIR%%/icons/appl/default/log_file.png
%%DATADIR%%/icons/appl/default/message.png
-%%DATADIR%%/icons/appl/default/next.png
-%%DATADIR%%/icons/appl/default/notconnected.png
-%%DATADIR%%/icons/appl/default/onlinemanual.png
-%%DATADIR%%/icons/appl/default/open.png
-%%DATADIR%%/icons/appl/default/other.png
-%%DATADIR%%/icons/appl/default/player_pause.png
-%%DATADIR%%/icons/appl/default/player_play.png
-%%DATADIR%%/icons/appl/default/quickoptions.png
+%%DATADIR%%/icons/appl/default/own_filelist.png
+%%DATADIR%%/icons/appl/default/qt-logo.png
%%DATADIR%%/icons/appl/default/reconnect.png
%%DATADIR%%/icons/appl/default/reload.png
-%%DATADIR%%/icons/appl/default/reload_22x22.png
-%%DATADIR%%/icons/appl/default/reload_32x32.png
-%%DATADIR%%/icons/appl/default/reload_plugins.png
-%%DATADIR%%/icons/appl/default/save.png
%%DATADIR%%/icons/appl/default/server.png
-%%DATADIR%%/icons/appl/default/slots_up.png
-%%DATADIR%%/icons/appl/default/sort-down-arrow.png
%%DATADIR%%/icons/appl/default/spam.png
%%DATADIR%%/icons/appl/default/splash.png
%%DATADIR%%/icons/appl/default/spy.png
-%%DATADIR%%/icons/appl/default/ssl_no.png
-%%DATADIR%%/icons/appl/default/ssl_yes.png
-%%DATADIR%%/icons/appl/default/support.png
-%%DATADIR%%/icons/appl/default/text-select-all.png
%%DATADIR%%/icons/appl/default/transfer.png
-%%DATADIR%%/icons/appl/default/translate.png
%%DATADIR%%/icons/appl/default/up.png
-%%DATADIR%%/icons/appl/default/update.png
+%%DATADIR%%/icons/appl/default/uplist.png
%%DATADIR%%/icons/appl/default/users.png
-%%DATADIR%%/icons/appl/default/users_22x22.png
-%%DATADIR%%/icons/appl/default/users_32x32.png
-%%DATADIR%%/icons/appl/default/view-list-details.png
-%%DATADIR%%/icons/appl/default/view-list-icons.png
-%%DATADIR%%/icons/appl/default/view_sidetree.png
-%%DATADIR%%/icons/appl/default/vru.png
-%%DATADIR%%/icons/appl/default/windows_cl_all.png
-%%DATADIR%%/icons/appl/default/windows_cl_find.png
-%%DATADIR%%/icons/appl/default/windows_cl_hubs.png
-%%DATADIR%%/icons/appl/default/windows_cl_lists.png
-%%DATADIR%%/icons/appl/default/windows_cl_offline.png
-%%DATADIR%%/icons/appl/default/windows_horiz.png
-%%DATADIR%%/icons/appl/default/windows_icon.png
-%%DATADIR%%/icons/appl/default/windows_lists.png
-%%DATADIR%%/icons/appl/default/windows_tiled.png
-%%DATADIR%%/icons/appl/default/windows_undock.png
-%%DATADIR%%/icons/appl/default/windows_vert.png
%%DATADIR%%/icons/appl/default/zoom-in.png
%%DATADIR%%/icons/appl/default/zoom-out.png
%%DATADIR%%/icons/emot/default/default.png
-%%DATADIR%%/icons/emot/default/emoticons-v2.xml
-%%DATADIR%%/icons/emot/flylink/emoticons-v2.xml
+%%DATADIR%%/icons/emot/default/default.xml
%%DATADIR%%/icons/emot/flylink/flylink.png
-%%DATADIR%%/icons/emot/kolobok/emoticons-v2.xml
-%%DATADIR%%/icons/emot/kolobok/kolobok.png
-%%DATADIR%%/icons/emot/simple-gnome/emoticons-v2.xml
-%%DATADIR%%/icons/emot/simple-gnome/simple-gnome.png
+%%DATADIR%%/icons/emot/flylink/flylink.xml
%%DATADIR%%/icons/user/default/usericons.png
%%DATADIR%%/icons/user/valknut/usericons.png
-%%DATADIR%%/translation/eiskaltdc.be.qm
-%%DATADIR%%/translation/eiskaltdc.de.qm
-%%DATADIR%%/translation/eiskaltdc.en.qm
-%%DATADIR%%/translation/eiskaltdc.fr.qm
-%%DATADIR%%/translation/eiskaltdc.ru.qm
-share/icons/hicolor/128x128/apps/eiskaltdc.png
-share/icons/hicolor/16x16/apps/eiskaltdc.png
-share/icons/hicolor/22x22/apps/eiskaltdc.png
-share/icons/hicolor/24x24/apps/eiskaltdc.png
-share/icons/hicolor/32x32/apps/eiskaltdc.png
-share/icons/hicolor/48x48/apps/eiskaltdc.png
-share/icons/hicolor/64x64/apps/eiskaltdc.png
-share/pixmaps/eiskaltdc.png
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrmtry share/applications
-@dirrm %%DATADIR%%/translation
-@dirrm %%DATADIR%%/sounds/default
-@dirrm %%DATADIR%%/sounds
+%%DATADIR%%/ts/eiskaltdcpp.be.qm
+%%DATADIR%%/ts/eiskaltdcpp.en.qm
+%%DATADIR%%/ts/eiskaltdcpp.ru.qm
+share/icons/hicolor/128x128/apps/eiskaltdcpp.png
+share/icons/hicolor/16x16/apps/eiskaltdcpp.png
+share/icons/hicolor/22x22/apps/eiskaltdcpp.png
+share/icons/hicolor/24x24/apps/eiskaltdcpp.png
+share/icons/hicolor/32x32/apps/eiskaltdcpp.png
+share/icons/hicolor/48x48/apps/eiskaltdcpp.png
+share/icons/hicolor/64x64/apps/eiskaltdcpp.png
+share/pixmaps/eiskaltdcpp.png
+@dirrm %%DATADIR%%/ts
@dirrm %%DATADIR%%/icons/user/valknut
@dirrm %%DATADIR%%/icons/user/default
@dirrm %%DATADIR%%/icons/user
-@dirrm %%DATADIR%%/icons/emot/simple-gnome
-@dirrm %%DATADIR%%/icons/emot/kolobok
@dirrm %%DATADIR%%/icons/emot/flylink
@dirrm %%DATADIR%%/icons/emot/default
@dirrm %%DATADIR%%/icons/emot
@@ -249,4 +84,4 @@ share/pixmaps/eiskaltdc.png
@dirrm %%DATADIR%%/icons/appl
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
-@dirrm include/eiskaltdc
+@dirrmtry share/applications