aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-02 03:33:30 +0800
committeryuri <yuri@FreeBSD.org>2018-09-02 03:33:30 +0800
commit616bb1bdece62db4a00013c995af844f35c1ce3f (patch)
tree7e16e5eddb3d7e467d2a92eba3376718496017cb /net-p2p
parentf6b3b9179bd7ee135d8d196d62f179341c320ad2 (diff)
downloadfreebsd-ports-gnome-616bb1bdece62db4a00013c995af844f35c1ce3f.tar.gz
freebsd-ports-gnome-616bb1bdece62db4a00013c995af844f35c1ce3f.tar.zst
freebsd-ports-gnome-616bb1bdece62db4a00013c995af844f35c1ce3f.zip
net-p2p/libbt: Update 1.05 -> 1.06
egypcio@googlemail.com takes maintainership Port changes: * Add DOCS option * Add to dependencies * Port cleanup PR: 231033 Submitted by: Vinícius Zavam <egypcio@googlemail.com> (original version) Submitted by: Nathan <ndowens@yahoo.com> (final version)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libbt/Makefile40
-rw-r--r--net-p2p/libbt/distinfo5
-rw-r--r--net-p2p/libbt/files/patch-include__util.h21
-rw-r--r--net-p2p/libbt/files/patch-src__udpproto.c11
-rw-r--r--net-p2p/libbt/pkg-plist3
5 files changed, 52 insertions, 28 deletions
diff --git a/net-p2p/libbt/Makefile b/net-p2p/libbt/Makefile
index 8bec90c724ca..c0311ef2c2ef 100644
--- a/net-p2p/libbt/Makefile
+++ b/net-p2p/libbt/Makefile
@@ -2,24 +2,28 @@
# $FreeBSD$
PORTNAME= libbt
-PORTVERSION= 1.05
-PORTREVISION= 5
+DISTVERSION= 1.06
CATEGORIES= net-p2p devel
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@googlemail.com
COMMENT= C library implementing the core BitTorrent protocol
-LIB_DEPENDS= libcurl.so:ftp/curl
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libuuid.so:misc/e2fsprogs-libuuid
+
+USES= gmake localbase ssl
GNU_CONFIGURE= yes
-USES= gmake
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= protocol-ext.txt protocol.txt
+DOCS= docs/protocol.txt docs/protocol-ext.txt \
+ CHANGELOG CREDITS README
+
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
@@ -28,16 +32,12 @@ post-patch:
do-install:
${INSTALL_DATA} ${WRKSRC}/src/libbt.a ${STAGEDIR}${PREFIX}/lib
- ${MKDIR} ${STAGEDIR}${PREFIX}/include/libbt
-.for i in btcheck btget btlist
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${i} ${STAGEDIR}${PREFIX}/bin
-.endfor
-.for i in benc.h bitset.h bterror.h btmessage.h bts.h context.h peer.h random.h segmenter.h strbuf.h stream.h types.h util.h
- ${INSTALL_DATA} ${WRKSRC}/include/${i} ${STAGEDIR}${PREFIX}/include/libbt
-.endfor
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/libbt
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} btcheck btget btlist ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/include && ${INSTALL_DATA} *.h ${STAGEDIR}${PREFIX}/include/libbt
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-p2p/libbt/distinfo b/net-p2p/libbt/distinfo
index 67e28751d96d..e6a21e545572 100644
--- a/net-p2p/libbt/distinfo
+++ b/net-p2p/libbt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libbt-1.05.tar.gz) = d4d770120c7e5df6957b2b40e1edb6695106142360d5caac521b31a4c59fa1c7
-SIZE (libbt-1.05.tar.gz) = 322880
+TIMESTAMP = 1535654605
+SHA256 (libbt-1.06.tar.gz) = 89f7887ef892158fec2691efaf26036dab2a239ab87881473ae405f2f2d13560
+SIZE (libbt-1.06.tar.gz) = 334835
diff --git a/net-p2p/libbt/files/patch-include__util.h b/net-p2p/libbt/files/patch-include__util.h
index 8ad3b431dd7b..bcb41ae00b56 100644
--- a/net-p2p/libbt/files/patch-include__util.h
+++ b/net-p2p/libbt/files/patch-include__util.h
@@ -1,12 +1,21 @@
---- include/util.h Fri Apr 16 08:41:48 2004
-+++ include/util.h.new Sun May 30 14:17:54 2004
-@@ -28,9 +28,4 @@
+--- include/util.h.orig 2018-08-30 18:48:15 UTC
++++ include/util.h
+@@ -53,11 +53,15 @@
typedef void (*exitfn_ptr) (int,void*);
int on_exit( exitfn_ptr exitfn, void* data) ;
#endif
-#define malloc(s) use_btmalloc_instead
-#define calloc(n,s) use_btcalloc_instead
-#define realloc(p,s) use_btrealloc_instead
--#define free(p) use_btfree_instead
--
- #endif
++/*
++ #define malloc(s) use_btmalloc_instead
++ #define calloc(n,s) use_btcalloc_instead
++ #define realloc(p,s) use_btrealloc_instead
++/*
+ #undef free
++/*
+ #define free(p) use_btfree_instead
++*/
+
+ void hexdump( void *buf, int buflen);
+
diff --git a/net-p2p/libbt/files/patch-src__udpproto.c b/net-p2p/libbt/files/patch-src__udpproto.c
new file mode 100644
index 000000000000..42554af9eb33
--- /dev/null
+++ b/net-p2p/libbt/files/patch-src__udpproto.c
@@ -0,0 +1,11 @@
+--- src/udpproto.c.orig 2018-08-30 18:56:26 UTC
++++ src/udpproto.c
+@@ -4,7 +4,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+-
++#include <limits.h>
+ #include <arpa/inet.h>
+
+ #include "udpproto.h"
diff --git a/net-p2p/libbt/pkg-plist b/net-p2p/libbt/pkg-plist
index a1bba9bb432e..578a2b0b2497 100644
--- a/net-p2p/libbt/pkg-plist
+++ b/net-p2p/libbt/pkg-plist
@@ -6,12 +6,15 @@ include/libbt/bitset.h
include/libbt/bterror.h
include/libbt/btmessage.h
include/libbt/bts.h
+include/libbt/config.h
include/libbt/context.h
include/libbt/peer.h
+include/libbt/peerexchange.h
include/libbt/random.h
include/libbt/segmenter.h
include/libbt/strbuf.h
include/libbt/stream.h
include/libbt/types.h
+include/libbt/udpproto.h
include/libbt/util.h
lib/libbt.a