aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /net-p2p
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/btqueue/Makefile1
-rw-r--r--net-p2p/nicotine-plus/Makefile1
-rw-r--r--net-p2p/py-bittornado/Makefile1
-rw-r--r--net-p2p/py-fngrab/Makefile1
-rw-r--r--net-p2p/py-kenosis-bittorrent/Makefile1
-rw-r--r--net-p2p/py-py2play/Makefile1
-rw-r--r--net-p2p/py-vertex/Makefile1
7 files changed, 7 insertions, 0 deletions
diff --git a/net-p2p/btqueue/Makefile b/net-p2p/btqueue/Makefile
index e86552410664..c837bd3834c9 100644
--- a/net-p2p/btqueue/Makefile
+++ b/net-p2p/btqueue/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
CONFLICTS= py??-*[Bb]it[Tt]ornado* py??-*[Bb]it[Tt]orrent*
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= BTQueue
DATADIR= ${PREFIX}/share/BTQueue
DOCSDIR= ${PREFIX}/share/doc/BTQueue
diff --git a/net-p2p/nicotine-plus/Makefile b/net-p2p/nicotine-plus/Makefile
index 302a24f4fc1a..1de2505304a7 100644
--- a/net-p2p/nicotine-plus/Makefile
+++ b/net-p2p/nicotine-plus/Makefile
@@ -26,6 +26,7 @@ USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_GETTEXT= yes
+PYDISTUTILS_PKGNAME= nicotine
DOCSDIR= share/doc/${PKGNAMEPREFIX:S/-//}
DATADIR= share/${PKGNAMEPREFIX:S/-//}
diff --git a/net-p2p/py-bittornado/Makefile b/net-p2p/py-bittornado/Makefile
index b8dc5bd114fc..52d10e96e40a 100644
--- a/net-p2p/py-bittornado/Makefile
+++ b/net-p2p/py-bittornado/Makefile
@@ -24,6 +24,7 @@ CONFLICTS= py??-*[Bb]it[Tt]ornado-core-[0-9]* py??-*[Bb]it[Tt]orrent*-[0-9]* btq
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGVERSION= T-0.3.18._BitTornado_
WRKSRC= ${WRKDIR}/${PORTNAME}-CVS
diff --git a/net-p2p/py-fngrab/Makefile b/net-p2p/py-fngrab/Makefile
index 6c4e02f1e230..ba6c4c05d059 100644
--- a/net-p2p/py-fngrab/Makefile
+++ b/net-p2p/py-fngrab/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= FreenetGrab
post-install:
@${MV} ${PREFIX}/bin/fngrab.py ${PREFIX}/bin/fngrab
diff --git a/net-p2p/py-kenosis-bittorrent/Makefile b/net-p2p/py-kenosis-bittorrent/Makefile
index 451921f6cb9a..98bb0f38cf07 100644
--- a/net-p2p/py-kenosis-bittorrent/Makefile
+++ b/net-p2p/py-kenosis-bittorrent/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/kenosis/__init__.py:${PORTSDIR}/net-p2p/py-ken
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGVERSION= 0.95
WRKSRC= ${WRKDIR}/${DISTNAME}/bt
diff --git a/net-p2p/py-py2play/Makefile b/net-p2p/py-py2play/Makefile
index 1117621f642f..d24025b35ad5 100644
--- a/net-p2p/py-py2play/Makefile
+++ b/net-p2p/py-py2play/Makefile
@@ -18,6 +18,7 @@ COMMENT= Peer-to-peer network game engine
DIST_SUBDIR= python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Py2Play
EXAMPLESDIR= ${PREFIX}/share/examples/py-py2play
post-install:
diff --git a/net-p2p/py-vertex/Makefile b/net-p2p/py-vertex/Makefile
index de303ced869e..99feb914fdde 100644
--- a/net-p2p/py-vertex/Makefile
+++ b/net-p2p/py-vertex/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsil
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Vertex
USE_TWISTED= yes
NO_BUILD= yes