aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-29 21:35:58 +0800
committerpav <pav@FreeBSD.org>2004-03-29 21:35:58 +0800
commite1c880aa03f335bb1143f1fefe60801b732f799b (patch)
tree02129f5f57c0faa8800defb856f6d7872d31ff53 /net-p2p
parentcbd431bb66726635b49225316e4dd64a59b49a1d (diff)
downloadfreebsd-ports-gnome-e1c880aa03f335bb1143f1fefe60801b732f799b.tar.gz
freebsd-ports-gnome-e1c880aa03f335bb1143f1fefe60801b732f799b.tar.zst
freebsd-ports-gnome-e1c880aa03f335bb1143f1fefe60801b732f799b.zip
- Convert to OPTIONS
PR: ports/64892 Submitted by: Stefan Walter <sw@gegenunendlich.de> (maintainer)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine-plus/Makefile32
-rw-r--r--net-p2p/nicotine/Makefile32
2 files changed, 14 insertions, 50 deletions
diff --git a/net-p2p/nicotine-plus/Makefile b/net-p2p/nicotine-plus/Makefile
index cde9a7e492b0..e879ea22be51 100644
--- a/net-p2p/nicotine-plus/Makefile
+++ b/net-p2p/nicotine-plus/Makefile
@@ -22,40 +22,22 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
+OPTIONS= GEOIP "Enable the GeoIP based country code blocker" off \
+ PSYCO "Enable Psyco, the optimizing Python compiler" off \
+ VORBIS "Enable OGG/Vorbis support" on
+
.include <bsd.port.pre.mk>
-.if exists(${PYTHON_SITELIBDIR}/GeoIP.so) || defined(WITH_GEOIP)
-WITH_GEOIP= yes
+.if defined(WITH_GEOIP)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/GeoIP.so:${PORTSDIR}/net/py-GeoIP
.endif
-
-.if exists(${PYTHON_SITELIBDIR}/psyco/_psyco.so) || defined(WITH_PSYCO)
-WITH_PSYCO= yes
+.if defined(WITH_PSYCO)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
-
-.if exists(${PYTHON_SITELIBDIR}/ogg/vorbis.so) || defined(WITH_VORBIS)
-WITH_VORBIS= yes
+.if defined(WITH_VORBIS)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis
.endif
-.if !defined(WITH_VORBIS) || !defined(WITH_PSYCO) || !defined(WITH_GEOIP)
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can define the following for additional features:"
- @${ECHO_MSG} ""
-.if !defined(WITH_GEOIP)
- @${ECHO_MSG} "WITH_GEOIP - enable the GeoIP based country code blocker"
-.endif
-.if !defined(WITH_PSYCO)
- @${ECHO_MSG} "WITH_PSYCO - enable the psyco optimizing compiler"
-.endif
-.if !defined(WITH_VORBIS)
- @${ECHO_MSG} "WITH_VORBIS - enable OGG/Vorbis support"
-.endif
- @${ECHO_MSG} ""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|sys\.prefix|\"${PREFIX}\"|g" ${WRKSRC}/setup.py
diff --git a/net-p2p/nicotine/Makefile b/net-p2p/nicotine/Makefile
index cde9a7e492b0..e879ea22be51 100644
--- a/net-p2p/nicotine/Makefile
+++ b/net-p2p/nicotine/Makefile
@@ -22,40 +22,22 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
+OPTIONS= GEOIP "Enable the GeoIP based country code blocker" off \
+ PSYCO "Enable Psyco, the optimizing Python compiler" off \
+ VORBIS "Enable OGG/Vorbis support" on
+
.include <bsd.port.pre.mk>
-.if exists(${PYTHON_SITELIBDIR}/GeoIP.so) || defined(WITH_GEOIP)
-WITH_GEOIP= yes
+.if defined(WITH_GEOIP)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/GeoIP.so:${PORTSDIR}/net/py-GeoIP
.endif
-
-.if exists(${PYTHON_SITELIBDIR}/psyco/_psyco.so) || defined(WITH_PSYCO)
-WITH_PSYCO= yes
+.if defined(WITH_PSYCO)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
-
-.if exists(${PYTHON_SITELIBDIR}/ogg/vorbis.so) || defined(WITH_VORBIS)
-WITH_VORBIS= yes
+.if defined(WITH_VORBIS)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis
.endif
-.if !defined(WITH_VORBIS) || !defined(WITH_PSYCO) || !defined(WITH_GEOIP)
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can define the following for additional features:"
- @${ECHO_MSG} ""
-.if !defined(WITH_GEOIP)
- @${ECHO_MSG} "WITH_GEOIP - enable the GeoIP based country code blocker"
-.endif
-.if !defined(WITH_PSYCO)
- @${ECHO_MSG} "WITH_PSYCO - enable the psyco optimizing compiler"
-.endif
-.if !defined(WITH_VORBIS)
- @${ECHO_MSG} "WITH_VORBIS - enable OGG/Vorbis support"
-.endif
- @${ECHO_MSG} ""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|sys\.prefix|\"${PREFIX}\"|g" ${WRKSRC}/setup.py