aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-08-01 17:04:35 +0800
committerrakuco <rakuco@FreeBSD.org>2017-08-01 17:04:35 +0800
commitff35bae8a8e4f7d568a181f004344f4baf478b71 (patch)
treebdacb6772bd04c003cd561705de5d3a6ed0a53c2 /net-p2p
parentb8d1d29873576de6bba9283b22eacb627aad1e44 (diff)
downloadfreebsd-ports-gnome-ff35bae8a8e4f7d568a181f004344f4baf478b71.tar.gz
freebsd-ports-gnome-ff35bae8a8e4f7d568a181f004344f4baf478b71.tar.zst
freebsd-ports-gnome-ff35bae8a8e4f7d568a181f004344f4baf478b71.zip
Explicitly build with -std=gnu++03.
This fixes the build with GCC 6, which defaults to -std=gnu++14. The project seems to be incompatible with C++11 and later. PR: 219281 Approved by: portmgr (blanket approval)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/verlihub-plugins-floodprotect/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-p2p/verlihub-plugins-floodprotect/Makefile b/net-p2p/verlihub-plugins-floodprotect/Makefile
index f8e96ba47099..720a419939a9 100644
--- a/net-p2p/verlihub-plugins-floodprotect/Makefile
+++ b/net-p2p/verlihub-plugins-floodprotect/Makefile
@@ -15,5 +15,9 @@ BROKEN_armv6= fails to configure: checking for VERLIHUB - version >= 0... no (s
PLUGIN_NAME= floodprot
PLUGIN_DESC= Floodprotect
+# Bug 219281: the port fails to build in C++14 mode (the default in GCC 6),
+# switch back to the old default GCC used before.
+USE_CXXSTD= gnu++03
+
.include "../verlihub-plugins/Makefile.plugins"
.include <bsd.port.mk>