aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2017-09-07 23:19:51 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:29:29 +0800
commit7f175f7c52d3c92eb8fce3e5ce57a348f489e4d3 (patch)
treeb81a7bb89965029463bba3859968686a3a8fe864 /net-p2p
parentf9afb1781e62c363a279d41446889e0ed48d6e41 (diff)
downloadfreebsd-ports-gnome-7f175f7c52d3c92eb8fce3e5ce57a348f489e4d3.tar.gz
freebsd-ports-gnome-7f175f7c52d3c92eb8fce3e5ce57a348f489e4d3.tar.zst
freebsd-ports-gnome-7f175f7c52d3c92eb8fce3e5ce57a348f489e4d3.zip
Restore the maximum piece size of 2^30 introduced in r435987.
PR: 221717 Reported by: Anton Sayetsky
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mktorrent/Makefile1
-rw-r--r--net-p2p/mktorrent/files/patch-init.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
index 49b70c37cf56..901baa96950e 100644
--- a/net-p2p/mktorrent/Makefile
+++ b/net-p2p/mktorrent/Makefile
@@ -4,6 +4,7 @@
PORTNAME= mktorrent
PORTVERSION= 1.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-p2p
MAINTAINER= ports@FreeBSD.org
diff --git a/net-p2p/mktorrent/files/patch-init.c b/net-p2p/mktorrent/files/patch-init.c
new file mode 100644
index 000000000000..d54ad940705f
--- /dev/null
+++ b/net-p2p/mktorrent/files/patch-init.c
@@ -0,0 +1,15 @@
+--- init.c.orig 2017-09-07 14:49:58 UTC
++++ init.c
+@@ -512,10 +512,10 @@ EXPORT void init(metafile_t *m, int argc
+
+ /* set the correct piece length.
+ default is 2^18 = 256kb. */
+- if (m->piece_length < 15 || m->piece_length > 28) {
++ if (m->piece_length < 15 || m->piece_length > 30) {
+ fprintf(stderr,
+ "The piece length must be a number between "
+- "15 and 28.\n");
++ "15 and 30.\n");
+ exit(EXIT_FAILURE);
+ }
+ m->piece_length = 1 << m->piece_length;