aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-04-07 21:46:21 +0800
committerpav <pav@FreeBSD.org>2010-04-07 21:46:21 +0800
commitc83c0aefc619d94d5fdbd6f066e69a8be5623deb (patch)
treed34e71d44e0296ab7ae20fb106f17a536aaa4dbf /net-p2p
parentf103487af6b6f17349c8c11ad30c434f3779e970 (diff)
downloadfreebsd-ports-gnome-c83c0aefc619d94d5fdbd6f066e69a8be5623deb.tar.gz
freebsd-ports-gnome-c83c0aefc619d94d5fdbd6f066e69a8be5623deb.tar.zst
freebsd-ports-gnome-c83c0aefc619d94d5fdbd6f066e69a8be5623deb.zip
- Update to 0.3.1
PR: ports/145421 Submitted by: Dmitry Yashin <yashin.dm@gmail.com> (maintainer)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/uhub/Makefile2
-rw-r--r--net-p2p/uhub/distinfo6
-rw-r--r--net-p2p/uhub/files/patch-GNUmakefile18
-rw-r--r--net-p2p/uhub/files/patch-select.c13
4 files changed, 12 insertions, 27 deletions
diff --git a/net-p2p/uhub/Makefile b/net-p2p/uhub/Makefile
index e69262fc4c9b..6020b66f0aef 100644
--- a/net-p2p/uhub/Makefile
+++ b/net-p2p/uhub/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= uhub
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= net-p2p
MASTER_SITES= http://www.extatic.org/downloads/uhub/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
diff --git a/net-p2p/uhub/distinfo b/net-p2p/uhub/distinfo
index ac8d95967f6d..6d030cdba413 100644
--- a/net-p2p/uhub/distinfo
+++ b/net-p2p/uhub/distinfo
@@ -1,3 +1,3 @@
-MD5 (uhub-0.3.0-src.tar.gz) = d112694a9323bb47a8f62606633a8cf2
-SHA256 (uhub-0.3.0-src.tar.gz) = 24db78bf2f6c0da144197c49a1b37b88cec9f6d991f735d6544686c9f536fef1
-SIZE (uhub-0.3.0-src.tar.gz) = 134379
+MD5 (uhub-0.3.1-src.tar.gz) = 7e2810dceede442ba5c108bec50de4e5
+SHA256 (uhub-0.3.1-src.tar.gz) = 637b605c029738434438b5fe00a09a10a7bf3debddbe53b9dd12825644e68da0
+SIZE (uhub-0.3.1-src.tar.gz) = 147350
diff --git a/net-p2p/uhub/files/patch-GNUmakefile b/net-p2p/uhub/files/patch-GNUmakefile
index 2dfe51182591..168f531b995f 100644
--- a/net-p2p/uhub/files/patch-GNUmakefile
+++ b/net-p2p/uhub/files/patch-GNUmakefile
@@ -1,16 +1,16 @@
---- GNUmakefile.orig 2010-01-25 01:38:25.000000000 +0300
-+++ GNUmakefile 2010-02-01 12:12:34.000000000 +0300
-@@ -3,7 +3,7 @@
- ## Copyright (C) 2007-2010, Jan Vidar Krey <janvidar@extatic.org>
- #
+--- GNUmakefile 2010-04-05 18:53:17.000000000 +0400
++++ GNUmakefile.orig 2010-04-06 11:19:35.000000000 +0400
+@@ -5,7 +5,7 @@
+
+ -include Makefile.private
-CC = gcc
+CC ?= gcc
LD := $(CC)
MV := mv
RANLIB := ranlib
-@@ -36,11 +36,12 @@
- GIT_REVISION ?= NO
+@@ -44,10 +44,10 @@
+ BIN_EXT ?= .exe
else
DESTDIR ?= /
-UHUB_CONF_DIR ?= $(DESTDIR)/etc/uhub
@@ -22,11 +22,9 @@
+CFLAGS += -I$(LOCALBASE)/include
+LDFLAGS += -L$(LOCALBASE)/lib
BIN_EXT ?=
-+GIT_REVISION ?= NO
endif
- ifeq ($(SILENT),YES)
-@@ -225,7 +226,7 @@
+@@ -249,7 +249,7 @@
@if [ ! -d $(UHUB_CONF_DIR) ]; then echo Creating $(UHUB_CONF_DIR); mkdir -p $(UHUB_CONF_DIR); fi
@if [ ! -f $(UHUB_CONF_DIR)/uhub.conf ]; then cp doc/uhub.conf $(UHUB_CONF_DIR); fi
@if [ ! -f $(UHUB_CONF_DIR)/users.conf ]; then cp doc/users.conf $(UHUB_CONF_DIR); fi
diff --git a/net-p2p/uhub/files/patch-select.c b/net-p2p/uhub/files/patch-select.c
deleted file mode 100644
index d97ec9ca5e7b..000000000000
--- a/net-p2p/uhub/files/patch-select.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/network/select.c.orig 2010-01-25 01:38:25.000000000 +0300
-+++ src/network/select.c 2010-02-01 12:57:36.000000000 +0300
-@@ -101,8 +101,8 @@
- FD_ZERO(&g_backend->wfds);
-
- size_t secs = timeout_queue_get_next_timeout(&g_backend->timeout_queue, g_backend->now);
-- tval.tv_secs = secs;
-- tval.tv_usecs = 0;
-+ tval.tv_sec = secs;
-+ tval.tv_usec = 0;
-
- for (n = 0, found = 0; found < g_backend->num && n < g_backend->max; n++)
- {