aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2018-01-31 20:23:11 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:32:19 +0800
commitec27ff12a288c43535d111d8a467f7c9203cc56d (patch)
tree1264ab1f8001f6b84373999aa11ce3e83ff9718c /net-p2p
parent693889da873ae06952a9074d6adbb1dd884c09a4 (diff)
downloadfreebsd-ports-gnome-ec27ff12a288c43535d111d8a467f7c9203cc56d.tar.gz
freebsd-ports-gnome-ec27ff12a288c43535d111d8a467f7c9203cc56d.tar.zst
freebsd-ports-gnome-ec27ff12a288c43535d111d8a467f7c9203cc56d.zip
net-p2p/qtum: Mark as broken on i386
c++ -std=c++11 -DHAVE_CONFIG_H -I. -I../src/config -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -DQTUM_BUILD -I./cryptopp -I./cryptopp/include -DQTUM_BUILD -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS -Wstack-protector -fstack-protector-all -DETH_FATDB=1 -DNDEBUG -fPIC -O2 -g2 -O2 -pipe -fstack-protector -fno-strict-aliasing -MT cryptopp/cryptopp_libcryptopp_a-sha.o -MD -MP -MF cryptopp/.deps/cryptopp_libcryptopp_a-sha.Tpo -c -o cryptopp/cryptopp_libcryptopp_a-sha.o `test -f 'cryptopp/sha.cpp' || echo './'`cryptopp/sha.cpp cryptopp/sha.cpp:1288:2: error: invalid operand for instruction ASJ( jnz, 0, b) ^ ./cryptopp/cpu.h:469:23: note: expanded from macro 'ASJ' #define ASJ(x, y, z) GNU_ASJ(x, y, z) ^ ./cryptopp/cpu.h:463:27: note: expanded from macro 'GNU_ASJ' #define GNU_ASJ(x, y, z) #x " " #y #z ";" NEW_LINE ^ <scratch space>:219:2: note: expanded from here "jnz" ^ <inline asm>:80:1: note: instantiated into assembly here jnz 0b; ^
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qtum/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-p2p/qtum/Makefile b/net-p2p/qtum/Makefile
index cb96ca1d6d45..47715f80ff31 100644
--- a/net-p2p/qtum/Makefile
+++ b/net-p2p/qtum/Makefile
@@ -11,6 +11,8 @@ COMMENT= PoS cryptocurrency that can execute smart contract as part of an UTXO
LICENSE= GPLv3
+BROKEN_i386= does not compile: invalid operand for instruction ... ASJ(jnz, 0, b) ... "jnz"
+
BUILD_DEPENDS= libzmq4>0:net/libzmq4
RUN_DEPENDS= libzmq4>0:net/libzmq4
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \