aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2013-05-11 01:34:56 +0800
committerfjoe <fjoe@FreeBSD.org>2013-05-11 01:34:56 +0800
commit073a161f85ef5faa3b923aa2e61af3752b0ee9ca (patch)
tree33d1093b3315f2c20eb20efefb35f765710930f9 /net-p2p
parent6f914c75b39bcb2da472f107c6499e47bb8e5481 (diff)
downloadfreebsd-ports-gnome-073a161f85ef5faa3b923aa2e61af3752b0ee9ca.tar.gz
freebsd-ports-gnome-073a161f85ef5faa3b923aa2e61af3752b0ee9ca.tar.zst
freebsd-ports-gnome-073a161f85ef5faa3b923aa2e61af3752b0ee9ca.zip
- Unbreak the build (link with -lboost_system)
- Fix COMMENT for eiskaltdcpp-cli - Take maintainership Approved by: MAINTAINER
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp-cli/Makefile4
-rw-r--r--net-p2p/eiskaltdcpp-daemon/Makefile4
-rw-r--r--net-p2p/eiskaltdcpp-daemon/files/patch-CMakeLists.txt13
-rw-r--r--net-p2p/eiskaltdcpp-daemon/files/patch-nasdc__CMakeLists.txt6
-rw-r--r--net-p2p/eiskaltdcpp-data/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile4
-rw-r--r--net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt13
-rw-r--r--net-p2p/eiskaltdcpp-lib/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-qt/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-qt/files/patch-CMakeLists.txt13
10 files changed, 43 insertions, 20 deletions
diff --git a/net-p2p/eiskaltdcpp-cli/Makefile b/net-p2p/eiskaltdcpp-cli/Makefile
index 53417ce7c3c9..792cfb3291da 100644
--- a/net-p2p/eiskaltdcpp-cli/Makefile
+++ b/net-p2p/eiskaltdcpp-cli/Makefile
@@ -11,8 +11,8 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
-COMMENT= Shared data for EiskaltDC++ GUIs
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= EiskaltDC++ Direct Connect command-line interface
LICENSE= GPLv3
diff --git a/net-p2p/eiskaltdcpp-daemon/Makefile b/net-p2p/eiskaltdcpp-daemon/Makefile
index 8e1b922cf7a3..247961e961bf 100644
--- a/net-p2p/eiskaltdcpp-daemon/Makefile
+++ b/net-p2p/eiskaltdcpp-daemon/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= EiskaltDC++ Direct Connect client daemon
LICENSE= GPLv3
@@ -16,8 +16,6 @@ LICENSE= GPLv3
LIB_DEPENDS+= eiskaltdcpp:${PORTSDIR}/net-p2p/eiskaltdcpp-lib
BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
-BROKEN= does not link
-
PROJECTHOST= eiskaltdc
USE_XZ= yes
diff --git a/net-p2p/eiskaltdcpp-daemon/files/patch-CMakeLists.txt b/net-p2p/eiskaltdcpp-daemon/files/patch-CMakeLists.txt
index 6667079b1c8e..7fa7d5147306 100644
--- a/net-p2p/eiskaltdcpp-daemon/files/patch-CMakeLists.txt
+++ b/net-p2p/eiskaltdcpp-daemon/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2011-10-02 18:12:43.000000000 +0300
-+++ CMakeLists.txt 2011-10-03 10:40:18.000000000 +0300
+--- CMakeLists.txt.orig 2011-10-02 22:12:43.000000000 +0700
++++ CMakeLists.txt 2013-05-09 17:37:33.000000000 +0700
+@@ -256,7 +256,7 @@
+ endif()
+ message (STATUS "USED LOCAL BOOST HEADERS")
+ else (LOCAL_BOOST)
+- find_package (Boost REQUIRED)
++ find_package (Boost COMPONENTS system REQUIRED)
+ if (Boost_VERSION VERSION_LESS 103900)
+ add_definitions(-DFIX_FOR_OLD_BOOST)
+ endif()
@@ -370,16 +370,14 @@
else (MINGW)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
diff --git a/net-p2p/eiskaltdcpp-daemon/files/patch-nasdc__CMakeLists.txt b/net-p2p/eiskaltdcpp-daemon/files/patch-nasdc__CMakeLists.txt
index 55ce7fe7b86f..2aa2f72cb7db 100644
--- a/net-p2p/eiskaltdcpp-daemon/files/patch-nasdc__CMakeLists.txt
+++ b/net-p2p/eiskaltdcpp-daemon/files/patch-nasdc__CMakeLists.txt
@@ -1,5 +1,5 @@
---- nasdc/CMakeLists.txt.orig 2011-10-02 18:12:43.000000000 +0300
-+++ nasdc/CMakeLists.txt 2011-10-03 10:51:06.000000000 +0300
+--- nasdc/CMakeLists.txt.orig 2011-10-02 22:12:43.000000000 +0700
++++ nasdc/CMakeLists.txt 2013-05-09 17:38:53.000000000 +0700
@@ -49,7 +49,16 @@
${nasdc_SRCS}
)
@@ -14,7 +14,7 @@
+ endif (DCPP_LIB)
+endif (BUILD_LIB)
+
-+target_link_libraries (nasdc ${DCPP_LIB} ${XMLRPCLIBS})
++target_link_libraries (nasdc ${DCPP_LIB} ${XMLRPCLIBS} ${Boost_LIBRARIES} ${GETTEXT_LIBRARIES})
if (UNIX)
set (BINDIR bin)
diff --git a/net-p2p/eiskaltdcpp-data/Makefile b/net-p2p/eiskaltdcpp-data/Makefile
index df61dd54c47f..6b547b268f4a 100644
--- a/net-p2p/eiskaltdcpp-data/Makefile
+++ b/net-p2p/eiskaltdcpp-data/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= Shared data for EiskaltDC++ GUIs
LICENSE= GPLv3
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 8dda4d169366..7b16d72da0b8 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= EiskaltDC++ Direct Connect client GTK GUI
LICENSE= GPLv3
@@ -17,8 +17,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/eiskaltdcpp/keep_me:${PORTSDIR}/net-p2p/eiskaltd
LIB_DEPENDS= eiskaltdcpp:${PORTSDIR}/net-p2p/eiskaltdcpp-lib
BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
-BROKEN= does not build
-
CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
diff --git a/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt b/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
index 526a0d24a262..f1f6e7321d3b 100644
--- a/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
+++ b/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ./CMakeLists.txt.orig 2011-10-02 18:12:43.000000000 +0300
-+++ ./CMakeLists.txt 2011-10-10 11:16:46.000000000 +0300
+--- CMakeLists.txt.orig 2011-10-02 22:12:43.000000000 +0700
++++ CMakeLists.txt 2013-05-09 17:58:03.000000000 +0700
@@ -212,14 +212,14 @@
if (USE_LIBGNOME2)
@@ -17,6 +17,15 @@
else (USE_LIBNOTIFY)
message (STATUS "Building without libnotify support")
endif (USE_LIBNOTIFY)
+@@ -256,7 +256,7 @@
+ endif()
+ message (STATUS "USED LOCAL BOOST HEADERS")
+ else (LOCAL_BOOST)
+- find_package (Boost REQUIRED)
++ find_package (Boost COMPONENTS system REQUIRED)
+ if (Boost_VERSION VERSION_LESS 103900)
+ add_definitions(-DFIX_FOR_OLD_BOOST)
+ endif()
@@ -370,16 +370,14 @@
else (MINGW)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
diff --git a/net-p2p/eiskaltdcpp-lib/Makefile b/net-p2p/eiskaltdcpp-lib/Makefile
index 9b297725c5a4..f59438796985 100644
--- a/net-p2p/eiskaltdcpp-lib/Makefile
+++ b/net-p2p/eiskaltdcpp-lib/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= A Direct Connect client shared library
LICENSE= GPLv3
diff --git a/net-p2p/eiskaltdcpp-qt/Makefile b/net-p2p/eiskaltdcpp-qt/Makefile
index c67fe0b487bf..8fe38051e155 100644
--- a/net-p2p/eiskaltdcpp-qt/Makefile
+++ b/net-p2p/eiskaltdcpp-qt/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= EiskaltDC++ Direct Connect client Qt GUI
LICENSE= GPLv3
diff --git a/net-p2p/eiskaltdcpp-qt/files/patch-CMakeLists.txt b/net-p2p/eiskaltdcpp-qt/files/patch-CMakeLists.txt
index 6667079b1c8e..33571dc4a48a 100644
--- a/net-p2p/eiskaltdcpp-qt/files/patch-CMakeLists.txt
+++ b/net-p2p/eiskaltdcpp-qt/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
---- CMakeLists.txt.orig 2011-10-02 18:12:43.000000000 +0300
-+++ CMakeLists.txt 2011-10-03 10:40:18.000000000 +0300
+--- CMakeLists.txt.orig 2011-10-02 22:12:43.000000000 +0700
++++ CMakeLists.txt 2013-05-10 19:57:21.000000000 +0700
+@@ -256,7 +256,7 @@
+ endif()
+ message (STATUS "USED LOCAL BOOST HEADERS")
+ else (LOCAL_BOOST)
+- find_package (Boost REQUIRED)
++ find_package (Boost COMPONENTS system REQUIRED)
+ if (Boost_VERSION VERSION_LESS 103900)
+ add_definitions(-DFIX_FOR_OLD_BOOST)
+ endif()
@@ -370,16 +370,14 @@
else (MINGW)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")