aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-10-31 18:08:09 +0800
committerdanfe <danfe@FreeBSD.org>2017-10-31 18:08:09 +0800
commit09d638dcb2b0bba442c4c72c5a99285c5cb8217a (patch)
treed26d93a3c585ff69a45847b86d9f17c31af9cc6c /net-p2p
parent9fdda1685053a016724700d519e81406f43aaa86 (diff)
downloadfreebsd-ports-gnome-09d638dcb2b0bba442c4c72c5a99285c5cb8217a.tar.gz
freebsd-ports-gnome-09d638dcb2b0bba442c4c72c5a99285c5cb8217a.tar.zst
freebsd-ports-gnome-09d638dcb2b0bba442c4c72c5a99285c5cb8217a.zip
- Update `net-p2p/torrent-file-editor' to version 0.3.7
- TIMESTAMP (torrent-file-editor-0.3.7.tar.gz) = 1506418597 Found out via: repology.org Didn't report: portscout :(
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrent-file-editor/Makefile2
-rw-r--r--net-p2p/torrent-file-editor/distinfo6
-rw-r--r--net-p2p/torrent-file-editor/files/patch-CMakeLists.txt17
3 files changed, 17 insertions, 8 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 8701ce22e5dd..a7f7535a40aa 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= torrent-file-editor
-PORTVERSION= 0.3.4
+PORTVERSION= 0.3.7
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/v${PORTVERSION}
diff --git a/net-p2p/torrent-file-editor/distinfo b/net-p2p/torrent-file-editor/distinfo
index 686c6f302767..14a8eef8d74b 100644
--- a/net-p2p/torrent-file-editor/distinfo
+++ b/net-p2p/torrent-file-editor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492441821
-SHA256 (torrent-file-editor-0.3.4.tar.gz) = 6f3dda0fe0dee76bd1e15f62af4d29b11e6f4149d05ed520e5a7c2baa269a08c
-SIZE (torrent-file-editor-0.3.4.tar.gz) = 302621
+TIMESTAMP = 1506418597
+SHA256 (torrent-file-editor-0.3.7.tar.gz) = f423f6eab33d9e63d9584dfb67a117bee37d26af81622d7737b2b28bd5b27e68
+SIZE (torrent-file-editor-0.3.7.tar.gz) = 328752
diff --git a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
index 6f23f3f190fb..6117e3ef41b1 100644
--- a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
+++ b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
@@ -1,10 +1,19 @@
---- CMakeLists.txt.orig 2017-04-17 14:19:04 UTC
+--- CMakeLists.txt.orig 2017-09-26 09:30:09 UTC
+++ CMakeLists.txt
-@@ -73,6 +73,7 @@ if(QT5_BUILD)
+@@ -46,7 +46,7 @@ if(CMAKE_BUILD_TYPE STREQUAL Release OR CMAKE_BUILD_TY
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+
+ # #warning is not an error
+- if(NOT APPLE)
++ if(NOT APPLE AND NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=cpp")
+ else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-#warnings")
+@@ -108,6 +108,7 @@ if(QT5_BUILD)
else()
find_package(Qt4 REQUIRED)
find_package(QJSON 0.8.0 REQUIRED)
+ include_directories(${QJSON_INCLUDE_DIR})
- include(${QT_USE_FILE})
- endif()
+ add_definitions("'-DQStringLiteral(str)=QString::fromUtf8(\"\" str \"\", sizeof(str) - 1)'")
+ if(WIN32)