aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-06-05 17:42:04 +0800
committeralepulver <alepulver@FreeBSD.org>2007-06-05 17:42:04 +0800
commit2cf117418052548d0bd835a34e5861daa1f938ee (patch)
tree1915c57d1ba25fbc5cefc63ab0de951ef0147e60 /net-p2p
parent0852eb9200ee1db610cd93e6d11154fec267fd0f (diff)
downloadfreebsd-ports-gnome-2cf117418052548d0bd835a34e5861daa1f938ee.tar.gz
freebsd-ports-gnome-2cf117418052548d0bd835a34e5861daa1f938ee.tar.zst
freebsd-ports-gnome-2cf117418052548d0bd835a34e5861daa1f938ee.zip
- Add USE_GCC=3.4 since doesn't build with 4.x (seems a devel/boost problem).
- Add part of removed patch to sync with net-p2p/rblibtorrent, since they are currently of the same version.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile1
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp10
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile1
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp10
4 files changed, 22 insertions, 0 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 5943f90962dd..6600ed0a0456 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GCC= 3.4
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp
new file mode 100644
index 000000000000..65260b013846
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp
@@ -0,0 +1,10 @@
+--- include/libtorrent/asio/detail/socket_ops.hpp Wed May 16 00:35:55 2007
++++ include/libtorrent/asio/detail/socket_ops.hpp.orig Wed May 16 00:35:45 2007
+66c66
+< #if defined(__MACH__) && defined(__APPLE__)
+---
+> #if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+298c298
+< #elif defined(__MACH__) && defined(__APPLE__)
+---
+> #elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index 5943f90962dd..6600ed0a0456 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GCC= 3.4
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp b/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp
new file mode 100644
index 000000000000..65260b013846
--- /dev/null
+++ b/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp
@@ -0,0 +1,10 @@
+--- include/libtorrent/asio/detail/socket_ops.hpp Wed May 16 00:35:55 2007
++++ include/libtorrent/asio/detail/socket_ops.hpp.orig Wed May 16 00:35:45 2007
+66c66
+< #if defined(__MACH__) && defined(__APPLE__)
+---
+> #if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+298c298
+< #elif defined(__MACH__) && defined(__APPLE__)
+---
+> #elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)