aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2011-01-10 15:23:17 +0800
committerdougb <dougb@FreeBSD.org>2011-01-10 15:23:17 +0800
commit47bfead340928847dd10f7e5042afa1ca46c65c9 (patch)
tree77d66d355fa75dbeab63e696aa70079ef5b01e45 /net-p2p
parentf665a477e7028127a9c8646964f4d50b24af4036 (diff)
downloadfreebsd-ports-gnome-47bfead340928847dd10f7e5042afa1ca46c65c9.tar.gz
freebsd-ports-gnome-47bfead340928847dd10f7e5042afa1ca46c65c9.tar.zst
freebsd-ports-gnome-47bfead340928847dd10f7e5042afa1ca46c65c9.zip
Introduce version 2.6.0, which has numerous new features and improvements
vs. 2.3.x including, but not limited to: * Many UI improvements * Run external program on torrent completion * qBittorrent can now act as a tracker * New and improved RSS feed automated downloader * Web UI improvements
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/qbittorrent-26/Makefile51
-rw-r--r--net-p2p/qbittorrent-26/distinfo2
-rw-r--r--net-p2p/qbittorrent-26/files/patch-src__filesystemwatcher.h11
-rw-r--r--net-p2p/qbittorrent-26/files/patch-src__misc.cpp11
-rw-r--r--net-p2p/qbittorrent-26/pkg-descr22
-rw-r--r--net-p2p/qbittorrent-26/pkg-plist38
7 files changed, 136 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 36c2499318e4..4eb6e925ffbb 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -106,6 +106,7 @@
SUBDIR += py-transmissionrpc
SUBDIR += py-vertex
SUBDIR += qbittorrent-23
+ SUBDIR += qbittorrent-26
SUBDIR += qtella
SUBDIR += qtorrent
SUBDIR += rtgui
diff --git a/net-p2p/qbittorrent-26/Makefile b/net-p2p/qbittorrent-26/Makefile
new file mode 100644
index 000000000000..f9271bafc6fc
--- /dev/null
+++ b/net-p2p/qbittorrent-26/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: qbittorrent-26
+# Date created: 10 January 2011
+# Whom: dougb@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= qbittorrent
+PORTVERSION= 2.6.0
+CATEGORIES= net-p2p ipv6
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PKGNAME}/
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Bittorrent client using Qt4 and libtorrent-rasterbar
+
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
+ torrent-rasterbar.5:${PORTSDIR}/net-p2p/libtorrent-rasterbar-14 \
+ GeoIP.5:${PORTSDIR}/net/GeoIP
+
+MAKE_JOBS_SAFE= yes
+
+CONFLICTS= qbittorrent-2.[2345789].*
+
+OPTIONS= NOTIFY "Enable libnotify support" on
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network xml \
+ moc_build qmake_build rcc_build uic_build
+QT_NONSTANDARD= yes
+HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+MAN1= qbittorrent.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+= --disable-libnotify
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
+ ${WRKSRC}/unixconf.pri
+ @${ECHO_CMD} "LIBS+= -lexecinfo" >> ${WRKSRC}/src/src.pro
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/qbittorrent
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/qbittorrent-26/distinfo b/net-p2p/qbittorrent-26/distinfo
new file mode 100644
index 000000000000..28ec8d9ea565
--- /dev/null
+++ b/net-p2p/qbittorrent-26/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qbittorrent-2.6.0.tar.gz) = 5ecf2125870950861913368daa862bc0b083714563ca8ac074954938fcff9670
+SIZE (qbittorrent-2.6.0.tar.gz) = 2900632
diff --git a/net-p2p/qbittorrent-26/files/patch-src__filesystemwatcher.h b/net-p2p/qbittorrent-26/files/patch-src__filesystemwatcher.h
new file mode 100644
index 000000000000..ecafa3807181
--- /dev/null
+++ b/net-p2p/qbittorrent-26/files/patch-src__filesystemwatcher.h
@@ -0,0 +1,11 @@
+--- src/filesystemwatcher.h.orig 2011-01-07 11:42:34.000000000 -0800
++++ src/filesystemwatcher.h 2011-01-09 23:11:01.000000000 -0800
+@@ -12,7 +12,7 @@
+ #include <QSet>
+ #include <iostream>
+ #include <errno.h>
+-#ifdef Q_WS_MAC
++#if defined(Q_WS_MAC) || defined(__FreeBSD__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
+ #include <string.h>
diff --git a/net-p2p/qbittorrent-26/files/patch-src__misc.cpp b/net-p2p/qbittorrent-26/files/patch-src__misc.cpp
new file mode 100644
index 000000000000..efc00d6f52af
--- /dev/null
+++ b/net-p2p/qbittorrent-26/files/patch-src__misc.cpp
@@ -0,0 +1,11 @@
+--- src/misc.cpp.orig 2011-01-06 04:12:07.000000000 -0800
++++ src/misc.cpp 2011-01-09 23:11:01.000000000 -0800
+@@ -60,7 +60,7 @@
+ #endif
+
+ #ifndef Q_WS_WIN
+-#ifdef Q_WS_MAC
++#if defined Q_WS_MAC || defined(__FreeBSD__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
+ #else
diff --git a/net-p2p/qbittorrent-26/pkg-descr b/net-p2p/qbittorrent-26/pkg-descr
new file mode 100644
index 000000000000..6c8a36048adb
--- /dev/null
+++ b/net-p2p/qbittorrent-26/pkg-descr
@@ -0,0 +1,22 @@
+qBittorrent v2 is the closest open source (GNU GPL v2 license) equivalent
+to utorrent. It is based on the Qt4 toolkit and libtorrent-rasterbar.
+
+Features:
+
+ Well-integrated and extensible Search Engine
+ Simultaneous search in most famous BitTorrent search sites
+ Per-category-specific search requests (e.g. Books, Music, Movies)
+ All Bittorrent extensions
+ * DHT, Peer Exchange, Full encryption, Magnet URI
+ Remote control through a Web user interface
+ * Nearly identical to the regular UI, all in Ajax
+ Advanced control over trackers, peers and torrents
+ * Torrents queueing and prioritizing
+ * Torrent content selection and prioritizing
+ UPnP / NAT-PMP port forwarding support
+ Available in ~25 languages (Unicode support)
+ uTorrent spoofing to bypass private trackers whitelisting
+ Advanced RSS support with download filters (inc. regex)
+ IP Filtering (eMule and PeerGuardian compatible)
+
+WWW: http://www.qbittorrent.org/
diff --git a/net-p2p/qbittorrent-26/pkg-plist b/net-p2p/qbittorrent-26/pkg-plist
new file mode 100644
index 000000000000..aeb2a48626fc
--- /dev/null
+++ b/net-p2p/qbittorrent-26/pkg-plist
@@ -0,0 +1,38 @@
+bin/qbittorrent
+share/applications/qBittorrent.desktop
+share/icons/hicolor/128x128/apps/qbittorrent.png
+share/icons/hicolor/16x16/apps/qbittorrent.png
+share/icons/hicolor/192x192/apps/qbittorrent.png
+share/icons/hicolor/22x22/apps/qbittorrent.png
+share/icons/hicolor/24x24/apps/qbittorrent.png
+share/icons/hicolor/32x32/apps/qbittorrent.png
+share/icons/hicolor/36x36/apps/qbittorrent.png
+share/icons/hicolor/48x48/apps/qbittorrent.png
+share/icons/hicolor/64x64/apps/qbittorrent.png
+share/icons/hicolor/72x72/apps/qbittorrent.png
+share/icons/hicolor/96x96/apps/qbittorrent.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/36x36/apps
+@dirrmtry share/icons/hicolor/36x36
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/192x192/apps
+@dirrmtry share/icons/hicolor/192x192
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications