aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2012-02-27 23:06:26 +0800
committerarved <arved@FreeBSD.org>2012-02-27 23:06:26 +0800
commit8fa157a86ca61ae5e52de54da4143241c4558345 (patch)
tree4b609943246628744a42e4c67275bace7e64d50a /net-p2p
parent5f2d82df9a3380eeaeceaad4aa69220c3b306c5e (diff)
downloadfreebsd-ports-gnome-8fa157a86ca61ae5e52de54da4143241c4558345.tar.gz
freebsd-ports-gnome-8fa157a86ca61ae5e52de54da4143241c4558345.tar.zst
freebsd-ports-gnome-8fa157a86ca61ae5e52de54da4143241c4558345.zip
Update to 0.5.3a
PR: 164979 Submitted by: maintainer
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/retroshare/Makefile48
-rw-r--r--net-p2p/retroshare/distinfo4
-rw-r--r--net-p2p/retroshare/files/patch-libbitdht-src-util-bdrandom.cc11
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-dbase-findex.h17
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfilecreator.h10
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfileprovider.h10
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-libretroshare.pro10
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsinit.cc88
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsloginhandler.cc28
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.cc10
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.h14
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-util-rsdir.h20
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-util-rsdiscspace.cc10
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare-src-util-rsrandom.cc11
-rw-r--r--net-p2p/retroshare/files/patch-retroshare-gui-src-RetroShare.pro17
-rw-r--r--net-p2p/retroshare/files/rsinit.h78
-rw-r--r--net-p2p/retroshare/pkg-plist1
17 files changed, 36 insertions, 351 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 586d0cdd9618..34f496c18a9f 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= retroshare
-PORTVERSION= 0.5.2a
+PORTVERSION= 0.5.3a
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/${BINARY}/${PORTVERSION}
@@ -29,35 +29,53 @@ QT_COMPONENTS= corelib gui network xml script designer_build uic_build \
qmake_build moc_build rcc_build
HAS_CONFIGURE= yes
BINARY= RetroShare
+BINARY_NOGUI= retroshare-nogui
+MAKE_JOBS_UNSAFE=yes
DESKTOP_ENTRIES="${BINARY}" "${COMMENT}" "" "${BINARY}" \
"Network;FileTransfer;" true
-CFLAGS+= -I${LOCALBASE}/include/gpgme
+OPTIONS= NOGUI "Also build nogui binary" Off
-USE_DOS2UNIX= retroshare-gui/src/${BINARY}.pro
+.include <bsd.port.options.mk>
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} PREFIX=${PREFIX} ${BINARY}.pro
post-patch:
- ${CP} ${FILESDIR}/rsinit.h ${WRKSRC}/libretroshare/src/rsserver
+ @${REINPLACE_CMD} -e 's|plugins|#plugins|' ${WRKSRC}/${BINARY}.pro
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/libretroshare/src/libretroshare.pro
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/retroshare-gui/src/RetroShare.pro
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/retroshare-nogui/src/retroshare-nogui.pro
+ @${REINPLACE_CMD} -e 's|/usr/local/share/retroshare|${DATADIR}|' \
+ ${WRKSRC}/libretroshare/src/rsserver/rsinit.cc
+.if defined(WITHOUT_NOGUI)
+ @${REINPLACE_CMD} -e 's|retroshare-nogui|#retroshare-nogui|' \
+ ${WRKSRC}/${BINARY}.pro
+ @${REINPLACE_CMD} -e 's|RetroShare.pro \\|RetroShare.pro|' \
+ ${WRKSRC}/${BINARY}.pro
+.else
+ @${REINPLACE_CMD} -e 's|retroshare-nogui.pro \\|retroshare-nogui.pro|' \
+ ${WRKSRC}/${BINARY}.pro
+.endif
+
+pre-install:
+.if defined(WITHOUT_NOGUI)
+PLIST_SUB+= NOGUI="@comment "
+.else
+PLIST_SUB+= NOGUI=""
+.endif
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/retroshare-gui/src/${BINARY} ${PREFIX}/bin
+.if defined(WITH_NOGUI)
+ ${INSTALL_PROGRAM} ${WRKSRC}/retroshare-nogui/src/${BINARY_NOGUI} ${PREFIX}/bin
+.endif
${MKDIR} ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/libbitdht/src/example/bdboot.txt ${DATADIR}
- @${ECHO_MSG} "**************************************************"
- @${ECHO_MSG} "* POST INSTALL *"
- @${ECHO_MSG} "**************************************************"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "After you have created an account, you should copy"
- @${ECHO_MSG} "${DATADIR}/bdboot.txt into your"
- @${ECHO_MSG} "~/.retroshare/YOURCERT/ directory to seed DHT with"
- @${ECHO_MSG} "initial nodes. UPnP does not work right now, you"
- @${ECHO_MSG} "have to use port forwarding to connect to others."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "**************************************************"
.include <bsd.port.mk>
diff --git a/net-p2p/retroshare/distinfo b/net-p2p/retroshare/distinfo
index 4d935e7e2106..24ec4061d29e 100644
--- a/net-p2p/retroshare/distinfo
+++ b/net-p2p/retroshare/distinfo
@@ -1,2 +1,2 @@
-SHA256 (RetroShare-v0.5.2a.tar.gz) = 33838c0234e779e6b310bbd19bf6c5c0394e84cc5b418114b68f0cac8c1eec18
-SIZE (RetroShare-v0.5.2a.tar.gz) = 10334273
+SHA256 (RetroShare-v0.5.3a.tar.gz) = 744f3d410c57e51455d07fe9e77dc9e645a58de454ce5248aa8704c41d2df3a4
+SIZE (RetroShare-v0.5.3a.tar.gz) = 6419672
diff --git a/net-p2p/retroshare/files/patch-libbitdht-src-util-bdrandom.cc b/net-p2p/retroshare/files/patch-libbitdht-src-util-bdrandom.cc
deleted file mode 100644
index 1a3b57be3707..000000000000
--- a/net-p2p/retroshare/files/patch-libbitdht-src-util-bdrandom.cc
+++ /dev/null
@@ -1,11 +0,0 @@
-+++ libbitdht/src/util/bdrandom.cc 2012-01-15 03:45:36.000000000 +0100
---- libbitdht/src/util/bdrandom.cc.orig 2012-01-15 03:45:07.000000000 +0100
-@@ -13,7 +13,7 @@
- #ifdef __APPLE__
- static bool auto_seed = bdRandom::seed( (time(NULL) + pthread_mach_thread_np(pthread_self())*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
- #else
-+// static bool auto_seed = bdRandom::seed( (time(NULL) + pthread_self()*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
-- static bool auto_seed = bdRandom::seed( (time(NULL) + pthread_self()*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
- #endif
- #endif
- bool bdRandom::seed(uint32_t s)
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-dbase-findex.h b/net-p2p/retroshare/files/patch-libretroshare-src-dbase-findex.h
deleted file mode 100644
index dfcf1e618ed9..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-dbase-findex.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- libretroshare/src/dbase/findex.h.orig 2011-04-15 22:21:52.000000000 +0200
-+++ libretroshare/src/dbase/findex.h 2012-01-15 03:55:27.000000000 +0100
-@@ -33,6 +33,14 @@
- #include <stdint.h>
- #include "retroshare/rstypes.h"
-
-+#include <dirent.h>
-+#include <fnmatch.h>
-+#include <unistd.h>
-+#define O_LARGEFILE 0100000
-+#define stat64 stat
-+#define _stat stat
-+#define _getcwd getcwd
-+
- class ostream;
-
- /******************************************************************************************
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfilecreator.h b/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfilecreator.h
deleted file mode 100644
index 1c9d403ec339..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfilecreator.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libretroshare/src/ft/ftfilecreator.h~ 2011-04-25 16:20:57.000000000 +0200
-+++ libretroshare/src/ft/ftfilecreator.h 2012-01-15 20:30:41.000000000 +0100
-@@ -35,6 +35,7 @@
- #include "ftfileprovider.h"
- #include "ftchunkmap.h"
- #include <map>
-+#define fseeko64 fseeko
-
- class ZeroInitCounter
- {
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfileprovider.h b/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfileprovider.h
deleted file mode 100644
index 3906c1fe9c06..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-ft-ftfileprovider.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libretroshare/src/ft/ftfileprovider.h~ 2011-02-20 01:59:47.000000000 +0100
-+++ libretroshare/src/ft/ftfileprovider.h 2012-01-15 04:01:35.000000000 +0100
-@@ -34,6 +34,7 @@
- #include <stdint.h>
- #include "util/rsthreads.h"
- #include "retroshare/rsfiles.h"
-+#define fseeko64 fseeko
-
- class ftFileProvider
- {
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-libretroshare.pro b/net-p2p/retroshare/files/patch-libretroshare-src-libretroshare.pro
deleted file mode 100644
index 2e8b4ee1c4c3..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-libretroshare.pro
+++ /dev/null
@@ -1,10 +0,0 @@
---- libretroshare/src/libretroshare.pro~ 2011-08-03 19:43:26.000000000 +0200
-+++ libretroshare/src/libretroshare.pro 2012-01-15 04:20:41.000000000 +0100
-@@ -104,6 +104,7 @@
- INCLUDEPATH += . $${BITDHT_DIR}
- # The next line if for compliance with debian packages. Keep it!
- INCLUDEPATH += ../libbitdht
-+ INCLUDEPATH += $${PREFIX}/include/gpgme
- DEFINES *= RS_USE_BITDHT
- }
-
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsinit.cc b/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsinit.cc
deleted file mode 100644
index a98e5b4df1a2..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsinit.cc
+++ /dev/null
@@ -1,88 +0,0 @@
---- libretroshare/src/rsserver/rsinit.cc.org 2012-01-15 04:34:27.000000000 +0100
-+++ libretroshare/src/rsserver/rsinit.cc 2012-01-15 04:35:45.000000000 +0100
-@@ -59,78 +59,14 @@
-
- #include "tcponudp/udpstunner.h"
-
--class accountId
--{
-- public:
-- std::string pgpId;
-- std::string pgpName;
-- std::string pgpEmail;
--
-- std::string sslId;
-- std::string location;
--};
--
--
--class RsInitConfig
--{
-- public:
-- /* Directories (SetupBaseDir) */
-- static std::string basedir;
-- static std::string homePath;
--#ifdef WINDOWS_SYS
-- static bool portable;
-- static bool isWindowsXP;
--#endif
--
-- static std::list<accountId> accountIds;
-- static std::string preferedId;
--
-- /* for certificate creation */
-- //static std::string gpgPasswd;
--
--#ifndef WINDOWS_SYS
-- static int lockHandle;
--#else
-- static HANDLE lockHandle;
--#endif
--
-- /* These fields are needed for login */
-- static std::string loginId;
-- static std::string configDir;
-- static std::string load_cert;
-- static std::string load_key;
--
-- static std::string passwd;
--
-- static bool autoLogin; /* autoLogin allowed */
-- static bool startMinimised; /* Icon or Full Window */
--
-- /* Key Parameters that must be set before
-- * RetroShare will start up:
-- */
--
-- /* Listening Port */
-- static bool forceExtPort;
-- static bool forceLocalAddr;
-- static unsigned short port;
-- static char inet[256];
--
-- /* Logging */
-- static bool haveLogFile;
-- static bool outStderr;
-- static bool haveDebugLevel;
-- static int debugLevel;
-- static std::string logfname;
--
-- static bool firsttime_run;
-- static bool load_trustedpeer;
-- static std::string load_trustedpeer_file;
--
-- static bool udpListenerOnly;
--
-- static std::string RetroShareLink;
--};
-+#include "rsinit.h"
-
-+#include <fnmatch.h>
-+#include <unistd.h>
-+#define O_LARGEFILE 0100000
-+#define stat64 stat
-+#define _stat stat
-+#define _getcwd getcwd
-
- const int p3facestartupzone = 47238;
-
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsloginhandler.cc b/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsloginhandler.cc
deleted file mode 100644
index 6813ca6e6d89..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-rsserver-rsloginhandler.cc
+++ /dev/null
@@ -1,28 +0,0 @@
---- libretroshare/src/rsserver/rsloginhandler.cc.orig 2012-01-15 04:44:59.000000000 +0100
-+++ libretroshare/src/rsserver/rsloginhandler.cc 2012-01-15 04:43:08.000000000 +0100
-@@ -4,6 +4,7 @@
- #include <pqi/authgpg.h>
- #include "rsloginhandler.h"
- #include "util/rsdir.h"
-+#include "rsinit.h"
-
- #ifdef UBUNTU
- #include <gnome-keyring-1/gnome-keyring.h>
-@@ -196,7 +197,7 @@
- /******************** OSX KeyChain stuff *****************************/
- #else /* UNIX, but not UBUNTU or APPLE */
-
-- FILE* helpFile = RsDirUtil::rs_fopen(getAutologinFileName.c_str(), "r");
-+ FILE* helpFile = RsDirUtil::rs_fopen(getAutologinFileName(ssl_id).c_str(), "r");
-
- if(helpFile == NULL){
- std::cerr << "\nFailed to open help file\n" << std::endl;
-@@ -408,7 +409,7 @@
- #else
-
- /* WARNING: Autologin is inherently unsafe */
-- FILE* helpFile = RsDirUtil::rs_fopen(getAutologinFileName.c_str(), "w");
-+ FILE* helpFile = RsDirUtil::rs_fopen(getAutologinFileName(ssl_id).c_str(), "w");
-
- if(helpFile == NULL){
- std::cerr << "\nRsStoreAutoLogin(): Failed to open help file\n" << std::endl;
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.cc b/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.cc
deleted file mode 100644
index db796e65ed5b..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- libretroshare/src/upnp/upnphandler.cc~ 2011-07-08 11:54:27.000000000 +0200
-+++ libretroshare/src/upnp/upnphandler.cc 2012-01-15 05:27:12.000000000 +0100
-@@ -12,6 +12,7 @@
- #endif
- /* This stuff is actually C */
-
-+#define do_not_use_this
- #include "upnp/upnphandler.h"
-
- #include "util/rsnet.h"
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.h b/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.h
deleted file mode 100644
index 45d1f4dc36f0..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-upnp-upnphandler.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- libretroshare/src/upnp/upnphandler.h~ 2010-07-04 12:42:17.000000000 +0200
-+++ libretroshare/src/upnp/upnphandler.h 2012-01-15 05:26:45.000000000 +0100
-@@ -13,7 +13,11 @@
- #include "util/rsthreads.h"
-
- #include <upnp/upnp.h>
-+#ifdef do_not_use_this
-+#include "upnp/UPnPBase.cpp"
-+#else
- #include "upnp/UPnPBase.h"
-+#endif
-
- #define RS_UPNP_S_UNINITIALISED 0
- #define RS_UPNP_S_UNAVAILABLE 1
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdir.h b/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdir.h
deleted file mode 100644
index ce9a12494094..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdir.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- libretroshare/src/util/rsdir.h.orig 2011-05-15 14:42:55.000000000 +0200
-+++ libretroshare/src/util/rsdir.h 2012-01-15 20:10:19.000000000 +0100
-@@ -31,6 +31,17 @@
- #include <string>
- #include <list>
- #include <stdint.h>
-+#include <fnmatch.h>
-+
-+#include <dirent.h>
-+#include <unistd.h>
-+#define O_LARGEFILE 0100000
-+#define stat64 stat
-+#define _stat stat
-+#define _getcwd getcwd
-+#define fseeko64 fseeko
-+#define fopen64 fopen
-+#define ftello64 ftello
-
- class CRC32Map ;
- class RsThread;
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdiscspace.cc b/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdiscspace.cc
deleted file mode 100644
index 4c590bb1602b..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsdiscspace.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- libretroshare/src/util/rsdiscspace.cc.orig 2011-07-05 00:59:39.000000000 +0200
-+++ libretroshare/src/util/rsdiscspace.cc 2012-01-15 04:55:17.000000000 +0100
-@@ -31,6 +31,7 @@
- #include <util/rsthreads.h>
- #ifndef WIN32
- #include <sys/statvfs.h>
-+#define statvfs64 statvfs
- #endif
-
- #define DELAY_BETWEEN_CHECKS 2
diff --git a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsrandom.cc b/net-p2p/retroshare/files/patch-libretroshare-src-util-rsrandom.cc
deleted file mode 100644
index 094e3ac7f454..000000000000
--- a/net-p2p/retroshare/files/patch-libretroshare-src-util-rsrandom.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- libretroshare/src/util/rsrandom.cc~ 2011-07-05 00:59:39.000000000 +0200
-+++ libretroshare/src/util/rsrandom.cc 2012-01-15 04:56:47.000000000 +0100
-@@ -13,7 +13,7 @@
- #ifdef __APPLE__
- static bool auto_seed = RSRandom::seed( (time(NULL) + pthread_mach_thread_np(pthread_self())*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
- #else
-- static bool auto_seed = RSRandom::seed( (time(NULL) + pthread_self()*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
-+// static bool auto_seed = RSRandom::seed( (time(NULL) + pthread_self()*0x1293fe + (getpid()^0x113ef76b))^0x18e34a12 ) ;
- #endif
- #endif
- bool RSRandom::seed(uint32_t s)
diff --git a/net-p2p/retroshare/files/patch-retroshare-gui-src-RetroShare.pro b/net-p2p/retroshare/files/patch-retroshare-gui-src-RetroShare.pro
deleted file mode 100644
index 9e5b8be7bdda..000000000000
--- a/net-p2p/retroshare/files/patch-retroshare-gui-src-RetroShare.pro
+++ /dev/null
@@ -1,17 +0,0 @@
---- retroshare-gui/src/RetroShare.pro.orig 2011-08-03 19:45:03.000000000 +0200
-+++ retroshare-gui/src/RetroShare.pro 2012-01-15 12:55:12.000000000 +0100
-@@ -153,9 +153,12 @@
-
- # ###########################################
-
-+INCLUDEPATH += $${PREFIX}/include/gpgme
-+LIBS += ../../libretroshare/src/libretroshare.a -lssl -lgpgme -lupnp
-+
- bitdht {
-- LIBS += ../../libbitdht/src/lib/libbitdht.a
-- PRE_TARGETDEPS *= ../../libbitdht/src/lib/libbitdht.a
-+ LIBS += ../../libbitdht/src/libbitdht.a
-+ PRE_TARGETDEPS *= ../../libbitdht/src/libbitdht.a
- }
-
- win32 {
diff --git a/net-p2p/retroshare/files/rsinit.h b/net-p2p/retroshare/files/rsinit.h
deleted file mode 100644
index 5434971c7b23..000000000000
--- a/net-p2p/retroshare/files/rsinit.h
+++ /dev/null
@@ -1,78 +0,0 @@
-
-#ifndef RETROSHARE_RSINIT_H
-#define RETROSHARE_RSINIT_H
-
-class accountId
-{
- public:
- std::string pgpId;
- std::string pgpName;
- std::string pgpEmail;
-
- std::string sslId;
- std::string location;
-};
-
-
-class RsInitConfig
-{
- public:
- /* Directories (SetupBaseDir) */
- static std::string basedir;
- static std::string homePath;
-#ifdef WINDOWS_SYS
- static bool portable;
- static bool isWindowsXP;
-#endif
-
- static std::list<accountId> accountIds;
- static std::string preferedId;
-
- /* for certificate creation */
- //static std::string gpgPasswd;
-
-#ifndef WINDOWS_SYS
- static int lockHandle;
-#else
- static HANDLE lockHandle;
-#endif
-
- /* These fields are needed for login */
- static std::string loginId;
- static std::string configDir;
- static std::string load_cert;
- static std::string load_key;
-
- static std::string passwd;
-
- static bool autoLogin; /* autoLogin allowed */
- static bool startMinimised; /* Icon or Full Window */
-
- /* Key Parameters that must be set before
- * RetroShare will start up:
- */
-
- /* Listening Port */
- static bool forceExtPort;
- static bool forceLocalAddr;
- static unsigned short port;
- static char inet[256];
-
- /* Logging */
- static bool haveLogFile;
- static bool outStderr;
- static bool haveDebugLevel;
- static int debugLevel;
- static std::string logfname;
-
- static bool firsttime_run;
- static bool load_trustedpeer;
- static std::string load_trustedpeer_file;
-
- static bool udpListenerOnly;
-
- static std::string RetroShareLink;
-};
-
-#endif
-
diff --git a/net-p2p/retroshare/pkg-plist b/net-p2p/retroshare/pkg-plist
index 0de00238e3ca..f593348a7c02 100644
--- a/net-p2p/retroshare/pkg-plist
+++ b/net-p2p/retroshare/pkg-plist
@@ -1,3 +1,4 @@
bin/RetroShare
+%%NOGUI%%bin/retroshare-nogui
%%DATADIR%%/bdboot.txt
@dirrm %%DATADIR%%