aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-16 15:06:13 +0800
committerantoine <antoine@FreeBSD.org>2016-09-16 15:06:13 +0800
commit942ee390bbc6baca96c6654f969c028d6bc3709c (patch)
tree025ccfd8aa53104b3e46c3f9bcdb1fa1f8b25ae4 /net-p2p
parent53cf125accaef0f96a6dbf78ba2037a137ddde06 (diff)
downloadfreebsd-ports-gnome-942ee390bbc6baca96c6654f969c028d6bc3709c.tar.gz
freebsd-ports-gnome-942ee390bbc6baca96c6654f969c028d6bc3709c.tar.zst
freebsd-ports-gnome-942ee390bbc6baca96c6654f969c028d6bc3709c.zip
Mark BROKEN: fails to build
In file included from app/application.cpp:70: In file included from ./base/bittorrent/session.h:43: ./base/bittorrent/torrentinfo.h:50:37: error: no type named 'intrusive_ptr' in namespace 'boost' explicit TorrentInfo(boost::intrusive_ptr<const libtorrent::torrent_info> nativeInfo = boost::intrusive_ptr<const libtorrent::torrent_info>()); ~~~~~~~^ ./base/bittorrent/torrentinfo.h:50:50: error: expected ')' explicit TorrentInfo(boost::intrusive_ptr<const libtorrent::torrent_info> nativeInfo = boost::intrusive_ptr<const libtorrent::torrent_info>()); ^ ./base/bittorrent/torrentinfo.h:50:29: note: to match this '(' explicit TorrentInfo(boost::intrusive_ptr<const libtorrent::torrent_info> nativeInfo = boost::intrusive_ptr<const libtorrent::torrent_info>()); ^ ./base/bittorrent/torrentinfo.h:80:16: error: no type named 'intrusive_ptr' in namespace 'boost' boost::intrusive_ptr<libtorrent::torrent_info> nativeInfo() const; ~~~~~~~^ ./base/bittorrent/torrentinfo.h:80:29: error: expected member name or ';' after declaration specifiers boost::intrusive_ptr<libtorrent::torrent_info> nativeInfo() const; ~~~~~~~~~~~~~~~~~~~~^ ./base/bittorrent/torrentinfo.h:83:16: error: no type named 'intrusive_ptr' in namespace 'boost' boost::intrusive_ptr<libtorrent::torrent_info> m_nativeInfo; ~~~~~~~^ ./base/bittorrent/torrentinfo.h:83:29: error: expected member name or ';' after declaration specifiers boost::intrusive_ptr<libtorrent::torrent_info> m_nativeInfo; ~~~~~~~~~~~~~~~~~~~~^ In file included from app/application.cpp:70: ./base/bittorrent/session.h:291:63: error: no matching constructor for initialization of 'BitTorrent::TorrentInfo' const TorrentInfo &torrentInfo = TorrentInfo(), ^ ./base/bittorrent/torrentinfo.h:51:9: note: candidate constructor not viable: requires single argument 'other', but no arguments were provided TorrentInfo(const TorrentInfo &other); ^ In file included from app/application.cpp:71: ./base/bittorrent/torrenthandle.h:386:36: error: field has incomplete type 'libtorrent::torrent_status' libtorrent::torrent_status m_nativeStatus; ^ /usr/local/include/libtorrent/torrent_handle.hpp:72:9: note: forward declaration of 'libtorrent::torrent_status' struct torrent_status; ^ Reported by: pkg-fallout
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index de62c64c764a..5dfc415e6c64 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -11,6 +11,8 @@ COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
LICENSE= GPLv2
+BROKEN= fails to build
+
# ABI versions specified on purpose for libtorrent-rasterbar
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
libboost_system.so:devel/boost-libs