aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
committermat <mat@FreeBSD.org>2016-08-08 21:46:50 +0800
commitaccc153f0c7ee632df7b714f1861b98898e90e7c (patch)
tree509f9c56f6c9e206681219518e92866874b3ae54 /net-p2p
parentc333a42bbacfd478a1ae703c628fc3f6f2ce3575 (diff)
downloadfreebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.gz
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.tar.zst
freebsd-ports-gnome-accc153f0c7ee632df7b714f1861b98898e90e7c.zip
USE_BDB cleanup.
- USE_BDB=4x+ -> USES=bdb. - USE_BDB=yes -> USES=bdb. - USE_BDB=xx -> USES=bdb:xx. Other modernisations when I see them. PR: 209183 Sponsored by: Absolight
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile5
-rw-r--r--net-p2p/digitalcoin/Makefile4
-rw-r--r--net-p2p/dogecoin/Makefile4
-rw-r--r--net-p2p/jigdo/Makefile2
-rw-r--r--net-p2p/litecoin/Makefile5
-rw-r--r--net-p2p/namecoin/Makefile4
-rw-r--r--net-p2p/twister/Makefile4
-rw-r--r--net-p2p/zetacoin/Makefile5
8 files changed, 11 insertions, 22 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 1c0f3d98947f..05c90b50cc29 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -14,10 +14,9 @@ LICENSE= MIT
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent2
-USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix
+USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
SLAVE_PORT?= no
@@ -70,7 +69,7 @@ QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
WALLET_CONFIGURE_ENABLE= wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
-WALLET_USE= BDB=48
+WALLET_USES= bdb:48
ZMQ_CONFIGURE_ENABLE= zmq
ZMQ_BUILD_DEPENDS= libzmq4>0:net/libzmq4
diff --git a/net-p2p/digitalcoin/Makefile b/net-p2p/digitalcoin/Makefile
index 1bbb35092842..90f3e36070df 100644
--- a/net-p2p/digitalcoin/Makefile
+++ b/net-p2p/digitalcoin/Makefile
@@ -21,9 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= baritus
GH_TAGNAME= 96b098a
-USES= desktop-file-utils gmake
-USE_OPENSSL= yes
-USE_BDB= 48
+USES= bdb:48 desktop-file-utils gmake ssl
USE_QT4= corelib gui qmake_build linguisttools_build uic_build \
moc_build rcc_build
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index 6dd3477308be..fbc9c7b49871 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -24,14 +24,12 @@ QRCODES_DESC= Build with QR code display
USE_GITHUB= yes
-USES= gmake compiler:c++11-lib pkgconfig autoreconf
+USES= bdb:5 gmake compiler:c++11-lib pkgconfig autoreconf ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-incompatible-bdb \
SSL_CFLAGS="-I${OPENSSLINC} -L${OPENSSLLIB}" SSL_LIBS="-lssl" \
CRYPTO_CFLAGS="-I${OPENSSLINC} -L${OPENSSLLIB}" CRYPTO_LIBS="-lcrypto"
CONFIGURE_ENV+= OBJC="${CC}" OBJCFLAGS="${CFLAGS}" OBJCXX="${CXX}" OBJCXXFLAGS="${CXXFLAGS}"
-USE_OPENSSL= yes
-USE_BDB= 5
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR} \
-L${LOCALBASE}/lib -L${BDB_LIB_DIR}
diff --git a/net-p2p/jigdo/Makefile b/net-p2p/jigdo/Makefile
index 19e31de0c20d..8c1f07f14d0d 100644
--- a/net-p2p/jigdo/Makefile
+++ b/net-p2p/jigdo/Makefile
@@ -34,7 +34,7 @@ BDB_CONFIGURE_ON= --with-libdb=-l${BDB_LIB_CXX_NAME}
BDB_CONFIGURE_OFF= --without-libdb
BDB_CPPFLAGS= -I${BDB_INCLUDE_DIR}
BDB_LIBS= -L${BDB_LIB_DIR}
-BDB_USE= BDB=48+
+BDB_USES= bdb
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 6bc7bd3b64f0..4ac2a4f1e88e 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -16,10 +16,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-USES+= autoreconf gmake libtool pkgconfig shebangfix
+USES+= autoreconf gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
SLAVE_PORT?= no
@@ -71,7 +70,7 @@ QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
WALLET_CONFIGURE_ENABLE= wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
-WALLET_USE= BDB=48
+WALLET_USES= bdb:48
GH_ACCOUNT= litecoin-project
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index 1180e8e00ef3..72e1a8dd5be2 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -24,10 +24,8 @@ QRCODES_DESC= Build with QR code display
USE_GITHUB= yes
-USES= gmake compiler:c++11-lib
+USES= bdb:48 gmake compiler:c++11-lib ssl
MAKE_JOBS_UNSAFE=yes
-USE_OPENSSL= yes
-USE_BDB= 48
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
CXXFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index 8de8c65e85d6..cdc45b9f570e 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -26,9 +26,7 @@ OPTIONS_DEFINE= DOCS
USE_GITHUB= yes
GH_ACCOUNT= miguelfreitas
-USE_BDB= 48
-USE_OPENSSL= yes
-USES= autoreconf:build gmake iconv libtool
+USES= bdb:48 autoreconf:build gmake iconv libtool ssl
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/libtorrent
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index cc134848f64d..f0e33e1399b5 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -13,7 +13,7 @@ LICENSE= MIT
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-USES+= autoreconf compiler:c++0x gmake libtool pkgconfig:build
+USES+= autoreconf compiler:c++0x gmake libtool pkgconfig:build ssl
BROKEN_armv6= AtomicPointer not implemented
@@ -47,7 +47,7 @@ X11_USES= desktop-file-utils
WALLET_CONFIGURE_ENABLE= wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
-WALLET_USE= bdb=48
+WALLET_USES= bdb:48
QRCODES_IMPLIES= X11
QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
@@ -61,7 +61,6 @@ TEST_ALL_TARGET= check
GNU_CONFIGURE= yes
CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto" \
SSL_CFLAGS="-I${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl"
-USE_OPENSSL= yes
QT_BINARY= ${PORTNAME}-qt
CLI_BINARY= ${PORTNAME}-cli