aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-02-07 06:52:12 +0800
committernemysis <nemysis@FreeBSD.org>2014-02-07 06:52:12 +0800
commitb033f4b3f8c21eaf840c116f8a85b8f7899edd35 (patch)
treee90277cc2641ca760e7a5ec72bdfd7244cecad44 /net-p2p
parent5054c3c3523784c25905f0260f329525d4fd7c03 (diff)
downloadfreebsd-ports-gnome-b033f4b3f8c21eaf840c116f8a85b8f7899edd35.tar.gz
freebsd-ports-gnome-b033f4b3f8c21eaf840c116f8a85b8f7899edd35.tar.zst
freebsd-ports-gnome-b033f4b3f8c21eaf840c116f8a85b8f7899edd35.zip
- Add patch, fix build net-p2p/qbittorrent-nox11
Reported by: Alexander Welyczkowski <AWelyczkowski@convergex.com>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Makefile4
-rw-r--r--net-p2p/qbittorrent/files/patch-src__src.pro42
2 files changed, 44 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 0525954c111a..a2105e655b10 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qbittorrent
PORTVERSION= 3.1.8
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
@@ -45,7 +45,7 @@ USE_QT4+= dbus
do-configure:
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "no"
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
- ./configure --prefix=${PREFIX}
+ ./configure --prefix=${PREFIX} --enable-debug
.else
@cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} \
./configure --prefix=${PREFIX} --disable-gui
diff --git a/net-p2p/qbittorrent/files/patch-src__src.pro b/net-p2p/qbittorrent/files/patch-src__src.pro
new file mode 100644
index 000000000000..76df654419d9
--- /dev/null
+++ b/net-p2p/qbittorrent/files/patch-src__src.pro
@@ -0,0 +1,42 @@
+--- ./src/src.pro.orig 2014-02-02 21:50:54.000000000 +0100
++++ ./src/src.pro 2014-02-06 23:30:26.000000000 +0100
+@@ -107,8 +107,7 @@
+ scannedfoldersmodel.h \
+ qinisettings.h \
+ smtp.h \
+- dnsupdater.h \
+- messageboxraised.h
++ dnsupdater.h
+
+
+ SOURCES += main.cpp \
+@@ -117,8 +116,7 @@
+ misc.cpp \
+ fs_utils.cpp \
+ smtp.cpp \
+- dnsupdater.cpp \
+- messageboxraised.cpp
++ dnsupdater.cpp
+
+ nox {
+ HEADERS += headlessloader.h
+@@ -152,7 +150,8 @@
+ loglistwidget.h \
+ addnewtorrentdialog.h \
+ autoexpandabledialog.h \
+- statsdialog.h
++ statsdialog.h \
++ messageboxraised.h
+
+ SOURCES += mainwindow.cpp \
+ ico.cpp \
+@@ -171,7 +170,8 @@
+ loglistwidget.cpp \
+ addnewtorrentdialog.cpp \
+ autoexpandabledialog.cpp \
+- statsdialog.cpp
++ statsdialog.cpp \
++ messageboxraised.cpp
+
+ win32 {
+ HEADERS += programupdater.h