aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
committermat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
commitb2012f72500300ecbba6933c68717ba52c454563 (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /net-p2p
parente02e32ae84bd96a47a379dcd2c109efc58b41400 (diff)
downloadfreebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.gz
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.zst
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge-cli/Makefile12
-rw-r--r--net-p2p/py-transmissionrpc/Makefile2
-rw-r--r--net-p2p/py-vertex/Makefile6
3 files changed, 10 insertions, 10 deletions
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index 3120fdc843ff..4e48d4fc0385 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -14,13 +14,13 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= intltool-merge:textproc/intltool
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0:net-p2p/libtorrent-rasterbar-python@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
USES= gettext python:-2.7
USE_PYTHON= autoplist distutils
diff --git a/net-p2p/py-transmissionrpc/Makefile b/net-p2p/py-transmissionrpc/Makefile
index edd22b7e1b4a..7a257d2e53c7 100644
--- a/net-p2p/py-transmissionrpc/Makefile
+++ b/net-p2p/py-transmissionrpc/Makefile
@@ -14,7 +14,7 @@ COMMENT= Python module that communicates with Transmission through JSON-RPC
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
diff --git a/net-p2p/py-vertex/Makefile b/net-p2p/py-vertex/Makefile
index 818d2d78c72c..644d6a602ebc 100644
--- a/net-p2p/py-vertex/Makefile
+++ b/net-p2p/py-vertex/Makefile
@@ -15,9 +15,9 @@ COMMENT= Vertex is an implementation of the Q2Q protocol
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}epsilon>=0:devel/py-epsilon@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}epsilon>=0:devel/py-epsilon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR}
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils