aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /net-p2p
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnewtellium/Makefile3
-rw-r--r--net-p2p/gnewtellium/files/patch-src_config.c (renamed from net-p2p/gnewtellium/files/patch-src__config.c)110
-rw-r--r--net-p2p/torrentsniff/Makefile2
-rw-r--r--net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm10
-rw-r--r--net-p2p/torrentsniff/files/patch-BitTorrent_BDecode.pm10
-rw-r--r--net-p2p/torrentsniff/files/patch-torrentsniff22
6 files changed, 79 insertions, 78 deletions
diff --git a/net-p2p/gnewtellium/Makefile b/net-p2p/gnewtellium/Makefile
index d812c31389fa..06a07ceb2011 100644
--- a/net-p2p/gnewtellium/Makefile
+++ b/net-p2p/gnewtellium/Makefile
@@ -13,7 +13,8 @@ COMMENT= Gnutella client
PORTSCOUT= skipv:0.05 # older than current one
USE_GNOME= gtk12
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_GLOB= *.c
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/net-p2p/gnewtellium/files/patch-src__config.c b/net-p2p/gnewtellium/files/patch-src_config.c
index 54d3eba3f8be..8c2d7e2a2535 100644
--- a/net-p2p/gnewtellium/files/patch-src__config.c
+++ b/net-p2p/gnewtellium/files/patch-src_config.c
@@ -1,55 +1,55 @@
---- src/config.c.orig Tue Feb 5 03:50:18 2002
-+++ src/config.c Tue Mar 9 20:37:00 2004
-@@ -539,8 +539,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 0);
- gtk_widget_show(hbox);
-
-- label = gtk_label_new("Let Newtella know what speed your Internet Connection is.
--Setting this to an accurate number will help you get the most out of
-+ label = gtk_label_new("Let Newtella know what speed your Internet Connection is.\n\
-+Setting this to an accurate number will help you get the most out of\n\
- Newtella's advanced bandwidth management.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- hbox = gtk_hbox_new(FALSE, 0);
-@@ -579,7 +579,7 @@
- gtk_widget_show(button);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Select the directory where you want to store your newly
-+ label = gtk_label_new("Select the directory where you want to store your newly\n\
- downloaded files.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
-@@ -627,8 +627,8 @@
- gtk_widget_show(hbox);
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 5);
-
-- label = gtk_label_new("Add any number of directories here.
--All .mp3 files under any of these directories can then be
-+ label = gtk_label_new("Add any number of directories here.\n\
-+All .mp3 files under any of these directories can then be\n\
- downloaded by other Newtella users.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- hbox = gtk_hbox_new(FALSE, 0);
-@@ -686,8 +686,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Select how much search results Newtella will maximally send to
--other clients. Use this to limit the impact of stupid searches on your
-+ label = gtk_label_new("Select how much search results Newtella will maximally send to\n\
-+other clients. Use this to limit the impact of stupid searches on your\n\
- computer.");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
-@@ -724,8 +724,8 @@
- gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
-
- hbox = gtk_hbox_new(FALSE, 0);
-- label = gtk_label_new("Returns the entered IP with search results instead of your real one.
--Useful if your're behind a NAT Firewall (like Windows 98 Internet
-+ label = gtk_label_new("Returns the entered IP with search results instead of your real one.\n\
-+Useful if your're behind a NAT Firewall (like Windows 98 Internet\n\
- Connection Sharing)");
- gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
- gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+--- src/config.c.orig 2016-06-20 14:36:47 UTC
++++ src/config.c
+@@ -539,8 +539,8 @@ void config_draw(void)
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 0);
+ gtk_widget_show(hbox);
+
+- label = gtk_label_new("Let Newtella know what speed your Internet Connection is.
+-Setting this to an accurate number will help you get the most out of
++ label = gtk_label_new("Let Newtella know what speed your Internet Connection is.\n\
++Setting this to an accurate number will help you get the most out of\n\
+ Newtella's advanced bandwidth management.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -579,7 +579,7 @@ Newtella's advanced bandwidth management
+ gtk_widget_show(button);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select the directory where you want to store your newly
++ label = gtk_label_new("Select the directory where you want to store your newly\n\
+ downloaded files.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -627,8 +627,8 @@ downloaded files.");
+ gtk_widget_show(hbox);
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 5);
+
+- label = gtk_label_new("Add any number of directories here.
+-All .mp3 files under any of these directories can then be
++ label = gtk_label_new("Add any number of directories here.\n\
++All .mp3 files under any of these directories can then be\n\
+ downloaded by other Newtella users.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ hbox = gtk_hbox_new(FALSE, 0);
+@@ -686,8 +686,8 @@ downloaded by other Newtella users.");
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Select how much search results Newtella will maximally send to
+-other clients. Use this to limit the impact of stupid searches on your
++ label = gtk_label_new("Select how much search results Newtella will maximally send to\n\
++other clients. Use this to limit the impact of stupid searches on your\n\
+ computer.");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
+@@ -724,8 +724,8 @@ computer.");
+ gtk_box_pack_start(GTK_BOX(vbox), hbox, FALSE, FALSE, 10);
+
+ hbox = gtk_hbox_new(FALSE, 0);
+- label = gtk_label_new("Returns the entered IP with search results instead of your real one.
+-Useful if your're behind a NAT Firewall (like Windows 98 Internet
++ label = gtk_label_new("Returns the entered IP with search results instead of your real one.\n\
++Useful if your're behind a NAT Firewall (like Windows 98 Internet\n\
+ Connection Sharing)");
+ gtk_label_set_justify(GTK_LABEL(label), GTK_JUSTIFY_LEFT);
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 10);
diff --git a/net-p2p/torrentsniff/Makefile b/net-p2p/torrentsniff/Makefile
index eca0a26e6794..e843760b96da 100644
--- a/net-p2p/torrentsniff/Makefile
+++ b/net-p2p/torrentsniff/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= p5-libwww>=0:www/p5-libwww \
p5-Digest-SHA1>=0:security/p5-Digest-SHA1
NO_BUILD= yes
-USES= shebangfix perl5
+USES= dos2unix shebangfix perl5
SHEBANG_FILES= torrentsniff
do-install:
diff --git a/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm b/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm
deleted file mode 100644
index 9caadb0eda4e..000000000000
--- a/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm
+++ /dev/null
@@ -1,10 +0,0 @@
---- BitTorrent/BDecode.pm.orig Sun Jun 15 05:47:46 2003
-+++ BitTorrent/BDecode.pm Fri Nov 14 18:42:44 2003
-@@ -5,7 +5,6 @@
- use Carp;
- use base 'Exporter';
- use strict;
--our @EXPORT_OK = qw(bdecode);
-
- sub bdecode {
- my ($dataref) = @_;
diff --git a/net-p2p/torrentsniff/files/patch-BitTorrent_BDecode.pm b/net-p2p/torrentsniff/files/patch-BitTorrent_BDecode.pm
new file mode 100644
index 000000000000..43b9a4dab7ac
--- /dev/null
+++ b/net-p2p/torrentsniff/files/patch-BitTorrent_BDecode.pm
@@ -0,0 +1,10 @@
+--- BitTorrent/BDecode.pm.orig 2016-06-20 14:38:26 UTC
++++ BitTorrent/BDecode.pm
+@@ -5,7 +5,6 @@ package BitTorrent::BDecode;
+ use Carp;
+ use base 'Exporter';
+ use strict;
+-our @EXPORT_OK = qw(bdecode);
+
+ sub bdecode {
+ my ($dataref) = @_;
diff --git a/net-p2p/torrentsniff/files/patch-torrentsniff b/net-p2p/torrentsniff/files/patch-torrentsniff
index 03062bb7be8e..6c14566c0ed9 100644
--- a/net-p2p/torrentsniff/files/patch-torrentsniff
+++ b/net-p2p/torrentsniff/files/patch-torrentsniff
@@ -1,11 +1,11 @@
---- torrentsniff.orig Fri Nov 14 18:17:20 2003
-+++ torrentsniff Fri Nov 14 18:27:24 2003
-@@ -115,7 +115,7 @@
- my($file, $report_file_info, $report_tracker_info) = @_;
- print "$file\n";
- local *TOR;
-- if( not open(TOR, "<", $file) ) {
-+ if( not open(TOR, "< $file") ) {
- print STDERR "Unable to read $file because of $!\n";
- return 0;
- }
+--- torrentsniff.orig 2016-06-20 14:38:26 UTC
++++ torrentsniff
+@@ -115,7 +115,7 @@ sub process_file {
+ my($file, $report_file_info, $report_tracker_info) = @_;
+ print "$file\n";
+ local *TOR;
+- if( not open(TOR, "<", $file) ) {
++ if( not open(TOR, "< $file") ) {
+ print STDERR "Unable to read $file because of $!\n";
+ return 0;
+ }