aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-13 13:34:41 +0800
committermarino <marino@FreeBSD.org>2016-09-13 13:34:41 +0800
commitf3b5919de0bdddbc6019235447ef0eb42d511c5f (patch)
treec28fa41850b0d14c60937403da8e74c8ed04ef31 /net-p2p
parent6e5e0a35b7755e9abd3dbbb2893a8f1b98ff8f1c (diff)
downloadfreebsd-ports-gnome-f3b5919de0bdddbc6019235447ef0eb42d511c5f.tar.gz
freebsd-ports-gnome-f3b5919de0bdddbc6019235447ef0eb42d511c5f.tar.zst
freebsd-ports-gnome-f3b5919de0bdddbc6019235447ef0eb42d511c5f.zip
net-p2p/litecoin: ignore when SSL_DEFAULT matches "libressl"
If an attempt to build with LibreSSL is made, the configure script emits this message: configure: error: Detected LibreSSL: This is not supported, and may break consensus compatibility Go ahead and mark this port and its slaved with IGNORE when libressl is used to save the user the trouble of hitting the error later (this is also done by security/p5-openxpki) Approved by: SSL blanket
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoin/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index f2ebe156d526..26bb0cc4ca04 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -92,6 +92,13 @@ LDFLAGS+= -L${OPENSSLLIB}
PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
share/pixmaps/litecoin128.png
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+# The configure script will output this message, so save the user the trouble
+IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+.endif
+
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
post-patch:
@@ -115,4 +122,4 @@ regression-test: build
@cd ${WRKSRC} && ${GMAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>