aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-13 01:26:26 +0800
committermarino <marino@FreeBSD.org>2016-09-13 01:26:26 +0800
commitf733494375733e68d7ed40c9250c4b0c12c19927 (patch)
tree6325d54d8fabd484fa55a3c59542e2236d7b813c /net-p2p
parent20528233e88d772d17810bb74b2b58fb57ac0b65 (diff)
downloadfreebsd-ports-gnome-f733494375733e68d7ed40c9250c4b0c12c19927.tar.gz
freebsd-ports-gnome-f733494375733e68d7ed40c9250c4b0c12c19927.tar.zst
freebsd-ports-gnome-f733494375733e68d7ed40c9250c4b0c12c19927.zip
net-p2p/litecoin: Set SSL flags
Note for SSL_DEFAULT=libressl: configure: error: Detected LibreSSL: This is not supported, and may break consensus compatibility It might be worth detecting that via SSL_DEFAULT and setting the port to IGNORE. Or perhaps a newer version of litecoin will support LibreSSL officially. Approved by: SSL blanket
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoin/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 31627b26d18e..f2ebe156d526 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -85,6 +85,10 @@ CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lcr
CONFIGURE_ENV+= OBJC="${CC}" OBJCFLAGS="${CFLAGS}" OBJCXX="${CXX}" OBJCXXFLAGS="${CXXFLAGS}"
+CPPFLAGS+= -I${OPENSSLINC}
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
share/pixmaps/litecoin128.png