aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-05 04:46:54 +0800
committerswills <swills@FreeBSD.org>2012-09-05 04:46:54 +0800
commit1e041df89b86e13ccb9dfafb71df2d86435e6541 (patch)
tree2a037d52a399089fb34e562b1e7f89859590013d /net-p2p
parentfa2c92347a3fabc470870afee61c0a3d7fc24752 (diff)
downloadfreebsd-ports-gnome-1e041df89b86e13ccb9dfafb71df2d86435e6541.tar.gz
freebsd-ports-gnome-1e041df89b86e13ccb9dfafb71df2d86435e6541.tar.zst
freebsd-ports-gnome-1e041df89b86e13ccb9dfafb71df2d86435e6541.zip
- Hopefully really fix the last high CPU usage case
PR: ports/171252 Submitted by: Steven Lee <steven@roothosts.com>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile2
-rw-r--r--net-p2p/bitcoin/files/patch-util.h21
2 files changed, 22 insertions, 1 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index ed680bf4fd5b..987208008667 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.6.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p finance
MAINTAINER= ports@FreeBSD.org
diff --git a/net-p2p/bitcoin/files/patch-util.h b/net-p2p/bitcoin/files/patch-util.h
new file mode 100644
index 000000000000..7f6f8e0df160
--- /dev/null
+++ b/net-p2p/bitcoin/files/patch-util.h
@@ -0,0 +1,21 @@
+--- src/util.h.orig 2012-09-02 08:13:29.000000000 -0500
++++ src/util.h 2012-09-02 08:14:08.000000000 -0500
+@@ -290,8 +290,6 @@
+ LeaveCritical(); \
+ }
+
+-#ifdef MAC_OSX
+-// boost::interprocess::interprocess_semaphore seems to spinlock on OSX; prefer polling instead
+ class CSemaphore
+ {
+ private:
+@@ -328,9 +326,6 @@
+ val++;
+ }
+ };
+-#else
+-typedef boost::interprocess::interprocess_semaphore CSemaphore;
+-#endif
+
+ inline std::string i64tostr(int64 n)
+ {