aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-20 00:41:59 +0800
committermarino <marino@FreeBSD.org>2016-09-20 00:41:59 +0800
commit58ad433e3f648e986b14dad9ac41941b276cf5ec (patch)
tree142624ed072f5be58f38d230ccd2f1a66ec51156 /net-p2p
parent8e4cd552d88623b5acddac91c9811314a31b75fc (diff)
downloadfreebsd-ports-gnome-58ad433e3f648e986b14dad9ac41941b276cf5ec.tar.gz
freebsd-ports-gnome-58ad433e3f648e986b14dad9ac41941b276cf5ec.tar.zst
freebsd-ports-gnome-58ad433e3f648e986b14dad9ac41941b276cf5ec.zip
net-p2p/zetacoin: IGNORE when SSL_DEFAULT matches libressl
Zetacoin explicitly fails to configure when libressl is detected. It can only be built with OpenSSL right now (similar to litecoin). Approved by: SSL blanket
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/zetacoin/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 78953a2f6674..2858ad4b74b9 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -91,6 +91,13 @@ USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+# The configure script will output this message, so save the user the trouble
+IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+.endif
+
post-patch:
${MKDIR} ${WRKSRC}/src/build-aux
@@ -113,4 +120,4 @@ do-install-X11-off:
${INSTALL_PROGRAM} -s ${WRKSRC}/src/${DAEMON} ${STAGEDIR}${PREFIX}/bin/${DAEMON}
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.conf.sample ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>