aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-02-09 13:57:48 +0800
committermezz <mezz@FreeBSD.org>2008-02-09 13:57:48 +0800
commit684c18d813b511f175704935e160a5cdce095981 (patch)
tree553b41feb91ab0a81f798e673ed144d131b079b5 /net-p2p
parentf2c6e356d57b5015b5dbfbe3a2766d60b8a8e74e (diff)
downloadfreebsd-ports-gnome-684c18d813b511f175704935e160a5cdce095981.tar.gz
freebsd-ports-gnome-684c18d813b511f175704935e160a5cdce095981.tar.zst
freebsd-ports-gnome-684c18d813b511f175704935e160a5cdce095981.zip
The transmission-daemon is a daemon-based Transmission session that can
be controlled via IPC commands by transmission-remote (included). Transmission is a free, lightweight BitTorrent client. It features a simple, intuitive interface on top on an efficient, cross-platform back-end. WWW: http://www.transmissionbt.com/ -- I am getting more and more requests lately, some users want to use Clutch. The Clutch is using transmission-daemon to control the torrent by via web-based interface. http://clutchbt.com/ I have no interest in Clutch, so don't bother to ask me to create Clutch port. I do not really know anything about transmission-daemon, so test and report me bugs as usually.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/transmission-daemon/Makefile28
-rw-r--r--net-p2p/transmission-daemon/pkg-descr8
-rw-r--r--net-p2p/transmission-daemon/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 2262dba103f2..45c8f51e4821 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -119,6 +119,7 @@
SUBDIR += torrentvolve
SUBDIR += trackerbt
SUBDIR += transmission
+ SUBDIR += transmission-daemon
SUBDIR += transmission-gtk2
SUBDIR += tribler
SUBDIR += tvrss
diff --git a/net-p2p/transmission-daemon/Makefile b/net-p2p/transmission-daemon/Makefile
new file mode 100644
index 000000000000..ca6cb2834aea
--- /dev/null
+++ b/net-p2p/transmission-daemon/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: transmission-daemon
+# Date created: 08 February 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -daemon
+
+COMMENT= A free BitTorrent daemon written from scratch in C
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnometarget intlhack
+
+CUSTOM_SUBDIRS= third-party libtransmission daemon
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+MAN1= transmission-daemon.1 transmission-proxy.1 \
+ transmission-remote.1
+
+post-patch: general-patch
+
+post-install: general-install
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission-daemon/pkg-descr b/net-p2p/transmission-daemon/pkg-descr
new file mode 100644
index 000000000000..d5a056102d34
--- /dev/null
+++ b/net-p2p/transmission-daemon/pkg-descr
@@ -0,0 +1,8 @@
+The transmission-daemon is a daemon-based Transmission session that can
+be controlled via IPC commands by transmission-remote (included).
+
+Transmission is a free, lightweight BitTorrent client. It features a
+simple, intuitive interface on top on an efficient, cross-platform
+back-end.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission-daemon/pkg-plist b/net-p2p/transmission-daemon/pkg-plist
new file mode 100644
index 000000000000..007ea2ad1b6b
--- /dev/null
+++ b/net-p2p/transmission-daemon/pkg-plist
@@ -0,0 +1,8 @@
+bin/transmission-daemon
+bin/transmission-proxy
+bin/transmission-remote
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%