aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-15 20:35:56 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-15 20:35:56 +0800
commitae9c5aabc0c6b76683a43271e4ddf0e5722c5dd4 (patch)
treef60db570486be7b15dba2ca7795eedbd4061fffc /net-p2p
parent61b3ef9863d7d65d32424389a38cda54a218aaf2 (diff)
downloadfreebsd-ports-gnome-ae9c5aabc0c6b76683a43271e4ddf0e5722c5dd4.tar.gz
freebsd-ports-gnome-ae9c5aabc0c6b76683a43271e4ddf0e5722c5dd4.tar.zst
freebsd-ports-gnome-ae9c5aabc0c6b76683a43271e4ddf0e5722c5dd4.zip
Change header installation location for kdelibs4-based ports.
Install x11/kdelibs4's headers into include/kde4 instead of include (which consequently causes several other ports to have their installation paths changed too). The idea behind this is to reduce path conflicts between KDE4 ports and the upcoming KDE Frameworks 5 ports that will be installed into include/KF5. If we continue installing the KDE4 headers into include/, we can end up in a situation like this: c++ [...] -I/usr/local/include -I/usr/local/include/KF5 file.cpp If the KDE4 and KF5 versions of a port have the same headers, the KDE4 port will unintentionally be picked up first and the build will fail. Most of this huge patch is just PORTREVISION bumps, pkg-plist changes and a few patches to FooConfig.cmake files to make them look into the kde4/ subdirectory in include/. Changes which don't fit into the above are: - deskutils/kdepimlibs4: Import an upstream patch to remove some double semicolons that cause base GCC to fail. They have always been present, but since the faulty header was referenced via -isystem /usr/local/include this never caused any problems. - devel/subversion, devel/subversion18: Update patch-configure. The current kwallet changes there date back to 2011 (r272490), at a time when the build could fail when both KDE3 and KDE4 were installed. Replace those bits with a change I've submitted upstream to use the kde4-config program to determine where KDE4's headers and libraries are installed instead of assuming the headers are always in include/. Once again, huge thanks to Tobias Berner <tcberner@gmail.com> for being the first one to notice this problem when working on the KDE Frameworks 5 ports, coming up with the solution and bugging me until I had time to work on this and ask for the exp-run :-) PR: 207906 (exp-run)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libktorrent/Makefile2
-rw-r--r--net-p2p/libktorrent/pkg-plist370
2 files changed, 186 insertions, 186 deletions
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 4dd7072736d8..6877a7dbdcbd 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libktorrent
DISTVERSION= 1.3.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:C,^1,4,:C,-.*,,}/
diff --git a/net-p2p/libktorrent/pkg-plist b/net-p2p/libktorrent/pkg-plist
index 4164c1179f72..55a665fe7a65 100644
--- a/net-p2p/libktorrent/pkg-plist
+++ b/net-p2p/libktorrent/pkg-plist
@@ -1,188 +1,188 @@
-include/libktorrent/bcodec/bdecoder.h
-include/libktorrent/bcodec/bencoder.h
-include/libktorrent/bcodec/bnode.h
-include/libktorrent/bcodec/value.h
-include/libktorrent/datachecker/datachecker.h
-include/libktorrent/datachecker/datacheckerjob.h
-include/libktorrent/datachecker/datacheckerthread.h
-include/libktorrent/datachecker/multidatachecker.h
-include/libktorrent/datachecker/singledatachecker.h
-include/libktorrent/dht/announcereq.h
-include/libktorrent/dht/announcersp.h
-include/libktorrent/dht/announcetask.h
-include/libktorrent/dht/database.h
-include/libktorrent/dht/dht.h
-include/libktorrent/dht/dhtbase.h
-include/libktorrent/dht/dhtpeersource.h
-include/libktorrent/dht/findnodereq.h
-include/libktorrent/dht/findnodersp.h
-include/libktorrent/dht/getpeersreq.h
-include/libktorrent/dht/getpeersrsp.h
-include/libktorrent/dht/kbucket.h
-include/libktorrent/dht/kbucketentry.h
-include/libktorrent/dht/kbuckettable.h
-include/libktorrent/dht/kclosestnodessearch.h
-include/libktorrent/dht/key.h
-include/libktorrent/dht/node.h
-include/libktorrent/dht/nodelookup.h
-include/libktorrent/dht/pack.h
-include/libktorrent/dht/pingreq.h
-include/libktorrent/dht/pingrsp.h
-include/libktorrent/dht/rpccall.h
-include/libktorrent/dht/rpcmsg.h
-include/libktorrent/dht/rpcmsgfactory.h
-include/libktorrent/dht/rpcserver.h
-include/libktorrent/dht/rpcserverinterface.h
-include/libktorrent/dht/task.h
-include/libktorrent/dht/taskmanager.h
-include/libktorrent/diskio/cache.h
-include/libktorrent/diskio/cachefile.h
-include/libktorrent/diskio/chunk.h
-include/libktorrent/diskio/chunkmanager.h
-include/libktorrent/diskio/deletedatafilesjob.h
-include/libktorrent/diskio/dndfile.h
-include/libktorrent/diskio/movedatafilesjob.h
-include/libktorrent/diskio/multifilecache.h
-include/libktorrent/diskio/piecedata.h
-include/libktorrent/diskio/preallocationjob.h
-include/libktorrent/diskio/preallocationthread.h
-include/libktorrent/diskio/singlefilecache.h
-include/libktorrent/download/chunkdownload.h
-include/libktorrent/download/chunkselector.h
-include/libktorrent/download/downloader.h
-include/libktorrent/download/packet.h
-include/libktorrent/download/piece.h
-include/libktorrent/download/request.h
-include/libktorrent/download/webseed.h
-include/libktorrent/interfaces/blocklistinterface.h
-include/libktorrent/interfaces/cachefactory.h
-include/libktorrent/interfaces/chunkdownloadinterface.h
-include/libktorrent/interfaces/chunkselectorinterface.h
-include/libktorrent/interfaces/exitoperation.h
-include/libktorrent/interfaces/logmonitorinterface.h
-include/libktorrent/interfaces/monitorinterface.h
-include/libktorrent/interfaces/peerinterface.h
-include/libktorrent/interfaces/peersource.h
-include/libktorrent/interfaces/piecedownloader.h
-include/libktorrent/interfaces/queuemanagerinterface.h
-include/libktorrent/interfaces/serverinterface.h
-include/libktorrent/interfaces/torrentfileinterface.h
-include/libktorrent/interfaces/torrentinterface.h
-include/libktorrent/interfaces/trackerinterface.h
-include/libktorrent/interfaces/trackerslist.h
-include/libktorrent/interfaces/webseedinterface.h
-include/libktorrent/ktorrent_export.h
-include/libktorrent/magnet/magnetdownloader.h
-include/libktorrent/magnet/magnetlink.h
-include/libktorrent/magnet/metadatadownload.h
-include/libktorrent/migrate/cachemigrate.h
-include/libktorrent/migrate/ccmigrate.h
-include/libktorrent/migrate/migrate.h
-include/libktorrent/mse/bigint.h
-include/libktorrent/mse/encryptedauthenticate.h
-include/libktorrent/mse/encryptedpacketsocket.h
-include/libktorrent/mse/encryptedserverauthenticate.h
-include/libktorrent/mse/functions.h
-include/libktorrent/mse/rc4encryptor.h
-include/libktorrent/net/address.h
-include/libktorrent/net/addressresolver.h
-include/libktorrent/net/downloadthread.h
-include/libktorrent/net/networkthread.h
-include/libktorrent/net/packetsocket.h
-include/libktorrent/net/poll.h
-include/libktorrent/net/portlist.h
-include/libktorrent/net/reverseresolver.h
-include/libktorrent/net/serversocket.h
-include/libktorrent/net/socket.h
-include/libktorrent/net/socketdevice.h
-include/libktorrent/net/socketgroup.h
-include/libktorrent/net/socketmonitor.h
-include/libktorrent/net/socks.h
-include/libktorrent/net/speed.h
-include/libktorrent/net/streamsocket.h
-include/libktorrent/net/trafficshapedsocket.h
-include/libktorrent/net/uploadthread.h
-include/libktorrent/net/wakeuppipe.h
-include/libktorrent/peer/accessmanager.h
-include/libktorrent/peer/authenticate.h
-include/libktorrent/peer/authenticatebase.h
-include/libktorrent/peer/authenticationmonitor.h
-include/libktorrent/peer/chunkcounter.h
-include/libktorrent/peer/connectionlimit.h
-include/libktorrent/peer/packetreader.h
-include/libktorrent/peer/peer.h
-include/libktorrent/peer/peerconnector.h
-include/libktorrent/peer/peerdownloader.h
-include/libktorrent/peer/peerid.h
-include/libktorrent/peer/peermanager.h
-include/libktorrent/peer/peerprotocolextension.h
-include/libktorrent/peer/peeruploader.h
-include/libktorrent/peer/serverauthenticate.h
-include/libktorrent/peer/superseeder.h
-include/libktorrent/peer/utmetadata.h
-include/libktorrent/peer/utpex.h
-include/libktorrent/torrent/advancedchokealgorithm.h
-include/libktorrent/torrent/choker.h
-include/libktorrent/torrent/globals.h
-include/libktorrent/torrent/job.h
-include/libktorrent/torrent/jobqueue.h
-include/libktorrent/torrent/peersourcemanager.h
-include/libktorrent/torrent/server.h
-include/libktorrent/torrent/statsfile.h
-include/libktorrent/torrent/timeestimator.h
-include/libktorrent/torrent/torrent.h
-include/libktorrent/torrent/torrentcontrol.h
-include/libktorrent/torrent/torrentcreator.h
-include/libktorrent/torrent/torrentfile.h
-include/libktorrent/torrent/torrentfilestream.h
-include/libktorrent/torrent/torrentstats.h
-include/libktorrent/torrent/uploader.h
-include/libktorrent/tracker/httpannouncejob.h
-include/libktorrent/tracker/httptracker.h
-include/libktorrent/tracker/kioannouncejob.h
-include/libktorrent/tracker/tracker.h
-include/libktorrent/tracker/trackermanager.h
-include/libktorrent/tracker/udptracker.h
-include/libktorrent/tracker/udptrackersocket.h
-include/libktorrent/upnp/upnpmcastsocket.h
-include/libktorrent/upnp/upnprouter.h
-include/libktorrent/util/array.h
-include/libktorrent/util/autorotatelogjob.h
-include/libktorrent/util/bitset.h
-include/libktorrent/util/bufferpool.h
-include/libktorrent/util/circularbuffer.h
-include/libktorrent/util/compressfilejob.h
-include/libktorrent/util/constants.h
-include/libktorrent/util/decompressfilejob.h
-include/libktorrent/util/error.h
-include/libktorrent/util/extractfilejob.h
-include/libktorrent/util/file.h
-include/libktorrent/util/fileops.h
-include/libktorrent/util/functions.h
-include/libktorrent/util/log.h
-include/libktorrent/util/logsystemmanager.h
-include/libktorrent/util/pipe.h
-include/libktorrent/util/ptrmap.h
-include/libktorrent/util/resourcemanager.h
-include/libktorrent/util/sha1hash.h
-include/libktorrent/util/sha1hashgen.h
-include/libktorrent/util/signalcatcher.h
-include/libktorrent/util/timer.h
-include/libktorrent/util/urlencoder.h
-include/libktorrent/util/waitjob.h
-include/libktorrent/util/win32.h
-include/libktorrent/utp/connection.h
-include/libktorrent/utp/delaywindow.h
-include/libktorrent/utp/localwindow.h
-include/libktorrent/utp/packetbuffer.h
-include/libktorrent/utp/pollpipe.h
-include/libktorrent/utp/remotewindow.h
-include/libktorrent/utp/timevalue.h
-include/libktorrent/utp/utpprotocol.h
-include/libktorrent/utp/utpserver.h
-include/libktorrent/utp/utpserverthread.h
-include/libktorrent/utp/utpsocket.h
-include/libktorrent/version.h
+include/kde4/libktorrent/bcodec/bdecoder.h
+include/kde4/libktorrent/bcodec/bencoder.h
+include/kde4/libktorrent/bcodec/bnode.h
+include/kde4/libktorrent/bcodec/value.h
+include/kde4/libktorrent/datachecker/datachecker.h
+include/kde4/libktorrent/datachecker/datacheckerjob.h
+include/kde4/libktorrent/datachecker/datacheckerthread.h
+include/kde4/libktorrent/datachecker/multidatachecker.h
+include/kde4/libktorrent/datachecker/singledatachecker.h
+include/kde4/libktorrent/dht/announcereq.h
+include/kde4/libktorrent/dht/announcersp.h
+include/kde4/libktorrent/dht/announcetask.h
+include/kde4/libktorrent/dht/database.h
+include/kde4/libktorrent/dht/dht.h
+include/kde4/libktorrent/dht/dhtbase.h
+include/kde4/libktorrent/dht/dhtpeersource.h
+include/kde4/libktorrent/dht/findnodereq.h
+include/kde4/libktorrent/dht/findnodersp.h
+include/kde4/libktorrent/dht/getpeersreq.h
+include/kde4/libktorrent/dht/getpeersrsp.h
+include/kde4/libktorrent/dht/kbucket.h
+include/kde4/libktorrent/dht/kbucketentry.h
+include/kde4/libktorrent/dht/kbuckettable.h
+include/kde4/libktorrent/dht/kclosestnodessearch.h
+include/kde4/libktorrent/dht/key.h
+include/kde4/libktorrent/dht/node.h
+include/kde4/libktorrent/dht/nodelookup.h
+include/kde4/libktorrent/dht/pack.h
+include/kde4/libktorrent/dht/pingreq.h
+include/kde4/libktorrent/dht/pingrsp.h
+include/kde4/libktorrent/dht/rpccall.h
+include/kde4/libktorrent/dht/rpcmsg.h
+include/kde4/libktorrent/dht/rpcmsgfactory.h
+include/kde4/libktorrent/dht/rpcserver.h
+include/kde4/libktorrent/dht/rpcserverinterface.h
+include/kde4/libktorrent/dht/task.h
+include/kde4/libktorrent/dht/taskmanager.h
+include/kde4/libktorrent/diskio/cache.h
+include/kde4/libktorrent/diskio/cachefile.h
+include/kde4/libktorrent/diskio/chunk.h
+include/kde4/libktorrent/diskio/chunkmanager.h
+include/kde4/libktorrent/diskio/deletedatafilesjob.h
+include/kde4/libktorrent/diskio/dndfile.h
+include/kde4/libktorrent/diskio/movedatafilesjob.h
+include/kde4/libktorrent/diskio/multifilecache.h
+include/kde4/libktorrent/diskio/piecedata.h
+include/kde4/libktorrent/diskio/preallocationjob.h
+include/kde4/libktorrent/diskio/preallocationthread.h
+include/kde4/libktorrent/diskio/singlefilecache.h
+include/kde4/libktorrent/download/chunkdownload.h
+include/kde4/libktorrent/download/chunkselector.h
+include/kde4/libktorrent/download/downloader.h
+include/kde4/libktorrent/download/packet.h
+include/kde4/libktorrent/download/piece.h
+include/kde4/libktorrent/download/request.h
+include/kde4/libktorrent/download/webseed.h
+include/kde4/libktorrent/interfaces/blocklistinterface.h
+include/kde4/libktorrent/interfaces/cachefactory.h
+include/kde4/libktorrent/interfaces/chunkdownloadinterface.h
+include/kde4/libktorrent/interfaces/chunkselectorinterface.h
+include/kde4/libktorrent/interfaces/exitoperation.h
+include/kde4/libktorrent/interfaces/logmonitorinterface.h
+include/kde4/libktorrent/interfaces/monitorinterface.h
+include/kde4/libktorrent/interfaces/peerinterface.h
+include/kde4/libktorrent/interfaces/peersource.h
+include/kde4/libktorrent/interfaces/piecedownloader.h
+include/kde4/libktorrent/interfaces/queuemanagerinterface.h
+include/kde4/libktorrent/interfaces/serverinterface.h
+include/kde4/libktorrent/interfaces/torrentfileinterface.h
+include/kde4/libktorrent/interfaces/torrentinterface.h
+include/kde4/libktorrent/interfaces/trackerinterface.h
+include/kde4/libktorrent/interfaces/trackerslist.h
+include/kde4/libktorrent/interfaces/webseedinterface.h
+include/kde4/libktorrent/ktorrent_export.h
+include/kde4/libktorrent/magnet/magnetdownloader.h
+include/kde4/libktorrent/magnet/magnetlink.h
+include/kde4/libktorrent/magnet/metadatadownload.h
+include/kde4/libktorrent/migrate/cachemigrate.h
+include/kde4/libktorrent/migrate/ccmigrate.h
+include/kde4/libktorrent/migrate/migrate.h
+include/kde4/libktorrent/mse/bigint.h
+include/kde4/libktorrent/mse/encryptedauthenticate.h
+include/kde4/libktorrent/mse/encryptedpacketsocket.h
+include/kde4/libktorrent/mse/encryptedserverauthenticate.h
+include/kde4/libktorrent/mse/functions.h
+include/kde4/libktorrent/mse/rc4encryptor.h
+include/kde4/libktorrent/net/address.h
+include/kde4/libktorrent/net/addressresolver.h
+include/kde4/libktorrent/net/downloadthread.h
+include/kde4/libktorrent/net/networkthread.h
+include/kde4/libktorrent/net/packetsocket.h
+include/kde4/libktorrent/net/poll.h
+include/kde4/libktorrent/net/portlist.h
+include/kde4/libktorrent/net/reverseresolver.h
+include/kde4/libktorrent/net/serversocket.h
+include/kde4/libktorrent/net/socket.h
+include/kde4/libktorrent/net/socketdevice.h
+include/kde4/libktorrent/net/socketgroup.h
+include/kde4/libktorrent/net/socketmonitor.h
+include/kde4/libktorrent/net/socks.h
+include/kde4/libktorrent/net/speed.h
+include/kde4/libktorrent/net/streamsocket.h
+include/kde4/libktorrent/net/trafficshapedsocket.h
+include/kde4/libktorrent/net/uploadthread.h
+include/kde4/libktorrent/net/wakeuppipe.h
+include/kde4/libktorrent/peer/accessmanager.h
+include/kde4/libktorrent/peer/authenticate.h
+include/kde4/libktorrent/peer/authenticatebase.h
+include/kde4/libktorrent/peer/authenticationmonitor.h
+include/kde4/libktorrent/peer/chunkcounter.h
+include/kde4/libktorrent/peer/connectionlimit.h
+include/kde4/libktorrent/peer/packetreader.h
+include/kde4/libktorrent/peer/peer.h
+include/kde4/libktorrent/peer/peerconnector.h
+include/kde4/libktorrent/peer/peerdownloader.h
+include/kde4/libktorrent/peer/peerid.h
+include/kde4/libktorrent/peer/peermanager.h
+include/kde4/libktorrent/peer/peerprotocolextension.h
+include/kde4/libktorrent/peer/peeruploader.h
+include/kde4/libktorrent/peer/serverauthenticate.h
+include/kde4/libktorrent/peer/superseeder.h
+include/kde4/libktorrent/peer/utmetadata.h
+include/kde4/libktorrent/peer/utpex.h
+include/kde4/libktorrent/torrent/advancedchokealgorithm.h
+include/kde4/libktorrent/torrent/choker.h
+include/kde4/libktorrent/torrent/globals.h
+include/kde4/libktorrent/torrent/job.h
+include/kde4/libktorrent/torrent/jobqueue.h
+include/kde4/libktorrent/torrent/peersourcemanager.h
+include/kde4/libktorrent/torrent/server.h
+include/kde4/libktorrent/torrent/statsfile.h
+include/kde4/libktorrent/torrent/timeestimator.h
+include/kde4/libktorrent/torrent/torrent.h
+include/kde4/libktorrent/torrent/torrentcontrol.h
+include/kde4/libktorrent/torrent/torrentcreator.h
+include/kde4/libktorrent/torrent/torrentfile.h
+include/kde4/libktorrent/torrent/torrentfilestream.h
+include/kde4/libktorrent/torrent/torrentstats.h
+include/kde4/libktorrent/torrent/uploader.h
+include/kde4/libktorrent/tracker/httpannouncejob.h
+include/kde4/libktorrent/tracker/httptracker.h
+include/kde4/libktorrent/tracker/kioannouncejob.h
+include/kde4/libktorrent/tracker/tracker.h
+include/kde4/libktorrent/tracker/trackermanager.h
+include/kde4/libktorrent/tracker/udptracker.h
+include/kde4/libktorrent/tracker/udptrackersocket.h
+include/kde4/libktorrent/upnp/upnpmcastsocket.h
+include/kde4/libktorrent/upnp/upnprouter.h
+include/kde4/libktorrent/util/array.h
+include/kde4/libktorrent/util/autorotatelogjob.h
+include/kde4/libktorrent/util/bitset.h
+include/kde4/libktorrent/util/bufferpool.h
+include/kde4/libktorrent/util/circularbuffer.h
+include/kde4/libktorrent/util/compressfilejob.h
+include/kde4/libktorrent/util/constants.h
+include/kde4/libktorrent/util/decompressfilejob.h
+include/kde4/libktorrent/util/error.h
+include/kde4/libktorrent/util/extractfilejob.h
+include/kde4/libktorrent/util/file.h
+include/kde4/libktorrent/util/fileops.h
+include/kde4/libktorrent/util/functions.h
+include/kde4/libktorrent/util/log.h
+include/kde4/libktorrent/util/logsystemmanager.h
+include/kde4/libktorrent/util/pipe.h
+include/kde4/libktorrent/util/ptrmap.h
+include/kde4/libktorrent/util/resourcemanager.h
+include/kde4/libktorrent/util/sha1hash.h
+include/kde4/libktorrent/util/sha1hashgen.h
+include/kde4/libktorrent/util/signalcatcher.h
+include/kde4/libktorrent/util/timer.h
+include/kde4/libktorrent/util/urlencoder.h
+include/kde4/libktorrent/util/waitjob.h
+include/kde4/libktorrent/util/win32.h
+include/kde4/libktorrent/utp/connection.h
+include/kde4/libktorrent/utp/delaywindow.h
+include/kde4/libktorrent/utp/localwindow.h
+include/kde4/libktorrent/utp/packetbuffer.h
+include/kde4/libktorrent/utp/pollpipe.h
+include/kde4/libktorrent/utp/remotewindow.h
+include/kde4/libktorrent/utp/timevalue.h
+include/kde4/libktorrent/utp/utpprotocol.h
+include/kde4/libktorrent/utp/utpserver.h
+include/kde4/libktorrent/utp/utpserverthread.h
+include/kde4/libktorrent/utp/utpsocket.h
+include/kde4/libktorrent/version.h
lib/libktorrent.so
lib/libktorrent.so.%%SHLIB_VER%%
lib/libktorrent.so.%%SHLIB_SHVER%%