aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-08-31 08:13:25 +0800
committermarcus <marcus@FreeBSD.org>2002-08-31 08:13:25 +0800
commitc09dc513f70813fd1915b12787ca0e934c4e4f5d (patch)
treed861acef1f689743981e09642f332436fdd4994a /net-p2p
parent0854f152efed3fca29e6e1cf16edae3f9fe70059 (diff)
downloadfreebsd-ports-gnome-c09dc513f70813fd1915b12787ca0e934c4e4f5d.tar.gz
freebsd-ports-gnome-c09dc513f70813fd1915b12787ca0e934c4e4f5d.tar.zst
freebsd-ports-gnome-c09dc513f70813fd1915b12787ca0e934c4e4f5d.zip
Use USE_GNOMENG.
PR: 42232 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/lopster/Makefile3
-rw-r--r--net-p2p/teknap/Makefile10
2 files changed, 8 insertions, 5 deletions
diff --git a/net-p2p/lopster/Makefile b/net-p2p/lopster/Makefile
index 19d9e68a91fa..37eb4a6d2c0b 100644
--- a/net-p2p/lopster/Makefile
+++ b/net-p2p/lopster/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_X_PREFIX= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net-p2p/teknap/Makefile b/net-p2p/teknap/Makefile
index 457360e1ed83..c29c2e6c7ff0 100644
--- a/net-p2p/teknap/Makefile
+++ b/net-p2p/teknap/Makefile
@@ -8,7 +8,7 @@
PORTNAME= TekNap
PORTVERSION= 1.2
CATEGORIES= audio
-MASTER_SITES= ftp://ukug.uk.freebsd.org/pub/lord_cj/
+MASTER_SITES= ftp://ukug.uk.freebsd.org/pub/lord_cj/
MAINTAINER= calle.madestrand@norrgarden.se
@@ -24,16 +24,18 @@ WRKSRC= ${WRKDIR}/TekNap
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
USE_GMAKE= yes
-WANT_GTK= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if defined(HAVE_GTK)
-USE_GTK= yes
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
CONFIGURE_ARGS+=--with-gtk
+PKGNAMESUFFIX= -gtk
.else
CONFIGURE_ARGS+=--without-gtk
.endif