aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-11-05 07:55:30 +0800
committerlioux <lioux@FreeBSD.org>2002-11-05 07:55:30 +0800
commit4c7926365ef3adce4f4c4e4a7a9f3f544c713c1d (patch)
tree1211b7dd2efddc758a2c85d0f14dec2b24f2fc15 /net-p2p
parent6f5a0506d2c5e9be57dde1b6836919f3fe659b9a (diff)
downloadfreebsd-ports-gnome-4c7926365ef3adce4f4c4e4a7a9f3f544c713c1d.tar.gz
freebsd-ports-gnome-4c7926365ef3adce4f4c4e4a7a9f3f544c713c1d.tar.zst
freebsd-ports-gnome-4c7926365ef3adce4f4c4e4a7a9f3f544c713c1d.zip
Fix regexp and patches to work with recently added USE_REINPLACE
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/edonkey-tool-slist/Makefile4
-rw-r--r--net-p2p/edonkey-tool-slist/files/patch-linux_net.c10
2 files changed, 11 insertions, 3 deletions
diff --git a/net-p2p/edonkey-tool-slist/Makefile b/net-p2p/edonkey-tool-slist/Makefile
index 6b80b296f552..c02e03712821 100644
--- a/net-p2p/edonkey-tool-slist/Makefile
+++ b/net-p2p/edonkey-tool-slist/Makefile
@@ -18,9 +18,7 @@ WRKSRC= ${WRKDIR}/ed2k_slist
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|\r\n|\n|' ${WRKSRC}/*.[ch]
- @${REINPLACE_CMD} -e 's|(#include <unistd.h>)|\1\n#include\
- <sys/time.h>|' ${WRKSRC}/linux_net.c
+ @${REINPLACE_CMD} -e 's| ||' ${WRKSRC}/*.[ch]
# I could have written a Makefile but I would rather
# not waste inodes
diff --git a/net-p2p/edonkey-tool-slist/files/patch-linux_net.c b/net-p2p/edonkey-tool-slist/files/patch-linux_net.c
new file mode 100644
index 000000000000..f1280c9c1e97
--- /dev/null
+++ b/net-p2p/edonkey-tool-slist/files/patch-linux_net.c
@@ -0,0 +1,10 @@
+--- linux_net.c.orig Mon Nov 4 21:50:07 2002
++++ linux_net.c Mon Nov 4 21:50:15 2002
+@@ -27,6 +27,7 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <sys/time.h>
+
+ /* connect with timeout
+ *