aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-02 00:20:47 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-02 00:20:47 +0800
commit5c458795d4b6715d3f8c294294994064e024a0fd (patch)
tree48fdd1f0d0902abb3a399e525fb6d85182e9d9ab /net-p2p
parent252b575fc1cba42e27e6b67c644ea9e61fa2565e (diff)
downloadfreebsd-ports-gnome-5c458795d4b6715d3f8c294294994064e024a0fd.tar.gz
freebsd-ports-gnome-5c458795d4b6715d3f8c294294994064e024a0fd.tar.zst
freebsd-ports-gnome-5c458795d4b6715d3f8c294294994064e024a0fd.zip
- Switch to options helpers
- While here, add some NO_ARCHes Approved by: portmgr blanket
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ctorrent/Makefile6
-rw-r--r--net-p2p/qbittorrent/Makefile9
-rw-r--r--net-p2p/twister/Makefile4
3 files changed, 7 insertions, 12 deletions
diff --git a/net-p2p/ctorrent/Makefile b/net-p2p/ctorrent/Makefile
index 566f2e16378f..39bef6f85436 100644
--- a/net-p2p/ctorrent/Makefile
+++ b/net-p2p/ctorrent/Makefile
@@ -18,14 +18,10 @@ PORTDOCS= README-DNH.TXT UserGuide
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index ab61a56a5394..38e0faa0e91e 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -58,11 +58,6 @@ CONFIGURE_ARGS+= --disable-gui
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
-
.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "no"
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent
${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent.1 \
@@ -74,4 +69,8 @@ post-install:
.endif
@${RM} -rf ${STAGEDIR}${PREFIX}/share/man
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index 91533697c21d..b09bb75488a4 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -59,9 +59,9 @@ pre-configure:
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/twisterd ${STAGEDIR}${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>