aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-25 00:29:51 +0800
committermva <mva@FreeBSD.org>2014-10-25 00:29:51 +0800
commit9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22 (patch)
tree68b40f3f4036b306637ebfb7679083aa441086a8 /net-p2p
parent7cb20804acb2b46d4c0c3489dd746591f311f6de (diff)
downloadfreebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.tar.gz
freebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.tar.zst
freebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.zip
- Convert ports of net-im/, net-mgmt/ and net-p2p/ to new USES=python
Approved by: portmgr (implicit)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitmessage/Makefile2
-rw-r--r--net-p2p/btqueue/Makefile4
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile4
-rw-r--r--net-p2p/py-kenosis/Makefile5
-rw-r--r--net-p2p/py-py2play/Makefile4
-rw-r--r--net-p2p/py-vertex/Makefile6
6 files changed, 11 insertions, 14 deletions
diff --git a/net-p2p/bitmessage/Makefile b/net-p2p/bitmessage/Makefile
index d24293b52a0b..927042cafd61 100644
--- a/net-p2p/bitmessage/Makefile
+++ b/net-p2p/bitmessage/Makefile
@@ -22,8 +22,8 @@ GH_PROJECT= PyBitmessage
GH_COMMIT= ab49373
GH_TAGNAME= v${PORTVERSION}
+USES= python
USE_OPENSSL= yes
-USE_PYTHON= yes
INSTALLS_ICONS= yes
post-patch:
diff --git a/net-p2p/btqueue/Makefile b/net-p2p/btqueue/Makefile
index 5d681f71b65c..35f7abb115a0 100644
--- a/net-p2p/btqueue/Makefile
+++ b/net-p2p/btqueue/Makefile
@@ -14,8 +14,8 @@ COMMENT= Alternative BitTorrent client with queuing functionality
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb
CONFLICTS= py??-*[Bb]it[Tt]ornado* py??-*[Bb]it[Tt]orrent*
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= BTQueue
DATADIR= ${PREFIX}/share/BTQueue
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
index bd8edc7a22c9..517502a93e6d 100644
--- a/net-p2p/libtorrent-rasterbar-python/Makefile
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -15,8 +15,8 @@ BUILD_WRKSRC= ${WRKSRC}/bindings/python
INSTALL_WRKSRC= ${BUILD_WRKSRC}
SLAVE_PORT= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= python_libtorrent
PLIST= ${NONEXISTENT}
diff --git a/net-p2p/py-kenosis/Makefile b/net-p2p/py-kenosis/Makefile
index 79934b8f22cb..75724bad94ad 100644
--- a/net-p2p/py-kenosis/Makefile
+++ b/net-p2p/py-kenosis/Makefile
@@ -15,9 +15,8 @@ LICENSE= MIT
RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/xmlrpclib.py:${PORTSDIR}/net/py-xmlrpclib
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PYSETUP= ${PORTNAME}_setup.py
PORTSCOUT= skipv:0.941 # Older version than the current one
diff --git a/net-p2p/py-py2play/Makefile b/net-p2p/py-py2play/Makefile
index e63f57418d41..63ea79c53422 100644
--- a/net-p2p/py-py2play/Makefile
+++ b/net-p2p/py-py2play/Makefile
@@ -15,8 +15,8 @@ COMMENT= Peer-to-peer network game engine
LICENSE= GPLv2
DIST_SUBDIR= python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= Py2Play
EXAMPLESDIR= ${PREFIX}/share/examples/py-py2play
diff --git a/net-p2p/py-vertex/Makefile b/net-p2p/py-vertex/Makefile
index 6499fbb6bf91..5ed40403a123 100644
--- a/net-p2p/py-vertex/Makefile
+++ b/net-p2p/py-vertex/Makefile
@@ -18,9 +18,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsil
LICENSE= BSD
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= twisted
+USES= python twisted
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>